Archived

This topic is now archived and is closed to further replies.

  • 0

CatLoop Catloop

Question

Posted · Report post

hello, i created that same topic in pl forum - but danny told me to place it on the store forum with prefix catloop - so here we go again:

 

i use font awesome icon font on my new page and it works well (under
dev.). but i can't manage to get icon fonts to work within the text area
of post excerpts (together with PL catloop plugin) - they simply won't
show up. within post and pages and even in the footer nav i use font
awesome without any problem.

 

HTML for icon font is:

<i class="icon-external-link"></i>

example: from a static page with catloop category post excerpts (no
icon font visible) - i click on read more - and now - within the post
the icon font is visible. i think the catloop plugin causes the problem
any ideas ?

 

Edit: Sometimes the TinyMCE erases the HTML for icon font - when you switch to html mode and back! 

Share this post


Link to post
Share on other sites

6 answers to this question

Posted · Report post

Hi there,

 

To make the font icons visible in excerpts, please go to Pagelines > Site Options > Blog and Posts.

Scroll all the way at the bottom and in the Allow Tags in Excerpt  enter <i>.

Your font icons should now display correctly in CatLoop as well as regular PageLines post excerpts.

 

To avoid your HTML being erase by TinyMCE just put a space in the middle of it:

<i class="icon-external-link"> </i>

It should stop erasing the HTML. Or you could use shortcodes instead. It escapes me now what the shortcode format is, since I always used the HTML tags, as well.

 

Good luck!

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there,

 

Please go to: http://catloop.anthalis.info/customising-catloop/ and find instructions there. Note that multiple CatLoops in a page work well only if:

1) you have an equal total number of post for each category

or 2) you don't enable pagination for CatLoop of any kind (categories with fewer posts than the rest will generate a 404 error when they reach the end of posts).

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Anthalis, works perfect - thank you. And it actualy had nothing to do with the catloop section :)

Share this post


Link to post
Share on other sites

Posted · Report post

Hi I had a question about the CatLoop. I purchased the plugin but There is no option to clone it. I was wondering if there was a way to clone the CatLoop because I want my post categories seperated on the same page.

Share this post


Link to post
Share on other sites

Posted · Report post

Yeah, well :) it happens.

 

Glad it worked though.

1 person likes this

Share this post


Link to post
Share on other sites