Jump to content


Photo
- - - - -

Background Colour Not Showing


  • Please log in to reply
21 replies to this topic

#1 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 07 February 2013 - 10:32 PM

Hi,

 

I have just had this error reported for people viewing www.rdspartners.com.au on  IE Version 9. The colour associated with the body colour is not showing so the text is appearing on the background image and is unreadable and totally changes the look of the website. I have attached a screenshot of the issue, this error is occuring across the website. The page should in fact look like this

Please Login or Register to see this Hidden Content

How can I get this resolved as I have many of my websites set up with this layout.

 

Many thanks

 

Lynsey

Attached Files



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 07 February 2013 - 11:52 PM

Hi Lynsey,

 

Very nice site!  I'm presuming you created a layer for the text area background color but how did you do this?

 

I'm seeing the color set to the body, which is a higher level in hierarchy than, for example, the page-canvas.

 

Likely what's happening here is that Firefox and Chrome are being more tolerant of the CSS than IE is, and thus IE is not showing the background color for the page canvas (text area) and likely is calling the body background color behind the background image.

 

In fact, when I remove the background image, I see the baby blue everywhere and only a grey frame around the text.

 

Your code for the baby blue seems to be found here:

body, body.fixed_width {
    background-color#C5E7FA;
}
 
Is this the only place you added that color?


 



#3 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 12:24 AM

Hi One Smart Egg - thanks re the nice site :)

 

The only place I included the colour was via the site options colour Control Section. I haven't set it on a page by page basis. Does that help at all?



#4 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 12:59 AM

OK the person who had the issue updated their version of IE and now works fine, but on computer that was not updated still not working - same on their home computer Asked them to test another one my sites built with the same layout options and the site scrambled and no light green background showing. This was the other site I asked them to test 

Please Login or Register to see this Hidden Content



#5 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 February 2013 - 02:19 AM

When you were using the settings at Site Options > Color Control, did you place that color only under the Body option or did you test it in others, such as Content or Page?



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 February 2013 - 02:23 AM

The Sea Shanti site looks perfectly fine in IE9 on my computer.


  • progressive01 likes this

#7 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 04:47 AM

Hi,

 

Thanks for helping. Re the Site Options. Colour Control I have simply set the colour. I haven't changed the location of where this is placed.



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 February 2013 - 05:00 AM

Hi,

 

I was hoping you could add the same colour as shown in the attached photo:

 

Attached Files



#9 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 05:09 AM

Yep done that - now the blue showing as white - should I try the blue colour where the #ffffff is?



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 February 2013 - 05:13 AM

Yes.



#11 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 05:16 AM

Problem with that is my header images are now all on a white background rather than blue



#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 February 2013 - 05:19 AM

Did you leave #ffffff in there, anywhere?

 

My note in the image was to place your color in two places. Including the place where I have #ffffff



#13 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 February 2013 - 05:20 AM

Please snapshot your screen so that I may see what you're doing.   Thanks!



#14 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 05:35 AM

How do I attach a screen shot at this stage of the forum



#15 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 05:37 AM

Screen-Shot-2013-02-08-at-4.34.18-PM.png

 

worked it out :)



#16 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 05:38 AM

here is the backend

 

Screen-Shot-2013-02-08-at-4.34.25-PM.png



#17 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 February 2013 - 05:38 AM

When you reply, look down, to the right and click the "More Reply Options" button.

 

At the bottom of the editing screen you'll see an area to upload attachments.  Click that button, the same way you did it with the opening topic.



#18 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 05:41 AM

ahh sorry I now see I should have kept the colour in the content background (optional)

 

Is it now working for you in IE?



#19 progressive01

progressive01

    Advanced Member

  • Members

  • 79 posts

Posted 08 February 2013 - 05:43 AM

When you reply, look down, to the right and click the "More Reply Options" button.

 

At the bottom of the editing screen you'll see an area to upload attachments.  Click that button, the same way you did it with the opening topic.

Thank you that is very helpful



#20 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 February 2013 - 05:48 AM

Somehow your site generated this:

Please Login or Register to see this Hidden Content

In some level of custom code.

 

Change it to:

Please Login or Register to see this Hidden Content

 

Try putting #C5E7FA in all three of the color field options.

 

Also, check your plugins by deactivating everything other than Akismet and plugins you found in our Store.