Jump to content


Photo
- - - - -

font-awesome and ie8

fontawesome font-awesome ie8 internet explorer 8

  • Please log in to reply
14 replies to this topic

#1 kracker

kracker

    Advanced Member

  • Members

  • 41 posts
  • Country: Country Flag

Posted 06 February 2013 - 04:57 PM

Is there a fix for font-awesome not rendering in ie8? I've tried the shiv, so I am at a total loss. It's such a waist if we can't use it =\ renders in 9 perfectly.

Attached Files



#2 mackenzie

mackenzie

    Advocate

  • Members
  • 333 posts
  • Country: Country Flag

Posted 06 February 2013 - 06:21 PM

Unfortunately as new browsers become available some things will not work in the older versions and that is what this appears to be happening. Can you confirm whether you are noticing any problems in current FireFox, Chrome, etc?



#3 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 06 February 2013 - 06:26 PM

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

 

Lots of people with the same issue if you google 'fontawesome ie8'



#4 kracker

kracker

    Advanced Member

  • Members

  • 41 posts
  • Country: Country Flag

Posted 06 February 2013 - 08:05 PM

Simon, I've noticed you guys have made it work on pagelines.com running ie8 which was not displaying properly a month or so ago - I've been in the google loop for a week now - I thought this was out of the box? Pagelines I mean. I tried the shiv in the footer </body> and the top of the <head> and both at the same time. The only thing I haven't done is dug into pl code, is that where we're left?

 

Mackenzie 2325 readers were affected yesterday alone. With 2.9mm readers, we can't ignore ie8.

 

Could some write a tutorial or something of the most reasonable course of action? lol



#5 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 06 February 2013 - 08:24 PM

Perhaps give us a clue where this site is and where the icons are supposed to be?



#6 kracker

kracker

    Advanced Member

  • Members

  • 41 posts
  • Country: Country Flag

Posted 06 February 2013 - 08:58 PM

I see my site below my name, pl forced us to put it there. I'd prefer my site not be listed on pl. 



#7 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 06 February 2013 - 09:07 PM

OK i see the site, but where is the icon?



#8 kracker

kracker

    Advanced Member

  • Members

  • 41 posts
  • Country: Country Flag

Posted 06 February 2013 - 09:20 PM

here are the two prominent places - and thanks for looking

 

the attachment is of the home page, top news more in category, and Today's story timeline . We're using it mildly throughout the site for now till we can get ie8 worked out.

Attached Files



#9 kracker

kracker

    Advanced Member

  • Members

  • 41 posts
  • Country: Country Flag

Posted 06 February 2013 - 09:22 PM

This is the same section in ie8

Attached Files



#10 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 06 February 2013 - 09:41 PM

Looks fine to me, what are you testing it with? 

Please Login or Register to see this Hidden Content



#11 kracker

kracker

    Advanced Member

  • Members

  • 41 posts
  • Country: Country Flag

Posted 06 February 2013 - 10:02 PM

I run explorer 9 and under settings under F12 developer tools you can select ie7 ie8 and run in those instances.



#12 kracker

kracker

    Advanced Member

  • Members

  • 41 posts
  • Country: Country Flag

Posted 06 February 2013 - 10:04 PM

god I hate ie and I hate chasing ghosts I'm going get an xp laptop running ie8 and look for myself - I'll circle back



#13 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 06 February 2013 - 11:30 PM

Keep us posted.



#14 trebord_55

trebord_55

    Member

  • Members
  • 17 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 03 March 2013 - 11:08 PM

kracker: I discovered I was having the same problem: font-awesome icons not appearing in IE8. Endless frustration . . . until a performance test at webpagetest.org revealed a "403 Forbidden" error when IE8 attempted to access .../wp-content/themes/pagelines/fonts/fontawesome-webfont.eot. The culprit (in my case) turned out to be the root folder .htaccess edits that my BPS Security plugin had implemented. Disabled "Bulletproof Mode" for the root folder and IE8 was able to successfully access the font file, making my icons visible again.

 

Moral of the story (even if you're not using BPS Security): could be a 403 / .htaccess issue.

 

Hope this helps.



#15 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 04 March 2013 - 10:00 PM

Thanks Trebord for adding to this input. 

 

While the bulk of PageLines is accessible by, and viewable in IE8, there are some things which just have compatibility issues. Keeping in mind that IE8 predates HTML5 and CSS3, this should come as no surprise to anyone.  As Simon pointed out, fontawesome and IE8 are having issues, and that's not a PL issue, so I'd agree with you, that this could be something outside PL Framework.







Also tagged with one or more of these keywords: fontawesome, font-awesome, ie8, internet explorer 8