Archived

This topic is now archived and is closed to further replies.

Excerpts in iBlogPro3

3 posts in this topic

Posted · Report post

I am struggling a bit with excerpts. I've tried various combinations in Options but can't quite get what I want. I need the blog home page to show only excerpts, not full posts. So far, so good. I don't want the excerpt to show on the individual post page, but I DO want the thumb image to appear. If I turn off excerpts for the page, the image does not display. If I disable excerpts completely, the image actually still displays on the home page and individual page, but there is no text excerpt. A related issue is a post which includes a cform displays the field names in the excerpt - not really acceptable - http://www.songofsolomonstudy.com/category/dumb-lines/. It would also be nice to be able to have excerpts for pages, although that is secondary right now. I've researched plugins for all of the above but haven't found a solution. Any ideas or advice is welcome. Thanks, David http://www.songofsolomonstudy.com/study/

Share this post


Link to post
Share on other sites

Posted · Report post

Well if you know a little html/php all you need to do is edit the `_posts.php` file... Where things show up is controlled by the `if(is_single())` or `if(is_home())` type calls.

A related issue is a post which includes a cform displays the field names in the excerpt - not really acceptable - http://www.songofsolomonstudy.com/category/dumb-lines/.
In this case you want to manually set an excerpt; could be a ' ' (space) or whatever, but will prevent WP from setting it for you.

Share this post


Link to post
Share on other sites

Posted · Report post

Well if you know a little html/php all you need to do is edit the _posts.php file... Where things show up is controlled by the if(is_single()) or if(is_home()) type calls.
I'll take a look at that.
In this case you want to manually set an excerpt; could be a ' ' (space) or whatever, but will prevent WP from setting it for you.
Darn it, I meant to try that before I posted. It works, of course. Thanks Andrew.

Share this post


Link to post
Share on other sites