Archived

This topic is now archived and is closed to further replies.

  • 0

Static and or responsive

Question

Posted · Report post

Hi!

 

How come two sites with the exact same settings behaves different? In the layout option I have

set to static with pixel width and full width section. Yet one site is responsive and the other one is not?

 

The site is http://pehjaproduktion.se and http://peterhjalmarsson.se

 

I want it to be static but no matter what I set it looks the same.

 

Thanks for any input in this!

Peter

 

Share this post


Link to post
Share on other sites

14 answers to this question

Posted · Report post

Ok it was so simple just added .ipad before the code. And now it looks great on both iPad and all other browsers  :D

Share this post


Link to post
Share on other sites

Posted · Report post

What slider are you talking about

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Peter,

 

If both sites are using the same layout settings, the same version of PageLines/Wordpress but are behaving differently in terms of layout, then the issue is caused by one of the following:

 

You're using different plugins, which is the cause of the issue or you have custom code that is different and is the cause of the issue.

 

Also, make sure that both sites have the same option for Mobile Optimisation disabled.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Danny!

 

They have the same settings and mobile view is the same. That is OFF. Could you tell me which site is correct, corresponding to the settings I have. At least then I would know where to start looking.

Share this post


Link to post
Share on other sites

Posted · Report post

The slider is Layerslider. So Danny I have installed the browser specificik CSS and I want to target this for iPad and iPhone

 

 

#site .content, #footer .content {
    width: auto !important;
}
 
What would I paste in custom CSS to make it hapen ?
 
Do i just ad .iPad befote the code ??

Share this post


Link to post
Share on other sites

Posted · Report post

Can you provide all the settings related to your layout so I can see for myself.

 

Also, have you disabled all non-PageLines sections and removed all custom code added on both sites?

 

Do this and see if they still behave differently.

Share this post


Link to post
Share on other sites

Posted · Report post

No I have not. But if you can just go into the sites i stated above and drag one side to minimize to the left. I know that there are plugins that can cause the sites to behave differently. But which one is correct according to the settings provided in the topic regardless of any plugin, custom settings e t c.

Share this post


Link to post
Share on other sites

Posted · Report post

Peter, please do my suggestion before hand, disable all non-PageLines plugins and remove all custom code and see if both sites are still acting differently. This needs to be done before, I test on my end which site is acting correctly and which isn't.

 

If both sites are setup/configured the same, then in theory they should be the same. As they aren't, then either they're not configured the same and you have missed something or you have a plugin/custom code effecting the sites layout.

 

Disable all non-PageLines plugins and custom code, is the fastest way to find out if the problem is with your layout settings or is plugin/custom code related.

Share this post


Link to post
Share on other sites

Posted · Report post

OK it´s done, and now they behave the same ;)

Share this post


Link to post
Share on other sites

Posted · Report post

OK, so it is related to your plugins and custom code. Therefore, what you will need to do is make sure they all have the same plugins installed and review your custom CSS, as either of them are effecting your sites layout.

Share this post


Link to post
Share on other sites

Posted · Report post

Ok I will insert the custom code first and see what happens. Thanks for assisting me. I thought there was a short cut.

But I guess there really isn´t any..

Share this post


Link to post
Share on other sites

Posted · Report post

body{}.pl-sharebar {text-align:center;}
.pl-sharebar-text {display:none;}
 
#site .content, #footer .content {
    width: auto !important;
}
 
This was the custom code in pehjaproduktion.se When I put it back the site behaves not as it should. The reason for the #site code was because the layerslider didn´t go all the way in my iPad

Share this post


Link to post
Share on other sites

Posted · Report post

Well when designing your site for ipad or similar devices you should using either the Browser Specific CSS plugin or use @Media, this way it will only effect those devices and not your site when viewed on a PC/Laptop.

 

http://support.pagelines.me/docs/plugins/browser-specific-css/

http://css-tricks.com/snippets/css/media-queries-for-standard-devices/

Share this post


Link to post
Share on other sites

Posted · Report post

Yes, But I haven´t figured out how Browser specific CSS works. In this case how ever it doesn't matter. The slider you see on both sites are identical. It looks fine on all browsers including iPad on one site, but doesn´t on the other. 

 

As i removed every plug and custom code on both sites. Then applied the slider. It should look the same.. but it does not. 

Anyway this have nothing to do with PageLine so I will have to talk to the guy providing this code. 

 

#site .content, #footer .content {

    width: auto !important;
}

Share this post


Link to post
Share on other sites