Archived

This topic is now archived and is closed to further replies.

  • 0

Pass Info to Authorize.net - Pagelines/WordPress problem


Question

Posted · Report post

Working on this site for a client: http://onehealthurgentcare.com/

 

On the Pay Your Bill page, there is an authorize.net form that the visitor fills in and then it passes the info over to the clients merchant account on Authorize.net for secure payment processing. 

 

However, even though I've installed the code correctly, it is throwing back these errors. (see here: pay-your-bill_error.png & pay-your-bill_form-error.png)

 

One of my designers thinks that the theme isn't passing ID/PW to Auth.net

Any ideas?  Should I setup the page template to use an alternate header and call the php info there??

Thanks in advance!

Share this post


Link to post
Share on other sites

3 answers to this question

Posted · Report post

Hi Steve, The images you have attached to your post are not loading, so not sure of the error you're receiving. Therefore, would it be possible for you to provide these screenshots again so we can see the issue. Also, can you provide us with the steps you have taken to add the forum/code to your site.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Danny,

 

Sorry, here are links to those images in dropbox:
https://www.dropbox.com/s/1pc8qvvazszi2lc/pay-your-bill_error.png

 

https://www.dropbox.com/s/g081n9b4z3jos3w/pay-your-bill_form-error.png?m

 

On the page I setup several content boxes to lay it out and then set it up with divs inside the contentbox. Then I just dropped in the code that Authorize.net passed over to me.  One problem I can see is that what they gave me has ... action="/index.php"> But I haven't put the PHP in the index.php page so I wonder if that is why its not passing the information back over. 

 

Your thoughts?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

I don't think the problem is the framework, but the form coding. For example, in viewing the source, this is the form the "Click Here for Secure Payment Form" button is processing:

<form action="/index.php" method="POST">

As you can see, it's trying to load index.php.  However, it doesn't really know where to find this index.php, and if it's looking at Wordpress' file of the same name, it simply won't see any real instructions there to process.

 

You need to specifically identify where the processing action of the form is located. 

Share this post


Link to post
Share on other sites