Jump to content


Photo
- - - - -

Custom Head & Branding Only Appearing on Homepage

full width head full width branding

Best Answer Danny , 30 January 2013 - 01:51 PM

I'm not sure why you keep adding https:// your site isn't HTTP Secure as far as I can see. Please use the following code:

 

 
#site .section-branding {
width: 100%;
background-image: url(http://cheapwebdesign.co/freshinstall/wp-content/uploads/2013/01/tophead.png);
} 

When you say custom template, if this a template you have created ?

Go to the full post


  • Please log in to reply
13 replies to this topic

#1 robdesigner

robdesigner

    Advanced Member

  • Members
  • 64 posts

Posted 30 January 2013 - 12:14 PM

Hi, i have created a custom full width header and branding backgrounds, this appears on the main homepage, and is using the site default template. The CSS i have used is for all pages, i.e not for a certian page. I have then thought it would be a template issue, but it cant, as the code is for the header area which are for all templates, the branding and header appears on all pages aswell, really struggling with this? i have done this before and it has been fine. It is a template issue, but i cant figure out what the issue is...

 

Website :

Please Login or Register to see this Hidden Content

 

 



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17977 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 30 January 2013 - 12:20 PM

Hi,

 

Your issue is that you're using relative URL for your image, use the full image path, this should resolve your issue.



#3 robdesigner

robdesigner

    Advanced Member

  • Members
  • 64 posts

Posted 30 January 2013 - 12:33 PM

ok will try this, sorry about the duplicate topic, it was just loading for about 5 minutes, so i hit submit again, thanks for coming back, will test it out now..



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17977 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 30 January 2013 - 12:40 PM

No need to apologise, it can just cause confusion, let us know if the suggestion above resolves your issue.



#5 robdesigner

robdesigner

    Advanced Member

  • Members
  • 64 posts

Posted 30 January 2013 - 12:48 PM

Please Login or Register to see this Hidden Content

 

is the full path, i have tried the about, and without the

Please Login or Register to see this Hidden Content

also tried:

 

Please Login or Register to see this Hidden Content

 

Neither works, this actually makes the banner dissappear? thanks for your help.

 

(also the loading issue is happening again)



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 17977 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 30 January 2013 - 12:52 PM

Isn't that the wrong image ?

 

As there is no contentbox on the other pages, I assumed you were talking about the Branding image.

 

Also, I suggest you read through the W3Schools page regarding relative urls, you need to use http://

 

When I use this in the code, the image is loading on all pages.



#7 robdesigner

robdesigner

    Advanced Member

  • Members
  • 64 posts

Posted 30 January 2013 - 12:58 PM

ok yes this is the issue, i have added a content box to the head, but there is only one head, i.e once you click on the page templates you will then see the default and custom templates, but their is only one head, we have placed the content box in the main header which should be on every page. Yes this also applied to branding but we will test the above suggestion out now, thanks again.



#8 robdesigner

robdesigner

    Advanced Member

  • Members
  • 64 posts

Posted 30 January 2013 - 01:01 PM

futher to my above message, the file path is also not working for the bran section.



#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 17977 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 30 January 2013 - 01:11 PM

I have looked at your other pages and I am not able to see any Contentbox in your header area.

 

Please Login or Register to see this Hidden Content

 

The easiest thing to do is simply use the full URL to the image in your custom CSS, this will resolve your issue. Regarding the ContentBox, you either have this set to hide by default and are only showing this on your homepage or you do not have that section active on your header.



#10 robdesigner

robdesigner

    Advanced Member

  • Members
  • 64 posts

Posted 30 January 2013 - 01:15 PM

ok its certainly an issue with the content box, it is in the header, we have checked the pages and it is not on hide, we did this before contacting you. Where else could it be set to hide apart from the page settings?

 

If the section is not active in the header, which it is, then why is it on our homepage? we are stumped we did most of this before contacting. We tried the full paths in custom css area as above, and it is does not work. Can you confirm what the correct full path would be i.e

 

https:// and full path

 

or just starting the from the folder i.e freshinstall

 

Either way we did both of these aswell?

 

Is there anyone else who can help?



#11 Danny

Danny

    Is Awesome!

  • Moderators
  • 17977 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 30 January 2013 - 01:31 PM

The correct path for the image would be this.

 

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

 

The section can be hide by default on the following setting pages.

 

Drag & Drop > 

Please Login or Register to see this Hidden Content

 

and on the individual page using the PageLines Meta Settings > Page Setup.



#12 robdesigner

robdesigner

    Advanced Member

  • Members
  • 64 posts

Posted 30 January 2013 - 01:42 PM

Yes as explained both the page setup settings, and via the drag drop settings, both are visible, so this is the odd thing. We did check both before contacting you, there should be no reason why it is not showing. The only difference is the template used, we use the default template for home, and custom for other pages. But saying that the head is on all pages, so there is an issue here? we have checked the above.

 

Also the custom full path does not work, i think it may be an issue with my coding, since adding the https:// inested of the /folder/image path, it now does not show, i think i do not need the brackets, please confirm correct path and code:

 

#header .section-contentbox  { width:100%; background-image: url (

Please Login or Register to see this Hidden Content


);}



#13 Danny

Danny

    Is Awesome!

  • Moderators
  • 17977 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 30 January 2013 - 01:51 PM   Best Answer

I'm not sure why you keep adding https:// your site isn't HTTP Secure as far as I can see. Please use the following code:

 

Please Login or Register to see this Hidden Content

When you say custom template, if this a template you have created ?



#14 robdesigner

robdesigner

    Advanced Member

  • Members
  • 64 posts

Posted 30 January 2013 - 02:07 PM

Sorry long day at the office, yes that has worked a treat for both sections, it was just a case changing a few spaces in the code mainly positioning of the following -  ;)

 

You are a superpower in knowledge, thanks again!







Also tagged with one or more of these keywords: full width head, full width branding