Jump to content


Photo
- - - - -

Changing Permalink/Page Link Names


  • Please log in to reply
11 replies to this topic

#1 larryb947

larryb947

    Member

  • Members
  • 24 posts
  • Framework Version:Developer edition and Plus membership
  • Country: Country Flag

Posted 29 January 2013 - 06:17 PM

Hi - I'm having trouble changing the name of the pages (the URL permalinks) to be sitename.com/post-name. When I select the option, it breaks the page entirely. I have to leave the Permalink Settings on Default. I'm used to being able to change the Permalinks easily on page. So what did I not set up correctly? 

 

 

Site: 

Please Login or Register to see this Hidden Content

Pagelines 2.4 developer and pro user

 

Any ideas/solutions would be helpful.

 

Erin

 

 



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 29 January 2013 - 06:39 PM

Which option are you selecting in Permalinks? Post name? And how so does it break the page?



#3 larryb947

larryb947

    Member

  • Members
  • 24 posts
  • Framework Version:Developer edition and Plus membership
  • Country: Country Flag

Posted 29 January 2013 - 06:43 PM

I have tried to different options in Permalinks. I've tried Post Name from the Permalinks Settings. I've also tried editing the Permalinks directly from the edit option at the top of the actual page. When I do either, it does change the name of the Permalinks, but when I view the page I get the following message: 

 

Not Found

The requested URL /solutions/industry-solutions/ was not found on this server.

 

I know I'm doing something incorrect. Derp Derp...



#4 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 29 January 2013 - 06:58 PM

You can try to delete the .htaccess file in the root wordpress folder and then save your permalink options. You can also visit any PageLines page to re-save your settings. For further information, please enable the "debug" option in Site Options -> Advanced and then provide us with the link (found in "more info" in debug after saving).



#5 larryb947

larryb947

    Member

  • Members
  • 24 posts
  • Framework Version:Developer edition and Plus membership
  • Country: Country Flag

Posted 29 January 2013 - 08:08 PM

I don't have access to the WordPress folder, but I can get it. I've tried revisiting any Pagelines page to resave, but I still get the same error. I've clicked on the "debug" option in Site Options>>Advanced. Here's the page link:

Please Login or Register to see this Hidden Content

 

If there is supposed to be a link next to the "debug" option, I couldn't find it. Sorry.

 

(FYI, I'm have no html, css, or PHP background, so if I say stupid things, apologies in advance.)



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 January 2013 - 11:11 PM

When these things happen there are several potential causes which Jenny has pointed out.

 

1.  The .htaccess file, which may be accessed via FTP is either corrupted or doesn't have permissions to be written to by the server.  Ask your host about this. They can either fix the permissions issue or remove the file and replace it with a blank, writeable file.

 

2.  Plugins can cause errors, particularly if they're outdated or incompatible with the current version of WordPress.  Check all your plugins to make sure they're current, but meantime, deactivate all plugins except for Akismet and try saving the permalinks at the post-name option.



#7 larryb947

larryb947

    Member

  • Members
  • 24 posts
  • Framework Version:Developer edition and Plus membership
  • Country: Country Flag

Posted 30 January 2013 - 05:55 PM

I checked the .htaccess file, and the permissions are wide open. Then again, I don't know what a corrupted .htaccess file looks like. The only thing in the file is:

 
# BEGIN WordPress
 
# END WordPress
 
So... should there be something else in there? It opened just fine.
 
As for the plugins, we had this problem before any plugins were installed. Currently, we only have Pagelines supported plugins and Akismet installed. I've also tried editing from the post-name option, and half the time it moves me to the Permalinks Settings page when I try to save it. The other half of the time it just errors out.


#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 16289 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 30 January 2013 - 09:16 PM

Hi Larry, Did you attempt to delete the .htaccess file ? If not please do so, once you have deleted the file. Login to your Wordpress Admin Dashboard > Settings > Permalink, when the permalink page loads, it will automatically generate a new .htaccess file. Attempt to change your permalink structure again and see if this resolves your issue. If it doesn't I recommend you create a topic on the Wordpress.org forums, as they are the best people to ask, due to this being a Wordpress related issue.

#9 larryb947

larryb947

    Member

  • Members
  • 24 posts
  • Framework Version:Developer edition and Plus membership
  • Country: Country Flag

Posted 30 January 2013 - 11:45 PM

Deleted the .htaccess file and I still have the problem. Moving this to Wordpress.org forums. Thanks for the help.



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 31 January 2013 - 12:14 AM

Hi,

 

My .htaccess includes:

Please Login or Register to see this Hidden Content

If your former .htaccess were set to 777, that too could have been the problem. It should probably be 755.



#11 larryb947

larryb947

    Member

  • Members
  • 24 posts
  • Framework Version:Developer edition and Plus membership
  • Country: Country Flag

Posted 07 February 2013 - 05:29 PM

The only thing that was in the .htaccess file was:

 

# BEGIN WordPress

# END WordPress

 

What do you mean by ".htaccess were set to 777, that too could have been the problem. It should probably be 755." Sorry for being so ignorant. Tried looking the answer up online but just ended up confusing myself more.

 

Erin



#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 07 February 2013 - 10:57 PM

Erin,

 

The 777 permissions are wide open so that anything may read or write to a file.  The 755 permissions limit access to a file.  In this case. .htaccess should actually be 777, but you should ask the host about ownership of the file. In otherwords, does the server own it or does the user (you) own it?

 

Without all of this bit below, I don't think WP can properly change things:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
That said,  when you're trying to get to this URL that doesn't work, how are you doing it?
 
Do you have a category solutions and subcategory set up for industry-solutions in Dashboard > Posts > Categories ?