Jump to content


Photo
- - - - -

Buddypress Register button not showing


Best Answer Danny , 30 January 2013 - 08:22 AM

Hi,

 

Unfortunately, PageLines does not support Internet Explorer 7 nor provide support for issues related to that browser version. IE7 is extremely poor, slow, old and doesn't support HTML5 or CSS3 which is what PageLines Framework uses. I suggest informing these users that they're currently not experiencing the internet as it was intended and are putting there computers at risk, they should upgrade their browser as soon as possible.

 

Tell them to read the Browser Happy website, which will help them understand - http://browsehappy.com/

Go to the full post


  • Please log in to reply
12 replies to this topic

#1 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 29 January 2013 - 04:25 PM

The register button does not show on IE 7 (apparently) - several people have told me but I can't view it in IE7 - is there an issue. See 

Please Login or Register to see this Hidden Content

 

I've already tried to change the Submit button CSS and bring it back to the left...

Can you see what might be the issue...? Thanks.



#2 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 29 January 2013 - 04:28 PM

OK - I am using a useful programme - IE Tester - which you can get from

Please Login or Register to see this Hidden Content

. Looks terrible! What's going on !?



#3 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 29 January 2013 - 04:31 PM

I also get an error message on this:

 

An error has occurred in the script on this page. Line 3. Char. 1407. Object doesn't support this property or method. Code: 0 url ; as already stated. Do you want to continue running scripts on this page? ??



#4 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 29 January 2013 - 04:31 PM

And another. Line 6. character 1. 'jquery is undefined. code 0. etc



#5 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 29 January 2013 - 04:50 PM

My css is as follows - I've added this to the 'submits' because I'd read somehow this can help - 

Please Login or Register to see this Hidden Content

 

 

Please Login or Register to see this Hidden Content



#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 29 January 2013 - 06:36 PM

Can you please post a screenshot of what you see on the IE tester and post it here? I cannot use that tester because it's only for Windows and I'm on a Mac.



#7 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 29 January 2013 - 07:09 PM

Lucky you... well, I have tracked it to some css (see below). If you visit the url above now in another browser you will see however that I have what appears to be a button within a button. I resolved this with the following:

Please Login or Register to see this Hidden Content

/*
Other submit buttons
*/
.standard-form div.submit {
    clear: both;
    padding: 0;
}
 
div.submit {
    width: 0; 
    border-style: none; }

 

But this took away the button(s) in IE altogether. What do you suggest? Thanks.



#8 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 29 January 2013 - 07:11 PM

This double button also occurs when trying to create a group from the Create  a Group page (you need to be logged in to see this).



#9 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 January 2013 - 09:17 PM

Hi,

 

This may not be directly related, but when logged into BuddyPress or bbPress, the registration links don't work.  That's a protection built into both BuddyPress and bbPress to prevent double or multiple registrations.



#10 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 30 January 2013 - 08:03 AM

Not related... I realise that. I am commenting on the look of the buttons. Clearly there is some IE conflict which has been addressed by doubling up a on a button outline. Do you have any css recommendations? Many thanks.



#11 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 30 January 2013 - 08:21 AM

OK> Srted. Trial and error.... that IE...



#12 Danny

Danny

    Is Awesome!

  • Moderators
  • 17124 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 30 January 2013 - 08:22 AM   Best Answer

Hi,

 

Unfortunately, PageLines does not support Internet Explorer 7 nor provide support for issues related to that browser version. IE7 is extremely poor, slow, old and doesn't support HTML5 or CSS3 which is what PageLines Framework uses. I suggest informing these users that they're currently not experiencing the internet as it was intended and are putting there computers at risk, they should upgrade their browser as soon as possible.

 

Tell them to read the Browser Happy website, which will help them understand - 

Please Login or Register to see this Hidden Content



#13 neighbour

neighbour

    Advanced Member

  • Members
  • 47 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 30 January 2013 - 08:30 AM

thanks... will work this in