Jump to content


Photo
- - - - -

Problems migrating servers with path change


Best Answer Madi , 09 April 2013 - 05:51 PM

Hope this helps...I found my answer in Simon_P's response to: http://www.pagelines...essdynamic-url/

Go to the full post


  • Please log in to reply
21 replies to this topic

#1 nyesinstitute

nyesinstitute

    Newbie

  • Members
  • 9 posts
  • Country: Country Flag

Posted 28 January 2013 - 10:00 PM

Posting here after a discussion with James in live support.

 

I'm currently working on moving our site across from xyz.com/home to another server with a new path (xyz.com). The WordPress migration works fairly well, copying across content without too many issues. I regenerate permalinks and change all instances in the database with the Velvet Blues plugin (and then again with Search & Replace, as Velvet misses some instances). The caveat here is that I skipped columns with GUIDs to prevent a deluge of RSS notification for subscribers. Files are copied across and permissions are checked.

 

The issue is that the fonts are not displaying correctly. I think the problem lies in a file in /wp-content/uploads/pagelines/compiled-css-1358852642.css, which stil contains the old path. I've manually changed the path but the problem remains. Do you have any suggestions on where the problem could lie? Is there anything else I can try?

 

A word on the new server: I haven't changed the nameservers across yet as I'm aiming for a zero downtime transition. I am accessing the site on the new server by using the new server's DNS on my computer, which means it isn't publicly accessible for testing.

 

Cheers,

John



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 28 January 2013 - 11:02 PM

Hi John,

 

We don't recommend or support changing core files.  Changes made to core files are subject to overwrite by product updates.

 

That said,  I suspect the issue should be resolved by going directly to Dashboard > Settings > Permalinks.  Change nothing at all. Just save.  This should update all the links.  I'm not sure what editing the compiled-css file will do to this solution.



#3 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 28 January 2013 - 11:05 PM

John, the css file will be updated if you save the pagelines options in the backend, or simply delete the file.



#4 nyesinstitute

nyesinstitute

    Newbie

  • Members
  • 9 posts
  • Country: Country Flag

Posted 28 January 2013 - 11:38 PM

Previously updated permalinks but that didn't work. I'll try deleting the CSS and see what happens.



#5 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 28 January 2013 - 11:53 PM

Yea I didn't mean permalinks settings go to any pagelines setting area and hit save

#6 nyesinstitute

nyesinstitute

    Newbie

  • Members
  • 9 posts
  • Country: Country Flag

Posted 29 January 2013 - 02:05 AM

Yep I got that... the comment about permalinks was in reference to Rob's comment :)

 

I'd already tried resaving Pagelines settings with no effect, but I'll try deleting the CSS and saving settings and we'll see how we go.



#7 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 29 January 2013 - 03:43 AM

Keep us posted!



#8 nyesinstitute

nyesinstitute

    Newbie

  • Members
  • 9 posts
  • Country: Country Flag

Posted 29 January 2013 - 06:12 AM

So, I've tried cloning the site again. The site copies over OK, the search & replace script does it's thing and all is well as far as Wordpress is concerned. I've regenerated the permalinks and I've resaved the Pagelines settings. I notice that the CSS file from before has also disappeared.

 

When I view the site, some sections are missing and the fonts aren't displaying correctly, just like before.

 

Any other thoughts?



#9 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 29 January 2013 - 04:12 PM

Are plugins/sections actually installed? Perhaps they were deactivated in the move. For example, if you had GoogleFonts installed, but now it's not, then your fonts wouldn't appear properly. Also make sure all store items are up to date.



#10 nyesinstitute

nyesinstitute

    Newbie

  • Members
  • 9 posts
  • Country: Country Flag

Posted 30 January 2013 - 03:21 AM

Yep, all plugins & sections installed and updated. GoogleFonts definitely enabled and store items up to date.

 

Interestingly, the Import/Export Settings area isn't working as it should. If I go to update the Pagelines settings by importing a dat file, it simply shows me a blank white screen; no error message, no timeout, no nothing.

 

Thoughts?



#11 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 30 January 2013 - 03:28 AM

Host might have mod_security enabled

#12 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 30 January 2013 - 03:35 AM

If your willing to edit a file, i might have a solution.



#13 nyesinstitute

nyesinstitute

    Newbie

  • Members
  • 9 posts
  • Country: Country Flag

Posted 30 January 2013 - 04:39 AM

Yep, mod_security is enabled.

 

Happy to edit any file required.



#14 Danny

Danny

    Is Awesome!

  • Moderators
  • 13021 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 30 January 2013 - 06:57 AM

Before editing any files, ask your host to disable mod_security, this may resolve your issue.



#15 nyesinstitute

nyesinstitute

    Newbie

  • Members
  • 9 posts
  • Country: Country Flag

Posted 30 January 2013 - 07:17 AM

Hmmm... not too keen on disabling mod_security just because I can't move a Pagelines site from one server to another. It's a fairly standard security measure.

 

What are my other options?



#16 nyesinstitute

nyesinstitute

    Newbie

  • Members
  • 9 posts
  • Country: Country Flag

Posted 30 January 2013 - 07:24 AM

Sorry, I forgot to add that I did disable mod_security momentarily to try and upload the settings file. It still generates a white screen with no errors and no action.

 

The MySQL server/database/username/password have all changed on the new server, but I would have thought that Pagelines would draw its login data from wp-config.php anyway? Or would at least generate an error if it failed to connect to the database? Strange.

 

I don't suppose there's a way to manually import settings?



#17 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 30 January 2013 - 09:19 AM

The white screen is an error, and is either a PHP error or a server error.

 

If you have WP_DEBUG enabled in wp-config.php it would show the php error.

 

If you disabled mod_sec then the file edit is pointless.

 

Ask the host if there is a php error log, or a mod_sec error/audit log they can check



#18 nyesinstitute

nyesinstitute

    Newbie

  • Members
  • 9 posts
  • Country: Country Flag

Posted 03 February 2013 - 10:32 AM

I had WP_DEBUG enabled and no error was generated... same old white screen.

 

I'll chase up a php error log with my host.



#19 Martin Davies

Martin Davies

    Advocate

  • Moderators
  • 2454 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 04 February 2013 - 01:20 PM

Hello - Nyeinstitute

 

Let us know if there is anything else we can do on our end or please do update your thread once you find a resolution. 



#20 Madi

Madi

    Member

  • Members

  • 19 posts
  • Country: Country Flag

Posted 09 April 2013 - 05:09 PM

I'm having a similar issue after changing the upload_path and upload_url_path in options.php to redirect to

Please Login or Register to see this Hidden Content

- in order to host my images on a subdomain (rather than

Please Login or Register to see this Hidden Content

).

 

I also added this line to .htaccess: RedirectMatch 301 ^/wp-content/uploads/(.*)$

Please Login or Register to see this Hidden Content

 

But, Pagelines still tries to save the compiled-css files in wp-content/uploads, and when I load the front end of the site again, particularly after I saved settings in Site Options, I face the same issue as nyesinstitute.

 

I'm not sure if this shines any kind of light, hoping it works, but I'll be happy to open a new thread if it doesn't.