Jump to content


Photo
- - - - -

wp-navi pagination issue


  • Please log in to reply
9 replies to this topic

#1 danielj

danielj

    Member

  • Members
  • 14 posts
  • Country: Country Flag

Posted 24 January 2013 - 04:39 AM

I have wp-navi installed for pagination, and I gather from the documentation that PageLines supports it. However, if you look at the bottom of

Please Login or Register to see this Hidden Content

you'll see the responsive design aspect is breaking. Is there a known fix for this? wp-navi hasn't been updated in a while...



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 24 January 2013 - 05:54 AM

Hi,

 

I see it's wrapping.  Probably the result of the padding around each number. Have you tried adding this?

Please Login or Register to see this Hidden Content

 

It adds some styling to the plugin.

 

Unfortunately, the plugin itself is not a PageLines product and we really don't style it or control it with anything specific.  Our support for it simply means that it works in the Framework.

 

I can say that the more post you have, the more likely it is you'll see it wrap.  Either the plugin itself or the one Iinked will let you adjust the number values that it groups, so instead of being 10 posts, you may want to group 15 or 20, so that there are less numbers to wrap.



#3 danielj

danielj

    Member

  • Members
  • 14 posts
  • Country: Country Flag

Posted 25 January 2013 - 01:40 AM

Yeah, we do have 1600 pages worth of posts... Thanks. I tried the plugin you recommended, but it still didn't let me keep things on one line. I'll move on to something else in the layout and figure it out later ;-)

 

Daniel



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 25 January 2013 - 03:05 AM

Only 1600? I have about 90,000 and also use the same two plugins.

 

Did you try adjusting the padding or margins for the numbers?



#5 danielj

danielj

    Member

  • Members
  • 14 posts
  • Country: Country Flag

Posted 25 January 2013 - 04:13 AM

I did actually play with the padding and margins, and it now works on one line for single digit pages. It still wraps for anything longer, but it's usable. What's your website, so I can take a look?

 

Thanks,

 

Daniel



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 25 January 2013 - 04:20 AM

Please Login or Register to see this Hidden Content

 

I'm glad that worked at least a bit.



#7 danielj

danielj

    Member

  • Members
  • 14 posts
  • Country: Country Flag

Posted 25 January 2013 - 04:23 AM

I love epicurus! But it looks like you are just using the standard "previous entries" and "next entries", not wp-pagenavi. Am I missing something?



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 25 January 2013 - 04:26 AM

Click on the recipes, glossaries or beverages and select a category

 

And thank you!.



#9 danielj

danielj

    Member

  • Members
  • 14 posts
  • Country: Country Flag

Posted 25 January 2013 - 04:33 AM

I think I am talking about number of pages, and you are talking about number of posts. I couldn't find any categories on epicurus that had 4 digits worth of pages. Take a look at the bottom of

Please Login or Register to see this Hidden Content

to see what I'm talking about. I did get a bit more space also by shortening Page to P., which I think looks ok.

 

I'm off to make a

Please Login or Register to see this Hidden Content

:-)



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 25 January 2013 - 04:40 AM

You'll enjoy that!