Jump to content


Photo
- - - - -

500 Internal Server Error error


Best Answer Rob , 24 January 2013 - 10:13 PM

Hi,

 

Did you change the ownership or permissions of the /en folder? Or ask your host to do it?

 

As Simon explained, the problem is that the /en folder is not readable by the server.  The CHMOD settings, essentially the ability for the system to write to or read a folder or file are not set correctly.  If you're not familiar with this, please contact your host and explain to them what Simon said.

Go to the full post


  • Please log in to reply
7 replies to this topic

#1 megmedia

megmedia

    Member

  • Members
  • 22 posts
  • Framework Version:v2.4
  • Country: Country Flag

Posted 23 January 2013 - 11:03 PM

Hi, i just installed pagelines-framework developer edition on an existing wordpress with pagelines lite. This website is a test before upgrading another website using pagelines lite.

 

This website is a multi-site network, you're customer service tell me that in need the developper edition in order to use Pagelines within a multi-site environment, so i purchase your 239$ framework and got the same issue i got with the lite edition.

 

first i had problem with both site on my network

Please Login or Register to see this Hidden Content

and

Please Login or Register to see this Hidden Content

then i follow the steps in this topic :

Please Login or Register to see this Hidden Content

 and solve the problem on one site but i still have the 500 server error on the second site.

 

I got the 500 server error when i insert a menu in one of the 4 support menu (theme location)

 

I also want to add that my website work well with twenty twelve theme and twenty eleven (both site)

 

i use woocommerce plugin

 

Thanks



#2 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 23 January 2013 - 11:11 PM

I dont see any errors on the 1st site you mentioned.

 

The error on 

Please Login or Register to see this Hidden Content

Is caused by the webserver not being able to read the files inside that directory. Probably a file permission issue.

 

If you enable WP_DEBUG inside wp-config.php you might be able to see what errors wp is generating.



#3 megmedia

megmedia

    Member

  • Members
  • 22 posts
  • Framework Version:v2.4
  • Country: Country Flag

Posted 23 January 2013 - 11:44 PM

Thanks i will use wp_debug, but again

Please Login or Register to see this Hidden Content

 work well with any other theme...



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 23 January 2013 - 11:50 PM

Hi,

 

When you installed Developer Edition, what did you do with the Lite Edition? How did you install it?

 

If I'm not mistaken, both have a folder called pagelines located in wp-content/themes.

 

You'd have to delete the pagelines folder containing Lite and upload the pagelines folder found in the Developer Edition zip file.



#5 megmedia

megmedia

    Member

  • Members
  • 22 posts
  • Framework Version:v2.4
  • Country: Country Flag

Posted 24 January 2013 - 02:37 PM

Ok, i think i just found the problem...Pagelines didn't seem to support Woocommerce on network multisite. I did a fresh installation of wordpress with network and try every plugin one by one and got the 500 internal server error only when i activate the woocommerce plugin.

 

Someone have a solution for this ?

 

Thanks again!



#6 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 24 January 2013 - 04:00 PM

There is no problem with woocommerce and PageLines, in fact they even released a plugin on github!

 

Your problem here: 

Please Login or Register to see this Hidden Content

is the folder /en/ is NOT readabl by the webserver, look at the error, i'll put it into plain english for you...

 

 

Forbidden

You don't have permission to access /en/ on this server.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

The error is actually a 403 Forbidden, which means nobody is allowed to view that folder, not even th web server process, so no files will be servered until you change the permissions.

 

The 500 error is your webserver panicing because you do not have an error document assigned for 403 errors.

 

You should ask your host what the proper folder permissions should be for your webserver.



#7 megmedia

megmedia

    Member

  • Members
  • 22 posts
  • Framework Version:v2.4
  • Country: Country Flag

Posted 24 January 2013 - 04:50 PM

Ok, thank you, pretty weird, cause i just activate jigoshop on other website instead of woocommerce and everything works fine, no 500 error, but at the moment i activate woocomerce i got the 500 error on one of the site.

 

website with jigoshop

Please Login or Register to see this Hidden Content

and

Please Login or Register to see this Hidden Content

 

I prefer woocommerce



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 24 January 2013 - 10:13 PM   Best Answer

Hi,

 

Did you change the ownership or permissions of the /en folder? Or ask your host to do it?

 

As Simon explained, the problem is that the /en folder is not readable by the server.  The CHMOD settings, essentially the ability for the system to write to or read a folder or file are not set correctly.  If you're not familiar with this, please contact your host and explain to them what Simon said.