Jump to content


Photo
- - - - -

Pagelines Crashing Wordpress

bug fatal error wordpress engine

Best Answer agumperz , 24 January 2013 - 05:02 AM

Simon,

 

Thank you. Upgrading to 2.4 did the trick.

 

 

Andrew

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 agumperz

agumperz

    Newbie

  • Members
  • 7 posts
  • Country: Country Flag

Posted 23 January 2013 - 10:29 PM

Hello,

 

I am having a problem where a bug in the Pagelines theme is causing the Wordpress engine to crash.

 

The bug is associated with the lessc compiler (generates CSS). I have attached the PHP log file. Any patch or workaround will be greatly appreciated!

 

 

Andrew

 

Please Login or Register to see this Hidden Content

Note that I had to disable the Pagelines theme to get back into the wordpress admin panel (wordpress returned a 500 error when I ever I tried to get in) so currently you won't see the theme on the site.



#2 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 23 January 2013 - 10:30 PM

Sorry dont see anything attached.



#3 agumperz

agumperz

    Newbie

  • Members
  • 7 posts
  • Country: Country Flag

Posted 23 January 2013 - 10:40 PM

Sorry,

 

Here is the attachment.

 

 

Andrew

Attached Files



#4 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 23 January 2013 - 10:49 PM

I cant tell whats going on with your site, you have a LOT of plugins. Your themes dir is kinda weird a resources dir?

 

Please activate the PageLines theme and deactivate any other plugins/caching/optimization then we can help you. As it is there is so much going on its impossible to see whats happening.



#5 agumperz

agumperz

    Newbie

  • Members
  • 7 posts
  • Country: Country Flag

Posted 24 January 2013 - 02:02 AM

I have deactivated all optimization plugins and reactivated the pagelines theme as asked. Upon reactivation, I immediately received an HTTP 500 error from the webserver server. The two errors I see in my log file are:

 

[23-Jan-2013 17:10:50 UTC] PHP Fatal error:  Cannot redeclare class lessc_formatter_compressed in /mnt/stor08-wc1-ord1/694335/713690/www.pcrtproductions.org/web/content/wp-content/themes/pagelines/includes/less.plugin.php on line 3326
 
[23-Jan-2013 17:10:50 UTC] PHP Fatal error:  Cannot redeclare class lessc in /mnt/stor08-wc1-ord1/694335/713690/www.pcrtproductions.org/web/content/wp-content/themes/pagelines/includes/less.plugin.php on line 40
 
Any patch or workaround you can provide will be appreciated. Thank you!
 
 
 
 

 

 

Attached Files



#6 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 24 January 2013 - 02:33 AM

Sorry, still impossible to tell whats happening, you have supercache installed AND some weird plugin that throws all css/js etc into ne folder.

 

Please deactivate these plugins and clear whatever cache it is.



#7 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 24 January 2013 - 02:34 AM

The folder 

Please Login or Register to see this Hidden Content

loads a different blog altogether!!??



#8 agumperz

agumperz

    Newbie

  • Members
  • 7 posts
  • Country: Country Flag

Posted 24 January 2013 - 02:44 AM

No, it is the same blog--actually this is more of a static theatre website, not a blog. The pagelines directory under themes had been renamed temporarily, to allow me back into the wp-admin panel. I have changed the name back to pagelines.



#9 agumperz

agumperz

    Newbie

  • Members
  • 7 posts
  • Country: Country Flag

Posted 24 January 2013 - 02:45 AM

I have cleared the supercache and deactivated (but not deleted) all optimization plugins.



#10 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 24 January 2013 - 03:02 AM

Right so you are running v2.3.8 Please upgrade to 2.4



#11 agumperz

agumperz

    Newbie

  • Members
  • 7 posts
  • Country: Country Flag

Posted 24 January 2013 - 05:02 AM   Best Answer

Simon,

 

Thank you. Upgrading to 2.4 did the trick.

 

 

Andrew







Also tagged with one or more of these keywords: bug, fatal error, wordpress engine