Jump to content


Photo
Citi Theme

Citi Theme took down the website and locked me out of WP



Best Answer NameSake , 25 January 2013 - 03:24 PM

Phew. Problem resolved. Thanks.

Go to the full post


  • Please log in to reply
15 replies to this topic

#1 NameSake

NameSake

    Advanced Member

  • Members

  • 49 posts
  • Country: Country Flag

Posted 23 January 2013 - 06:11 AM

Hi,

I've just installed the Citi child theme. I got the error message:

Fatal error: Can't use function return value in write context in /home/content/o/r/b/orbach1/html/wp-content/themes/citi/functions.php on line 236

 

The website is down, and the WP admin is also down with the same error message. I'd love to get control over the problem ASAP.

 

thanks.



#2 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 23 January 2013 - 02:11 PM

Dont' really see how that''s possible at all. You are the ONLY person who has reported this issue. You must have some plugins interfering because nobody has reported this, and I cannot duplicate it.



#3 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 23 January 2013 - 02:17 PM

You must have a really finicky version of PHP or something on your server. I'm going to rewrite this piece of code but don't know if that is going to fix it for you. Update coming shortly.



#4 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 23 January 2013 - 04:05 PM

OK Citi updated now at 1.1.4 let me know how you go about.



#5 NameSake

NameSake

    Advanced Member

  • Members

  • 49 posts
  • Country: Country Flag

Posted 23 January 2013 - 05:43 PM

I am not sure what is the source of the problem, Godaddy hosting the website (a generic server). The WP is updated. I managed to uninstall Citi. If I try to install it again, I get the error message:

Fatal error: parent_theme_prepare_install

see the attached file.

 

Thanks.



#6 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 23 January 2013 - 10:12 PM

How are you trying to install and what are you using? 



#7 NameSake

NameSake

    Advanced Member

  • Members

  • 49 posts
  • Country: Country Flag

Posted 24 January 2013 - 01:46 AM

WP 3.5 on which I have PaperLines 2.4 installed as a theme. I have tried to install in two ways:

PL Dashboard: Citi appears as an upgrade

PL Store, Theme, Pressing the Install Button of Citi. 

 

If it matters, I have an iMac.



#8 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 24 January 2013 - 02:56 AM

I would try to manually FTP the files in, maybe something was corrupted on install.



#9 NameSake

NameSake

    Advanced Member

  • Members

  • 49 posts
  • Country: Country Flag

Posted 24 January 2013 - 03:12 AM

Have tried that with v. 1.1.4 and got the error message

Fatal error: Call to undefined function ploption() in /home/content/o/r/b/orbach1/html/wp-content/themes/citi/functions.php on line 272

 

I should mention that I tried the installation also without any plugin. 

Any other idea?



#10 NameSake

NameSake

    Advanced Member

  • Members

  • 49 posts
  • Country: Country Flag

Posted 24 January 2013 - 05:01 AM

I wiped out the website. Reinstalled WP. Reinstalled PL.  Still the same error message. This is weird. 



#11 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 24 January 2013 - 02:16 PM

The only way you'll get that error is if you don't have PageLines installed. I'm not entirely sure what the issue is at all. Why are you now getting a completely different error?

 

P.S - How did you use a plugin to install this? This is  child theme, which means you install it into wp-content/themes. I think you have much bigger issues at and like your host preventing child themes from running or you've renamed the parent framework or something.



#12 NameSake

NameSake

    Advanced Member

  • Members

  • 49 posts
  • Country: Country Flag

Posted 24 January 2013 - 09:24 PM

Clearly there is more than "one way" in which a person can get such an error message. PL is installed now and it was installed before.

 

Being an unsophisticated user, I wiped out the website, installed WP with no plugin, and still receiving the same error message. 

 

When I upload the plugin through FTP to "wp-content/themes" I receive 

Fatal error: Call to undefined function ploption() in /home/content/o/r/b/orbach1/html/wp-content/themes/citi/functions.php on line 272

 

Both at the website and the admin page. I therefore have to delete citi folder.

 

When I install citi through PL admin in WP I get the other error message. My ability to try to make such installation indeed suggests that PL is installed.

 

As mentioned before, the host is GoDaddy. It is super generic. I tried to keep things as simple as one can get. 

 

This has been a significant labor to try to address potential theoretical issues at my side. If you wish, I can give you access to WP, FTP, or both. There is truly nothing anywhere. Perhaps you could figure out the issue. 

 

Clearly, I've done a lot to try to be able to work with your plugins (this and hopefully others). I hope we could figure out the issue.

 

Thanks.



#13 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 24 January 2013 - 11:46 PM

Can you post a link to your site?



#14 NameSake

NameSake

    Advanced Member

  • Members

  • 49 posts
  • Country: Country Flag

Posted 25 January 2013 - 01:13 AM

orbach.org



#15 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 25 January 2013 - 02:24 PM

you renamed the folder. Please do not rename the parent folder. It's been renamed to PageLines. Change this back to pagelines



#16 NameSake

NameSake

    Advanced Member

  • Members

  • 49 posts
  • Country: Country Flag

Posted 25 January 2013 - 03:24 PM   Best Answer

Phew. Problem resolved. Thanks.







Also tagged with one or more of these keywords: Citi Theme