Jump to content


Photo
- - - - -

Jigoshop add to cart button css


  • Please log in to reply
4 replies to this topic

#1 steck1983

steck1983

    Member

  • Members
  • 27 posts
  • Framework Version:2.02
  • Country: Country Flag

Posted 22 January 2013 - 06:53 AM

Hi,

 

This may be a dumb question but im unable to style the add to cart button in the single product view of pagelines/jigoshop.

 

I can target the button by using:

 

.variations_button .button-alt{

 

*/whatever style/*

}

 

Changes dont seem to be responding. Well some of them do and some of them dont. I checked to see if I had jigoshops frontend.css disabled and it is, so there shouldnt be any conflicts.

 

For example,  text transform will work, but Im unable to remove gradients, remove moz border radius's and assign background colors. I can only seem to change the text size and style...

 

Any ideas?



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 16952 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 22 January 2013 - 07:39 AM

Hi,
 
If you wish to style the button your products list page then use the following:

Please Login or Register to see this Hidden Content

If you wish to style the add to cart button on your single products page, use the following:

Please Login or Register to see this Hidden Content

 



#3 steck1983

steck1983

    Member

  • Members
  • 27 posts
  • Framework Version:2.02
  • Country: Country Flag

Posted 22 January 2013 - 07:54 AM

Hi Danny,

 

Ok, tried this, and does not work.

 

If I use either your css .jigoshop #site .button-alt{} or .variations_button .button-alt{} I get the same result. 

 

Interesting though if I change the attributes to !important it will work for everything but the text color for the normal state.

 

Weird... as i shouldnt have to list things as !important unless theres a conflict.. any more thoughts?



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 16952 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 22 January 2013 - 01:25 PM

Hi,


From what I can see we've had to use !important, so I have reported this as a possible bug. However it may have been added on purpose due to an issue with JigoShop CSS.

 

In the meantime you will need to use !important I'm afraid, thank you for bring this to our attention.



#5 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 February 2013 - 04:35 PM

The !important was added because by default jigo was using that as well.

 

Danny seeing as you have it installed already, with the pl-jigo plugin disabled do you still need the !important?