Archived

This topic is now archived and is closed to further replies.

  • 0

Sidebar confusion


Question

Posted · Report post

hi volks,

 

some sidebar confusions and i can't find a solution!

 

in drag and drop i have Primary Sidebar and Secondary Sidebar (with option: hide by default) and Tertiary Sidebar (with option: hide by default).

 

In Secondary Sidebar i use the Category Widget and in the Primary Sidebar i'm using a Subpages Widget (to display childpages).

 

in the Pagelines page options tab i checked on blog page, archive page, category page "Show Secondary Sidebar".

 

in the past time these setting did what i wanted them to do:

display childpages on pages

display categorys on blog posts, etc.

 

suddently these settings did not work any more.

 

on every new post now i have to check the indiv. Settings Box "Show Secondary Sidebar" below the editor.

 

do you know a better way to create what i need for this page?

 

thanks!

 

post-9549-0-89353600-1358770863_thumb.pn

post-9549-0-24089400-1358770865_thumb.pn

post-9549-0-36977400-1358770866_thumb.pn

1 person likes this

Share this post


Link to post
Share on other sites

16 answers to this question

Posted · Report post

You seem to be confused, Page Options > Blog Page only manages your Blog Page, it does not manage your Single Posts, Single Posts are not a Blog Page but a Blog Post.

 

You manage the Sidebars for your posts on an individual basis, there is no default global option.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Have you upgraded to the latest version of Framework?

Share this post


Link to post
Share on other sites

Posted · Report post

Sorry but that changes nothing!

 

Have a look at that Screenshot "PageLines Meta Setting" made while creating a new post: http://screencast.com/t/tk8U6Vgjn

You can choose "Show Tertiary Sidebar" although showing the Tertiary Sidebar is already setup in the Page Options Setup for BLOG Pages!

 

The Settings from the global Page Options Setup for BLOG Pages seems not to work...!?

 

I have the same problem on two more pages!

 

 

>> Just disabled all plugins but that changed nothing too.

 

>> If i put the Tertiary Sidebar into the sidebar wrap the same thing happens:

      setting up global Page Options to "Show Tertiary Sidebar" but thats not working at all.

 

>>> Thats interesting: In Drag & Drop i unchecked the "hide by default" option http://screencast.com/t/mzdbFCRKZSo

        and i now can choose "Hide Tertiary Sidebar" in Pagelines Meta Settings below the post editor: http://screencast.com/t/9T5WHLKS

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

I think the solution to this issue isn't going through a complex series of hiding and showing sidebars. Instead, you may simply wish to apply Widget Logic which can enable a widget to appear only on pre-determined pages, posts, categories, etc.

 

If you set the options in PageLines Site Options to Hide Sidebars when Empty, and Widget Logic is hiding the widget on a page or category, from my experience the sidebar is automatically hidden.  If the widget is displayed, so is the sidebar containing it. This method also allows you to have dozens of widgets in a single sidebar, even if you display just one or none at all.

 

I hope this helps. Also, make sure you follow the link to Conditional Statements in the first page of that plugin. It's a wonderful resource.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

no sorry, no errors from the plugins.

even more errors inside pagelines - i tried to hide the Mainnav or the Brandnav on the Pagelines "Page Options" Blog Page Tab - and nothing happens, it seems like there is no reaction.

Share this post


Link to post
Share on other sites

Posted · Report post

Can you install a free application called JIng, which allows you to capture your screen by image or video and then share it. Once installed, can you record your settings and the issue and we can then try to recreate your issue.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there, I've just tested on my setup and I'm getting the same results as Danny.

 

It could also be that there's a corrupted file somewhere, if more problems are cropping up on other pages etc.

 

Have you tried installing a fresh copy of the framework to see if this corrects itself. Is there a live link to the site we can look at.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Rob, thanks, widget logic is a cool plugin. But basically its good to know whether PageLines has the ability to manager the sidebars in the specified way or not!? => to know with Pagelines Its impossible to manage the sidebars for single posts and pages could save a lot of time for me and other users. i would be very glad if you would give a clear answer to that question. thanks 

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Danny, that was my expected answer.

 

But i think that Pagelines suggests the ability to manage sidebars in Single Posts and on the Blog Page and thats what confused me.

 

Global Option for Single Post SB management would be a great function for further PL development!

 

=> Now its seems clear that i need another plugin for sidebar management.

Share this post


Link to post
Share on other sites

Posted · Report post

yes i have

Share this post


Link to post
Share on other sites

Posted · Report post

Not sure what your issue is, as it works for me ?

 

http://d.pr/i/V0Mh

 

The page below is displays only the Primary Sidebar and its widget.

 

http://d.pr/i/QAJJ

 

This is the blog page, I went to PageLines > Page Options > Blog > then checked to show both the Secondary and the Tertiary Sidebar.

 

http://d.pr/i/TcTy

http://d.pr/i/bXCX

 

Now back to the first page I shown above, which displayed only the Primary Sidebar, I went to Wordpress Admin Dashboard > Pages > Selected the page and scrolled down to the PageLines Meta Settings > Page Setup and check both the Secondary and the Tertiary Sidebar.

 

http://d.pr/i/TOJe

 

http://d.pr/i/BsJf

 

Therefore, you most likely have configured something somewhere incorrectly or you have a plugin/custom code preventing this from working.

Share this post


Link to post
Share on other sites

Posted · Report post

ok thanks danny - i check the plugins and report to that topic later

Share this post


Link to post
Share on other sites

Posted · Report post

Please let us know how it goes! :)

Share this post


Link to post
Share on other sites

Posted · Report post

Try disabling your translation and see if it works when using the default language (English).

Share this post


Link to post
Share on other sites

Posted · Report post

Hi James, i did as you told, with fresh installs of wordpress, pagelines, pagelines child theme, default EN language file and deactivated plugins.

 

PL Settings:

Template SB Settings

SB Blog Page Settings

 

Results:

Blog Page ==> Works!

Single Post ==> Fails! / Shows SB 1 and SB 2 / SB 3 is hidden!

 

Any ideas why SB 3 is hidden on single post pages?

Share this post


Link to post
Share on other sites