Jump to content


Photo
- - - - -

NavBar Issue post 2.4 upgrade...small screen


Best Answer loraxio , 21 January 2013 - 05:58 PM

Solved it myself...somehow, when the NavBar was updated in 2.4, there was some padding that was added to the bottom which looked weird when the li.current was active.  I had tried to fix that by specifying a height for the .navbar, but this had the unintended consequence of not allowing it to resize for small screens.

 

I remedied the whole shebang by adding media queries for large screens, intermediate screens, and small screens.  I love the granularity you get with media queries!!!

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 loraxio

loraxio

    Advanced Member

  • Members

  • 54 posts
  • Framework Version:3.4.2
  • Country: Country Flag

Posted 21 January 2013 - 09:40 AM

I am about 98% ready to launch a new Pagelines site, but the last thing I need to get fixed before launch is the fact that after 2.4 upgrade, the NavBar menu does not have a background, as well it shows up behind the page content.

 

Here is a page to see what I mean...

Please Login or Register to see this Hidden Content

 

Of course, this will only be re-created on small screens.

 

-joshua



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 15848 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 January 2013 - 10:07 AM

Hi,

 

When I view your site, I am not seeing the issue you're.

 

Please Login or Register to see this Hidden Content

 

The Fixed Navbar has a grey background, which is what you have set and the only other navigation you have is the Secondary Navigation. So has the issue been resolved ?



#3 loraxio

loraxio

    Advanced Member

  • Members

  • 54 posts
  • Framework Version:3.4.2
  • Country: Country Flag

Posted 21 January 2013 - 10:11 AM

Indeed the NavBAr has a light grey background, but I am referring to the menu when viewed on a smaller screen (max 480px) and the menu is toggled open.

#4 loraxio

loraxio

    Advanced Member

  • Members

  • 54 posts
  • Framework Version:3.4.2
  • Country: Country Flag

Posted 21 January 2013 - 05:58 PM   Best Answer

Solved it myself...somehow, when the NavBar was updated in 2.4, there was some padding that was added to the bottom which looked weird when the li.current was active.  I had tried to fix that by specifying a height for the .navbar, but this had the unintended consequence of not allowing it to resize for small screens.

 

I remedied the whole shebang by adding media queries for large screens, intermediate screens, and small screens.  I love the granularity you get with media queries!!!