Archived

This topic is now archived and is closed to further replies.

  • 0

Thumbnail size

Question

Posted · Report post

I am trying to find out why the thumbnails in my gallerys are displaying at 150 x 150. There are no obvoius setting to me in the theme or in the Lightbox setting which would be causing this.

Is it a theme setting?

According to the Wordpress site i should be able to do all sorts of shapes...

 

http://en.support.wordpress.com/images/gallery/#

 

I have tried adjusting the thumbnail sizes in media settings but all this does is shrink the square........

Share this post


Link to post
Share on other sites

22 answers to this question

Posted · Report post

Hi,

 

Settings for the thumbnail size used by WordPress can be found at Dashboard > Settings > Media. You may set a custom size there.  Let us know if this helps.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

I'm looking at that page and every photo in the two left-side columns are 175 x 131 in Firefox.  I see no problems with it.  Using Firebug, the margins may be tested and adjusted, then the CSS copied and pasted to Dashboard > PageLines > Site Options > Custom Code. But as it is now, the margins and padding are quite reasonable.

Share this post


Link to post
Share on other sites

Posted · Report post

Excellent.

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you Danny, I will let you know the outcome should the plugin author decide my problem warrants an answer.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

I'm looking at that page and every photo in the two left-side columns are 175 x 131 in Firefox.  I see no problems with it.  Using Firebug, the margins may be tested and adjusted, then the CSS copied and pasted to Dashboard > PageLines > Site Options > Custom Code. But as it is now, the margins and padding are quite reasonable.

 

Hello Rob

 

That is exactly what I am saying. The thumbnails work at 175 x 131 when used with the WP gallery (my preferred 3 columns) but not when they are used with the plugin.

If the margins are adjusted to suit the thumbnails will this have a knock on effect with a standard posted fullsize image?

Share this post


Link to post
Share on other sites

Posted · Report post

Keep us posted.

Share this post


Link to post
Share on other sites

Posted · Report post

Regarding the last problem, is there a question in there we can help you out with? :)

Now that you ask......... :thumbsu:

 

I am playing around with diferent gallery options, some images are self hosted hence my earlier question. That is now resolved.

My next problem is connected to a plugin called Picasa Express 2 which is enabling (or should be) to show a gallery with Picasa hosted images.

 

The default WP gallery works a treat but with my limited knowledge seems to work in a diferent way to the way the plugin does.

I would like the plugin to show 3 columns like the WP one but try as I might I cannot seem to be able to work out how. If I reduce the thumbnail size it still doesn't work and the result is a single column.

 

I have tried to find out what is happening using firebug but to be honest makes no sense.

 

Here are 2 comparison images showing A) WP Gallery B) Plugin

 

What seems odd to me is the offsetwidth is bigger on the method that works. Am I being too ambitious to make both work and is there a solution?

 

 

 

ScreenCapture1.jpg    ScreenCapture2_zps9b87502c.jpg

Share this post


Link to post
Share on other sites

Posted · Report post

I used the 'regenerate thumbnails' plugin - http://wordpress.org...ate-thumbnails/ to resize all the thumbnails to suit my needs. Worked a treat. Thanks to James B for that one.

 

The only problem then was there were loads of different sized thumbnails in the WP Content folder which were not being used and  taking up loads of storage. I then used another plugin called DUI to identify and then assist in the removal.

I hadn't realised that  if you upload an image WP will automatically do 3 versions to the sizes set in -Dashboard > Settings > Media.

I have now set the medium size to zero as I don't use that size image.

Share this post


Link to post
Share on other sites

Posted · Report post

OK, so the issue is that the plugin method is using CSS which is effecting your gallery columns, so if you wish to use this plugin, you will need to inspect your CSS and make changes, adding them to your custom CSS.

 

There is an issue with the images using .wp-caption which has padding, it is also using a class called .alignleft, which has a 1.5em margin, these two are pushing your columns out of position.

 

What I do not understand is why you wish to use a plugin when the Wordpress gallery method is working which out any issue?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

I think you should ask the plugin developer about columns.  That's not something PageLines is doing or preventing.  If they have a way to modify it for you, then it should work.

Share this post


Link to post
Share on other sites

Posted · Report post

Hello Danny

 

Thank you for this, I had tried reducing the .alignleft right margin to 0.5em but that just made everything go into a single colums for some reason??

 

I does all slot together OK without the caption so maybe I will just have do it without it.

 

The reason for using this plugin is so I can save on Disk Space. I can upload photos to Picasa and still have a gallery look which works with the Lightbox. I don't know of any other pugins that have this facility.

 

Here is a link to my test installation where I have tried all manner of set ups....  http://www.trinder.org/test2013/

 

The most recent being the one with the smaller right margin.

Share this post


Link to post
Share on other sites

Posted · Report post

From what I can see this plugin doesn't have any CSS and uses the themes default CSS, but I may be wrong. Therefore, can you provide the code you're using to generate your gallery please.

 

Also, you have quite a few <p></p> between each of your images code, this is usually caused by your code not being formatted correctly in the Wordpress editor.

 

When providing us your code, please add it to our paste service

 

http://paste.pagelines.com/

 

Then provide a link to your paste in your reply.

 

One thing to note that the more we investigate this, it is more likely this is a plugin issue and not a theme issue. Therefore, I think the best course of action would be to contact the plugin author for assistance.

Share this post


Link to post
Share on other sites

Posted · Report post

Regarding the last problem, is there a question in there we can help you out with? :)

Share this post


Link to post
Share on other sites

Posted · Report post

Quick update as promised.

We have a new author for the plugin who has been helping work round the column issue. We are still having issues with the captions but I believe we are making progress.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

I think you should ask the plugin developer about columns.  That's not something PageLines is doing or preventing.  If they have a way to modify it for you, then it should work.

Hello Rob

 

I take your point about speaking to the developer but isn't it also the theme that will dictate how an image displays. For example this particular plugin seems to be using the themes image settings to display the thumbnails.

How would you explain the yellow box on the first image? It seems to be pushing the 2nd image towards the right which is then not allowing enough space for the third image. I am assuming these settings are linked to a normal image?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

The yellow box is your developers tools coloring for margin, when you're inspecting the element. Also, I don't see the issue that you have in your image - http://d.pr/i/lWzQ

 

Thumbnails are controlled in Wordpress > Settings > Media > Thumbnail size.

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you Danny and I understand exactly what you are saying. This plugin does work without the captions so I am just going to have this type of gallery without them.

 

 

I have copied 2 styles of posting the gallery which are the 2 option available.

 

http://paste.pagelines.com/8cz

 

First option is insert a whole gallery using shortcode which produces all the images from the album with captions. The result is only 2 columns  
The second option you can select the images you want in the order you want and carries a lot more code. This option also allows you to remove the captions. This does give me what I am looking for but only if i remove the captions. I have updated the problem gallery now using this method.

There is option to include for you to define default class for images from theme's style.css and also to hardcode some css attributes but none of these seem to make any difference.

 


 

 

 

BTW, I have also contacted the plugin author after your first reply  but he is yet to respond.

 

Thank you once again for your patience and help.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

The yellow box is your developers tools coloring for margin, when you're inspecting the element. Also, I don't see the issue that you have in your image - http://d.pr/i/lWzQ

 

Thumbnails are controlled in Wordpress > Settings > Media > Thumbnail size.

 

Hello Danny

I appreciate the time you are giving me on this.

 

The screen shot you posted a link to, is of a WP Gallery using self hosted images and isn't where I am having the problem. My thumbnail settings are set at 175px x 131px which works well with the WP Gallery.

However the same thumbnail settings are used by the plugin but something within the page structure (the yellow shaded area on the first image) is preventing it from displaying 3 columns.

 

What is making me think it is using the standard image settings is the fact the caption font colour is yellow which is the same for all the media captions except the gallery ones.

Am I wrong in thinking this is the case?

 

I do have a test installation and can achieve 3 columns if I don't add the caption underneath. Can I send you a link via pm?

Share this post


Link to post
Share on other sites

Posted · Report post

Can you provide a link to the gallery in question please, so I can take a closer look.

Share this post


Link to post
Share on other sites

Posted · Report post

I think the best course of action is to wait for the author of the plugin to view your issue and see what he/she suggests.

Share this post


Link to post
Share on other sites