Jump to content


Photo

Add New Page

WhiteHousePro3

Best Answer James B , 18 January 2013 - 01:52 AM

Hi there

 

The permalink settings won't add the menu to the navbar, if you've created a custom menu and the new page isn't displaying please check you have 'automatically add new top level pages' checked, otherwise you'll have to add them manually to the menu each time you create them.

 

http://screencast.com/t/5qGVZQ5K4bX

 

Hope that helps :-)

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 tsilloh

tsilloh

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts
  • LocationUtah
  • Country: Country Flag

Posted 17 January 2013 - 07:44 PM

I tried to add the following page to the intlrr website http://www.intlrr.co...-estate-wisdom/ just as I have done many times before.  I can view the page that I am adding, but it does not appear in the menu.  I have updated to WordPress 3.5.

 

Status:  Published (16 Jan 2013 at 13:16)

Visibility:  Public

Main page (no parent)

Order:  90 (previous tabs are 80, 70, 60, . . .)

Full Width Page

Comments Allowed

 

Why does the page name not appear in the top row of menu options?

 



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 17 January 2013 - 08:06 PM

Are you using a custom menu?



#3 tsilloh

tsilloh

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts
  • LocationUtah
  • Country: Country Flag

Posted 17 January 2013 - 10:05 PM

Yes, you helped me change to a custom menu so the menu reflects the name of the pages.

 

I went to Permalink Settings > Common Settings and found the Month and Name option was selected.  The unchangeable part is http://www.intlrr.co...01/sample-post/

 

I selected Custom Structure.  The unchangeable part is http://www.intlrr.com/htdocs.  The changeable part is /%year%/%monthnum%/%postname%/.  When I saved changes, I reveived a message "You should update.htaccess now".

 

I located .htaccess at the bottom of the Permalink Settings page.  It says:

If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

 

I selected all, copied, and pasted.  Here are the contents of that block. 

 

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /htdocs/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /htdocs/index.php [L]
</IfModule>
 

 

What updates or changes to the Permalink Settings page do I need to make?



#4 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 18 January 2013 - 01:52 AM   Best Answer

Hi there

 

The permalink settings won't add the menu to the navbar, if you've created a custom menu and the new page isn't displaying please check you have 'automatically add new top level pages' checked, otherwise you'll have to add them manually to the menu each time you create them.

 

http://screencast.com/t/5qGVZQ5K4bX

 

Hope that helps :-)


  • tsilloh likes this

#5 tsilloh

tsilloh

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts
  • LocationUtah
  • Country: Country Flag

Posted 18 January 2013 - 03:47 PM

Went to Appearance > Menus.  Checked "Automatically add new top-level pages".  Tested.  New page still not in the navigation bar.  Went back to Appearance > Menus > Pages, found and checked the new page, and clicked on "Add to Menu".  Theh new page is now shown in the menu. 

 

You instructions did help.  Thank you very much!