Jump to content


Photo
- - - - -

2.4 Release notes.

release

  • This topic is locked This topic is locked
46 replies to this topic

#1 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 January 2013 - 10:16 PM

Were releasing version 2.4 of PageLines Framework.

 

This release fixes a few bugs and adds some cool new stuff. Here are the highlights:

 

- NEW - Upgrade the PageLinesFont to FontAwesome v3.
- NEW - Make css save directory filterable: pagelines_css_upload_dir.
- NEW - Added @pl-min-height variable to LESS system.
- NEW - Add Google Plus! profile to HEAD of page.
- NEW - Enable dropdown on hover for navbar.
- CORE - Load shims with // fixes ssl issues.
- CORE - Load google fonts with // fixes ssl issues.
- CORE - Make all navbar options translatable.
- CORE - Update LESS plugin and use class_exists to check if already loaded.
- Bugs - Remove supersize loader.
- Bugs - LESS: Fix hardcoded tooltip colours.
- Bugs - LESS: Typo in masthead.
- Bugs - LESS: Fixed bugs in forms.less and progressbars.less and dropdowns.less.
- Bugs - LESS: Modals media queries were missing.

- Bugs - LESS: Load responsive last. 


  • batman likes this

#2 creatov

creatov

    Advanced Member

  • Members

  • 56 posts
  • Framework Version:Developer Edition

Posted 18 January 2013 - 01:35 PM

After updating the dropdown menu of the fixed navbar is changed. Now I do not see the dropdown even with the option enabled.

 

See http://www.screencas.../t/ZVGUyjgJaTcM

 

I'm missing "<b class="caret"></b>" in the code, is what I see quickly.

 

PS: the upgrade is done on http://www.creatov.nl/news , the previous one is running on http://www.creatov.nl



#3 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 18 January 2013 - 05:33 PM

It worked fine in testing, as you can see here: http://pross.org.uk/

I dont use any plugins though, so all i can suggest is something might be conflicting with the css.

#4 creatov

creatov

    Advanced Member

  • Members

  • 56 posts
  • Framework Version:Developer Edition

Posted 18 January 2013 - 05:56 PM

Simon, thank you. Disabling every plugin was the solution. There's a conflict with Super RSS Reader, a RSS widget. Now it't working fine. Thanks again!



#5 elijahworkz

elijahworkz

    Member

  • Members
  • 19 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 19 January 2013 - 06:45 PM

page can't get past headers after upgrade... Disabled all plugins but still nothing - it just keeps spinning trying to load a page... Works fine with twenty twelve theme...



#6 elijahworkz

elijahworkz

    Member

  • Members
  • 19 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 19 January 2013 - 07:40 PM

Just checked the page source - it seems that the whole page is loaded but not displayed?! site is http://calvarynovoross.com



#7 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 19 January 2013 - 07:51 PM

Just checked the page source - it seems that the whole page is loaded but not displayed?! site is http://calvarynovoross.com

are you using any filters for the google fonts? the url needs // in front of it.

 

@import url(fonts.googleapis.com/css?v2&subset=latin,cyrillic&family=PT+Sans+Narrow|Scada|Roboto);
yours has no // 


#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 19 January 2013 - 08:05 PM

elijahworkz if your happy to edit one file with a small change i think i can fix this, reply via PM with admin login and i'll fix for you.

#9 raezerj

raezerj

    Advanced Member

  • Members
  • 81 posts
  • Country: Country Flag

Posted 19 January 2013 - 08:54 PM

Easy update - zero issues on our sites (www.agwine.com and www.approachguides.com)

Thank you!



#10 elijahworkz

elijahworkz

    Member

  • Members
  • 19 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 20 January 2013 - 03:09 AM

Yes, Simon_P, thank you

 

I can fix this... But why didn't it add // during the upgrade?



#11 elijahworkz

elijahworkz

    Member

  • Members
  • 19 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 20 January 2013 - 03:27 AM

adding // didn't help... Simon_P - I can edit a file if you can point me in the right direction?



#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 20 January 2013 - 04:06 AM

Where did you add it?



#13 elijahworkz

elijahworkz

    Member

  • Members
  • 19 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 20 January 2013 - 05:25 AM

Where did you add it?

in pagelines customize plugin functions.php - that's where I'm replacing original string to add cyrillic subset



#14 elijahworkz

elijahworkz

    Member

  • Members
  • 19 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 20 January 2013 - 05:31 AM

I just checked and even though I added // it's not displayed in pagelines generates css file... may be it's a caching problem now? I don't have any caching plugins installed though...



#15 elijahworkz

elijahworkz

    Member

  • Members
  • 19 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 20 January 2013 - 05:37 AM

 
add_filter( 'pagelines_gfont_baseurl', 'make_cyrillic' );


function make_cyrillic() {
return '//fonts.googleapis.com/css?v2&subset=latin,cyrillic&family=';
}

this is what I have in customize plugin



#16 chan08

chan08

    Advanced Member

  • Members

  • 37 posts

Posted 20 January 2013 - 07:34 AM

Does this update fix the issue with Time.ly's calendar plugin breaking the site in their 1.9 update?



#17 elijahworkz

elijahworkz

    Member

  • Members
  • 19 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 20 January 2013 - 02:08 PM

OK, I figured out the problem.... I noticed that page was not loading past script.supersize.js file so I disabled supersize background option and the page loaded... After that I re-enabled the option and page loaded fine...



#18 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 20 January 2013 - 04:13 PM

chan08 yes

#19 Jackey

Jackey

    Advocate

  • Members


  • 685 posts
  • LocationHelmond
  • Country: Country Flag

Posted 21 January 2013 - 11:49 AM

@Simon_P Still have issues with timely 1.9. When a LESS compile is triggered (through flush or save options) all CSS is gone from the site. Can only restore CSS by disabling Timely, flush LESS, and the re-enable timely.

 

So probably Timely prevents the LESS to compile.



#20 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 21 January 2013 - 02:14 PM

Worked fine for me in testing, Danny just tested it too with no problems.







Also tagged with one or more of these keywords: release