Archived

This topic is now archived and is closed to further replies.

2.4 Release notes.


47 posts in this topic

Posted · Report post

Were releasing version 2.4 of PageLines Framework.

 

This release fixes a few bugs and adds some cool new stuff. Here are the highlights:

 

- NEW - Upgrade the PageLinesFont to FontAwesome v3.
- NEW - Make css save directory filterable: pagelines_css_upload_dir.
- NEW - Added @pl-min-height variable to LESS system.
- NEW - Add Google Plus! profile to HEAD of page.
- NEW - Enable dropdown on hover for navbar.
- CORE - Load shims with // fixes ssl issues.
- CORE - Load google fonts with // fixes ssl issues.
- CORE - Make all navbar options translatable.
- CORE - Update LESS plugin and use class_exists to check if already loaded.
- Bugs - Remove supersize loader.
- Bugs - LESS: Fix hardcoded tooltip colours.
- Bugs - LESS: Typo in masthead.
- Bugs - LESS: Fixed bugs in forms.less and progressbars.less and dropdowns.less.
- Bugs - LESS: Modals media queries were missing.

- Bugs - LESS: Load responsive last. 

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

After updating the dropdown menu of the fixed navbar is changed. Now I do not see the dropdown even with the option enabled.

 

See http://www.screencast.com/t/ZVGUyjgJaTcM

 

I'm missing "<b class="caret"></b>" in the code, is what I see quickly.

 

PS: the upgrade is done on http://www.creatov.nl/news , the previous one is running on http://www.creatov.nl

Share this post


Link to post
Share on other sites

Posted · Report post

It worked fine in testing, as you can see here: http://pross.org.uk/

I dont use any plugins though, so all i can suggest is something might be conflicting with the css.

Share this post


Link to post
Share on other sites

Posted · Report post

Simon, thank you. Disabling every plugin was the solution. There's a conflict with Super RSS Reader, a RSS widget. Now it't working fine. Thanks again!

Share this post


Link to post
Share on other sites

Posted · Report post

page can't get past headers after upgrade... Disabled all plugins but still nothing - it just keeps spinning trying to load a page... Works fine with twenty twelve theme...

Share this post


Link to post
Share on other sites

Posted · Report post

Just checked the page source - it seems that the whole page is loaded but not displayed?! site is http://calvarynovoross.com

are you using any filters for the google fonts? the url needs // in front of it.

 

@import url(fonts.googleapis.com/css?v2&subset=latin,cyrillic&family=PT+Sans+Narrow|Scada|Roboto);
yours has no // 

Share this post


Link to post
Share on other sites

Posted · Report post

elijahworkz if your happy to edit one file with a small change i think i can fix this, reply via PM with admin login and i'll fix for you.

Share this post


Link to post
Share on other sites

Posted · Report post

Yes, Simon_P, thank you

 

I can fix this... But why didn't it add // during the upgrade?

Share this post


Link to post
Share on other sites

Posted · Report post

adding // didn't help... Simon_P - I can edit a file if you can point me in the right direction?

Share this post


Link to post
Share on other sites

Posted · Report post

Where did you add it?

Share this post


Link to post
Share on other sites

Posted · Report post

Where did you add it?

in pagelines customize plugin functions.php - that's where I'm replacing original string to add cyrillic subset

Share this post


Link to post
Share on other sites

Posted · Report post

I just checked and even though I added // it's not displayed in pagelines generates css file... may be it's a caching problem now? I don't have any caching plugins installed though...

Share this post


Link to post
Share on other sites

Posted · Report post

add_filter( 'pagelines_gfont_baseurl', 'make_cyrillic' );


function make_cyrillic() {
return '//fonts.googleapis.com/css?v2&subset=latin,cyrillic&family=';
}

this is what I have in customize plugin

Share this post


Link to post
Share on other sites

Posted · Report post

Does this update fix the issue with Time.ly's calendar plugin breaking the site in their 1.9 update?

Share this post


Link to post
Share on other sites

Posted · Report post

OK, I figured out the problem.... I noticed that page was not loading past script.supersize.js file so I disabled supersize background option and the page loaded... After that I re-enabled the option and page loaded fine...

Share this post


Link to post
Share on other sites

Posted · Report post

chan08 yes

Share this post


Link to post
Share on other sites

Posted · Report post

@Simon_P Still have issues with timely 1.9. When a LESS compile is triggered (through flush or save options) all CSS is gone from the site. Can only restore CSS by disabling Timely, flush LESS, and the re-enable timely.

 

So probably Timely prevents the LESS to compile.

Share this post


Link to post
Share on other sites

Posted · Report post

Worked fine for me in testing, Danny just tested it too with no problems.

Share this post


Link to post
Share on other sites

Posted · Report post

Can it be a memory problem?

Seems to disappear with less plugins active... 

Share this post


Link to post
Share on other sites

Posted · Report post

It's possible, enable the pagelines debug and that page will tell you what memory you have

Share this post


Link to post
Share on other sites

Posted · Report post

Pagelines reports 64M, that's not very much is it?

 

 

WordPress Version : 3.5 Multisite Enabled : No Current Role : Administrator Framework Path : /var/www/web126/web/wp-content/themes/pagelines Framework URI : http://www.xn--kulturregionstorstrm-tcc.dk/wp-content/themes/pagelines Framework Version : 2.4 Framework Build : 2.4 PHP Version : 5.3 PHP Open basedir restriction : Yes! PHP memory : 64 Mysql version : 5.1.56 Sections DIR : Writable.
/var/www/web126/web/wp-content/plugins/pagelines-sections PHP type : Cgi-fcgi PHP User : Posix functions are disabled on this host! OS : Linux Launchpad : Logged in ( jackey ) Licence : Dev Plugins : 18
advanced-post-types-order/advanced-post-types-order.php
all-in-one-seo-pack/all_in_one_seo_pack.php
ba-shortcodes/ba-shortcodes.php
billboard/billboard.php
browser-css/browser-css.php
child-page-navigation/child-page-navigation.php
contact-form-7/wp-contact-form-7.php
count-per-day/counter.php
google-sitemap-generator/sitemap.php
hello.php
ie7-js/ie7-js.php
page-less/page-less.php
pagelines-customize/pagelines-customize.php
pagelines-googlefonts/pagelines-googlefonts.php
pagelines-sections/pagelines-sections.php
pagelines-shortcode-generator/pagelines-shortcode-generator.php
special-recent-posts-2.4.7/special-recent-posts.php
tinymce-advanced/tinymce-advanced.php
 

Share this post


Link to post
Share on other sites

Posted · Report post

Should be enough, try disabling everything except the framework and the events plugin, that should work thats what me n danny were using. The re-enable one by one.

Share this post


Link to post
Share on other sites

Posted · Report post

Every single time I update Pagelines I have to move the text widget I created for my Footer text from the MoreFoot Left column back to the Footer Columns Sidebar in the Apperence >>> Widgets area. It was in the Footer Columns Sidebar before updating, but it is never there after.

 

I should have taken a screen shot or something I know, but what a weird bug! 

 

If I don't move the text widget back, I get a menu appearing in the footer, as expected if the default footer text isn't being overridden.

 

This is hardly world ending and unlikely to get many bug fixing resources thrown at it (even if it is replicable) but just though I'd mention it in case anyone else is experiencing this odd behaviour. 

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.