Archived

This topic is now archived and is closed to further replies.

  • 0

Post loop problem


Question

Posted · Report post

I have a site that uses custom post types for members. I used Types and Views to create the custom post types and the queries that show specific members. I created views to show specialities for member type. For example a member type could be culinary and within culinary, I have chef, caterer, etc. Take a look at this page on the right sidebar and you'll see the specialties for this member type listed. Unfortunately, for some reason I can't get this link to resolve from this post so please go to the home page and then click on member directory and then culinary. http://www.whidbeylifemagazine.org

 

So what is supposed to happen is the visitor would click on say "chef" and only those members with "chef" as one of their specialties (category) will display and this is what happens with the culinary members. However with all other member types: visual, dance, music, literary, and theater this does not happen. Instead, it lists the specialites for each of these member types correctly but then if you click on "sculpture" for instance from the visual directory, it lists all posts instead of the ones that just have sculpture. You can see this here: http://www.whidbeylifemagazine.org/visual-specialty/sculpture/

 

I can't figure out what I did differently for the culinary members that the categories work for them and not the other member types. Somehow it seems to me that the WordPress loop isn't working right for these members.  Any help would be appreciated.

Share this post


Link to post
Share on other sites

1 answer to this question

Posted · Report post

Hi Jannon,

 

I'm sorry to see you're having difficulty with properly viewing your custom post types.  Unfortunately, this isn't my specialty or related to PageLines.  Nothing in PageLines would stop you from properly viewing posts, or even custom post types, custom taxonomies or search results.

 

Have you contacted the developer of the plugin used to develop these custom post types? Double checked settings?  It seems quite odd that it would be just one particular category.  That must be a setting that you may have missed or inadvertantly set incorrectly.  I say this because if it were a conflict with Framework or a deprecated plugin, then nothing would show at all.

 

One other thing it could be, which again isn't related to PageLines is a naming conflict.   For example, if you have two things named Chef in the same area, then WP doesn't know which one to view.  Highly unlikely, but perhaps a duplicate entry for that taxonomy?

Share this post


Link to post
Share on other sites