Jump to content


Photo
- - - - -

Issues Upgrading from PL 2.2.1 to 2.3.8 (running WP V3.4)

upgrade

Best Answer James B , 16 January 2013 - 02:25 AM

Hi there.

 

Looking through the changelog there's been quiet a few changes between 2.1.6 and 2.3.8, you might find there are some minor css elements which require updating. However it doesn't seem that we've amended anything relating to the sidebars or widgets during this time

 

http://api.pagelines.com/changelog

 

The images you've linked are coming up quiet small so i can't really see the differences. Are you able to upload a higher resolution. If you compare the css bewteen the original site and the updated version you might be able to see where the change in the layout is.

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 16 January 2013 - 12:45 AM

Doing an upgrade on another site. The upgrade works but my custom CSS seems to be affected. Checkout the attached. Note the widget titles. There are probably other CSS glitches....

 

I have reverted back to the original version of the site: 

Please Login or Register to see this Hidden Content

 

:zoro:

Attached Files



#2 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 16 January 2013 - 02:25 AM   Best Answer

Hi there.

 

Looking through the changelog there's been quiet a few changes between 2.1.6 and 2.3.8, you might find there are some minor css elements which require updating. However it doesn't seem that we've amended anything relating to the sidebars or widgets during this time

 

Please Login or Register to see this Hidden Content

 

The images you've linked are coming up quiet small so i can't really see the differences. Are you able to upload a higher resolution. If you compare the css bewteen the original site and the updated version you might be able to see where the change in the layout is.



#3 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 16 January 2013 - 12:26 PM

Hello @James B: My issue is clearly with CSS. The widget Title's CSS has changed with the upgrade (h3.widget-title). This is not the first time this has happened to me with a PL upgrade. It's maddening inasmuch as it pretty easy to miss a succinct visual change when doing a platform upgrade. Even more disturbing is that the changelogs do not seem to reflect any changes in CSS. Why would one change styling selectors when doing a platform upgrade? It's fine as long as custom.css is not involved.

 

Anyways, I have no choice... Do the upgrade.... and then hunt and peck for little tweaks that may need to be done... ("minor css elements"). It's just messy, and really not needed.

 

:growl: (I am  :D inside).



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17600 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 16 January 2013 - 01:36 PM

Hi WebWerx,

 

The images you have attached are super tiny and I am unable to see the issue.

 

We apologise that you have encountered an issue, but we do recommend users keep their sites up to date to prevent any issues. I will resolve this topic.



#5 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 16 January 2013 - 01:46 PM

Hey @Danny: Ya they are small because of the size limitations of the Forum upload.... Sorry. As mentioned above, my issue appears to have been caused because of a change in CSS selectors in the core code. If I didn't do so much customization, this issue would probably have never surfaced and the upgrade would have been flawless.

 

Keeping a site updated with PL updates is useless if you guys change your CSS selectors along the way..... Just sayin'.....







Also tagged with one or more of these keywords: upgrade