Archived

This topic is now archived and is closed to further replies.

  • 0

compiled css not converting to https

Question

Posted · Report post

I am running pagelines with a custom childtheme for a site. For some reason on the SSL secured page the css is not loading, after a little inspection I see the following with Chrome inspector

 

The page at https://www.practitionersmemo.com/membership-account/membership-checkout/?level=1&doing_wp_cron=1358288485.2240259647369384765625 ran insecure content from http://www.practitionersmemo.com/wp-content/themes/pagelines/pagelines-compiled-css-1_1358284691/.

 

Any reason why the compiled css does not convert to https to secure it?

 

Example page in question is: https://www.practitionersmemo.com/membership-account/membership-checkout/?level=1

 

Share this post


Link to post
Share on other sites

7 answers to this question

Posted · Report post

Hi there, I've found the below information from one of our developers on another post which may assist you.

 

" the CSS is only written once and cached, so if its cached on a non-ssl page the css is going to be non-ssl on the ssl page, if you follow.

 

So your choices are:

 

  • Force the CSS to never cache and re-generate on ever pageload (!)
  • Force the CSS to be SSL on all pages, including non-ssl pages.

 

add_action( 'pl_force_ssl', '__return_true' );
Use the above to force the css to be ssl "
 
 
Let us know if that helps or if you require further assistance

Share this post


Link to post
Share on other sites

Posted · Report post

I've actually added the force ssl to the functions page, still does not seem to load ssl. Unless it goes somewhere other than that.

 

I can't imagine why it can not compile either a relative path or 2 versions for https and http. Seems like a pretty serious omission.

Share this post


Link to post
Share on other sites

Posted · Report post

The framework uses the default WordPress site_url, if your using SSL then the URL is SSL.

 

You are using a 3rd party plugin to fool WordPress into thinking its SSL for one page. We cannot support every 3rd party SSL plugin so we supply that filter that james quoted that forces the css to always use an ssl url.

If that action is not working you have either added it in the wrong place, or your looking at a cached page.

It needs to go in a wordpress child theme, like the free 'base' child theme, and the theme needs to be active.

Share this post


Link to post
Share on other sites

Posted · Report post

The plugin was added after I tried the force ssl and it did not work, and since has been deactivated.

 

The force ssl is added to the child theme. Just looking for a little support here, it doesn't seem like I am the only one who has had this problem, but after 4 hours of searching I've yet to find an answer. 

Share this post


Link to post
Share on other sites

Posted · Report post

Did you have any caching plugins active? Anything that could be masking the changes?

 

Have you made any changes or inserted any code for the ssl rules into the htaccess file?

 

If you've installed the base child theme to paste the code into the functions.php, is the base theme the active theme in appearance>themes

 

If none of the above apply can you enable the debug option in Pagelines>site options>advanced and click save.

Share this post


Link to post
Share on other sites

Posted · Report post

No caching, I always wait until I am 100% done with a site before installing caching. No htaccess modifications. Theme is active.

 

I just turned debug on, thanks for the help.

Share this post


Link to post
Share on other sites