Jump to content


Photo
- - - - -

Fatal error after updating plugin



This topic has been archived. This means that you cannot reply to this topic.
29 replies to this topic

#1 thebrasseffect†

thebrasseffect

    Member

  • DMS Subscriber†

  • 29 posts

Posted 15 January 2013 - 02:25 PM

I just tried to update a pluging on site

Please Login or Register to see this Hidden Content

and I received this error Fatal error: Cannot redeclare class lessc_formatter_compressed in /home/content/54/7527054/html/firstcme/wp-content/themes/pagelines/includes/less.plugin.php on line 3326

 

How do I get this corrected?



#2 Jenny†

Jenny

    Advocate

  • DMS Subscriber†
  • 2924 posts

Posted 15 January 2013 - 03:23 PM

What plugin were you updating?

 

I haven't seen that issue before but have you tried renaming the plugin folder (the one you were updating) via FTP or your host's file manager?



#3 thebrasseffect†

thebrasseffect

    Member

  • DMS Subscriber†

  • 29 posts

Posted 15 January 2013 - 03:28 PM

I believe it was an "All in one calendar" plugin but I"m not 100% sure. I haven't tried to rename any folder because I wasn't sure what to do. If I try to rename the folder will it get re-created or do I have to try and overwright it someway?



#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 15 January 2013 - 03:36 PM

You should try renaming the folder and see if the problem persists.



#5 thebrasseffect†

thebrasseffect

    Member

  • DMS Subscriber†

  • 29 posts

Posted 15 January 2013 - 04:35 PM

I found the "All in one event calendar" folder and deleted the folder and now the website is back active. Thanks for all the help.



#6 Jenny†

Jenny

    Advocate

  • DMS Subscriber†
  • 2924 posts

Posted 15 January 2013 - 05:28 PM

Then there you go :)  The plugin had bad code in it somewhere. Definitely don't install it again, and always make sure you're using up to date and high-rated plugins on your site.



#7 riverregionarts

riverregionarts

    Newbie

  • Members
  • 1 posts

Posted 15 January 2013 - 07:01 PM

I deleted the All-in-one folder as well, and the Pagelines theme will still not activate: Parse error: syntax error, unexpected T_CLASS, expecting T_FUNCTION in /home2/rcrimcom/public_html/wp-content/themes/pagelines2/includes/less.plugin.php on line 3328



#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 15 January 2013 - 07:20 PM

You have edited less.plugin.php

 

Download a fresh copy of the framework.



#9 jeb

jeb

    Newbie

  • Members
  • 4 posts

Posted 16 January 2013 - 08:55 PM

Hi there,

 

I had the same issue when updating the premium version of the Timely "All in One Calender" from version 1.8.4 to 1.9.  This is a very well documented and maintained plugin.

 

It seems that both the Pagelines Framework and the new calendar version are using the LESS thingy. There is a conflict between both uses of it.

Given the error message above, when Pagelines tries to use some of the classes of LESS, they have already been instantiated by the calendar. or vice versa. At least one plugin need to check whether the LESS thingy has already been loaded.

 

Some people suggest to use autoload (whatever that is; you will probably know):

See:

Please Login or Register to see this Hidden Content

 

See also the Timely calendar forum for a similar error description there:

Please Login or Register to see this Hidden Content

 

Please help with that issue as the calendar is widely used. Deinstalling or not updating that plugin is definitely NOT an option.

 

 

 



#10 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 16 January 2013 - 09:13 PM

Yes the next version addresses this.



#11 awarne

awarne

    Newbie

  • Members
  • 1 posts

Posted 17 January 2013 - 11:03 PM

Hello.

Do you know when the next version of Pagelines will be released?

Thanks



#12 James B†

James B

    Advocate

  • DMS Subscriber†
  • 5126 posts

Posted 18 January 2013 - 12:39 AM

Edit - checked with core team, next version out soon.



#13 caleb†

caleb

    Member

  • DMS Subscriber†
  • 16 posts

Posted 18 January 2013 - 02:28 AM

Hi,

 

Could you suggest a work around in the mean time?  Any place this could be changed in the core files to hold us over?  

Please Login or Register to see this Hidden Content

 

Thank you,



#14 James B†

James B

    Advocate

  • DMS Subscriber†
  • 5126 posts

Posted 18 January 2013 - 03:43 AM

2.4 has now been released, if you're having problems with this plugin please update :-)



#15 chules†

chules

    Super Member

  • DMS Subscriber†
  • 155 posts

Posted 18 January 2013 - 04:32 PM

James,

 

The update to 2.4 does not fix the problem.  With this update the installation works well but the minute you add an event to Timely the site crashes.  I am going to rename the Timely plugin to bring my site online.  Pagelines, thank you for helping with this issue.  Just wanted to update anyone who is experiencing this problem.  Chules



#16 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 18 January 2013 - 05:10 PM

Crashes how? Locks up your server? produces an error? if so whats the error? 

 

i was able to create events, admittedly i had to turn off debugging as the plugin produces a fair few php warnings, but apart from that it works.



#17 chules†

chules

    Super Member

  • DMS Subscriber†
  • 155 posts

Posted 18 January 2013 - 06:31 PM

When you create an event and save it you get a white screen and can no longer access your website.  It is the same situation as before the new release where you "white screened" your computer when trying to install the plugin.  To get the site back you need to remove the plugin.  I have now reinstalled the plugin so installation is working but if I create a new event the site will "white screen" once again.

 

Thank you - chules



#18 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 18 January 2013 - 06:39 PM

Enable wp_debug in wp-config.php then paste the errors

#19 jeb

jeb

    Newbie

  • Members
  • 4 posts

Posted 19 January 2013 - 09:30 PM

Thanks for the quick help. Update to 2.4 works fine for me.



#20 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 22 January 2013 - 12:06 AM

Chules,

 

I'm not sure if you have a cache plugin, but if so, please clear the cache within the plugin, then clear your browser's cache. Often the updates or changes are not seen because they get caught up in the cache.