Jump to content


Photo
- - - - -

Pageless issues loading time

pageless speed

  • Please log in to reply
17 replies to this topic

#1 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 08 January 2013 - 11:07 AM

Hi there,

 

We're having loading issues regarding to pageless file. We can't figure out what the problem is; some sites having "compiled" working better, it seems. Don't know where to adjust.

 

We've read the issues 

Please Login or Register to see this Hidden Content

 and 

Please Login or Register to see this Hidden Content

. We tested with and without W3 Total Cache (apc).

 

We added define( 'LESS_FILE_MODE', true ); to wp-config of the wp network.

 

It's a wordpress network installation with 

Please Login or Register to see this Hidden Content

 (we still have to adjust the images :-)) as main site. Subdomain install with f.e. 

Please Login or Register to see this Hidden Content

 as multisite. At both, pagelines debug is activated now. All sites in the network use the pagelines framework with a custom pagelines child theme. Pages are small but load time is extremely high, except sometimes for the mainsite, but still the pageless file seems to slow down this one as well. Analysis via tools.pingdom.com and webpagetest.org result all in showing issues/extreme load time with the pageless file.

 

In some other wordpress-network-pagelines-installs we see compiled-css files, some others show pageless.

 

Again, we have tested this with and without W3 Total Cache. Issues are the same in both situations.

 

Thank you for your time.

Attached Files



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 15103 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 January 2013 - 11:39 AM

Hi,

 

Your sites and pages are loading fine for me, not slow at all, in fact there instant ?

 

Have you resolved the issue ?



#3 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 08 January 2013 - 12:31 PM

Hi Rockstar :-),

 

Main site Recruytment.nl just loaded in over 10 seconds, with page size 428kb.

Subsite recruitmentpartners.nl just loaded in 10.82 seconds, with page size 177kb.

See the attached file, pageless file takes 5 about seconds.

 

I have sites with over 1mb loading in 2 seconds. Using the same vps, pagelines and w3tc.



#4 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 08 January 2013 - 12:34 PM

pingdom_recruitmentpartners.jpg



#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 15103 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 January 2013 - 12:56 PM

First of all please disable W3 Total Cache, if your site is still under construction, being designed etc.., then the plugin shouldn't be active. Only enable it when site design is finalised.

 

Also, if you go directly to your Compiled CSS file, it loads instantly, the compiled CSS file is not to blame.

 

If your page size is 177.5KB and is taking over 10seconds to load, this is server related in my opinion. However, I will speak with one of our developers, who is a bit of a boffin with server setups, load speed etc.. and reply here when I have more information.



#6 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 08 January 2013 - 02:17 PM

Thanks. Would be great to hear from you/your developers.



#7 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 08 January 2013 - 03:28 PM

The css will not be written out to a css file because you have opted to run PHP in mod_php mode as the user apache. So if it writes a file, you cant delete it via FTP, unless you are actually called apache lol.

 

You can overide the checks for this and try and force the css to be written to a file with the following:

 

 

Please Login or Register to see this Hidden Content



#8 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 08 January 2013 - 04:10 PM

Hi Advocate!

 

We've added the line in de child theme functions.php

 

Somehow this does not work?

 

We've asked our hoster CloudVPS.com to change "PHP User: Posix functions are disabled on this host".



#9 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 08 January 2013 - 05:23 PM

There is not much we can do here if you have enabled that filter and it still isnt writing a css file.

 

No way for me to check as you still have w3 cache on. Is it a busy site?



#10 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 08 January 2013 - 06:59 PM

w3 cache is on (see at bottom page source), but will de-activate now



#11 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 08 January 2013 - 07:03 PM

If you activate PageLines debug mode in advanced settings it might give a clue why the file mode isnt working.



#12 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 08 January 2013 - 07:45 PM

debug mode is activated on both recruytment.nl and recruitmentpartners.nl

w3 total cache disabled at both



#13 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 08 January 2013 - 07:54 PM

Theres only a few things that will stop the file mode from working...

 

Your uploads dir is is not writable.

 

You have PL_NO_DYNAMIC_URL set to true.

 

Your server is running with PHP as apache/www-data etc

We already know this is the case, and if its a VPS why are you running php as user apache anyway? Its the most unsecure way of doing it!

The filter I supplied earlier bypasses the check.

 

Before you disabled W3 I checked your site in pingdom and the css was loading in < 300ms whole site was 1.1s The twitter widget down the bottom was taking longer to load than the css file.



#14 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 08 January 2013 - 07:59 PM

Uploads dir seems to be an issue regarding to wp network installs; uses /blogs.dir/; will 777 them

 

pl_no_dynamic... don't understand what to do

 

php/apache/www-data... we will forward your message to our hoster CloudVPS.com

 

Yeah, loading time of the main site recruytment.nl was not an issue; seems like multi-sites are having problems; in fact only regarding to the pageless file (5 seconds of the 10)



#15 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 08 January 2013 - 08:01 PM

Why contact your host? Its a VPS isn't it? You manage it yourself.

 

Did you install apache/php? Is it a control panel?



#16 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 08 January 2013 - 08:09 PM

:-) because anything regarding to the technical... is way out of my league

pre-installed vps, CentOS5 with directadmin control panel

also vps control interface, terminal, but we do not have any experience with this :-(



#17 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 08 January 2013 - 08:12 PM

Well directadmin has a huge community forum here: 

Please Login or Register to see this Hidden Content

First thing you need to find out is how to switch apache and php to run in either suPHP or mod_fcgid mode.



#18 perininero

perininero

    Advanced Member

  • Members

  • 76 posts
  • LocationThe Hague, The Netherlands
  • Framework Version:DMS and former PL
  • Country: Country Flag

Posted 10 January 2013 - 03:12 PM

Hi again Advocate!

 

In the meanwhile, we tried something else, with our wordpress network (multisite) subdomains install.

Huge performance improvements.

 

First we switched off, at networksettings/domain mapping:

1. remote login

4. redirect admin pages

 

Then we deactivated W3TC at the subdomains.

Reactivated per subdomain.

Created a new CDN per subdomain.

 

Testing now but huge improvements.

 

Furthermore, maybe it's a good suggestion to add more info at the debug info page, like what to change if certain settings are not good. For non-technical-heroes like us, a statement like "sections dir not writable" automaticly delivers the quesstion: should this be writable?

 

So far so good, now more testing and optimizing vps.

 

Thanks!







Also tagged with one or more of these keywords: pageless, speed