Archived

This topic is now archived and is closed to further replies.

  • 0

Front Page - Turn Off Title?!?

Question

Posted · Report post

I know this has got to be an easy fix...but I'm wrecking my brain trying to figure it out.

 

I'm have a static home page...and I pretty much just want an image and some text centered on that page.  The problem is...the title of the page keeps appearing formatted at the top/left of the page.  Ugh!  lol

 

Any quick advice....

 

Eileen

Share this post


Link to post
Share on other sites

8 answers to this question

Posted · Report post

Eileen,

 

There's a page number for every page.  You can find it usually in the edit mode of the page, often in the URL in the browser's address bar.

 

Find it, and make a note of it.

 

Then, add this code, where XX is replaced by the actual page number:

.page-id-XX h1, .fpost .entry-title {
    display: none;
    font-size: 150%;
}

This will remove the page title ONLY for that page.

 

Add the revised code to Dashboard > PageLines > Site Options > Custom Code > CSS Rules.

Share this post


Link to post
Share on other sites

Posted · Report post

...quick followup question.

 

This obviously removes the Page Title from ALL pages.  I was hoping to just remove it from (1) page.  Is there a way to do that...?!?

 

Eileen

Share this post


Link to post
Share on other sites

Posted · Report post

Eileen, you can either hide it with CSS, or use a php filter (pagelines_post_title_output).

Share this post


Link to post
Share on other sites

Posted · Report post

hmmm....that might be a little above my pay grade.  ;-)  Thanks though...

Share this post


Link to post
Share on other sites

Posted · Report post

Came across this post today as I had the same need as Eileen.

 

However, using Rob's suggested code to hide the post title, I discovered the  H1 output by the Masthead section I had on the page  was hidden as well.

 

A small change resolved that problem

.page-id-XX h1.entry-title {
    display: none;
}

 

 

Not sure what the class=searchlite  was for so I removed that. (I'm new to less/bootstrap, so perhaps it needs to be there for another reason?)

 

I also found this plugin useful http://wordpress.org/extend/plugins/hide-title/ if you want to hide other titles singularly.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks!

Share this post


Link to post
Share on other sites

Posted · Report post

In the main settings, there is an option to turn off page titles.

Share this post


Link to post
Share on other sites

Posted · Report post

To clarify Simon's guidance, go to Dashboard > PageLines > Site Options > Website Setup.  Scroll down to Page Titles and uncheck the box.  This will stop page titles from showing on the page.

Share this post


Link to post
Share on other sites