Jump to content


Photo
- - - - -

Wrong author page link on post/page


  • Please log in to reply
10 replies to this topic

#1 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts
  • Country: Country Flag

Posted 06 January 2013 - 10:48 AM

Hi to all,

 

with Rich Snippet test tool I discovered that all my posts and pages link to a wrong author page

Each post or page linking to www.turismopesaro.com/**POST-URL**/author/VacanzePesaro/ instead they should linking to

Please Login or Register to see this Hidden Content

 

How can I solve it?

 

Thanks in advanced

Bye

Michel



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 15194 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 06 January 2013 - 10:57 AM

Hi,

 

I have reviewed your website and all the author links appear to be linking to the correct author page, can you provide a link where this isn't the case please.



#3 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts
  • Country: Country Flag

Posted 06 January 2013 - 11:13 AM

Hi Danny,

thanks for your reply on Sunday :)

Google Rich Snippet tool find the error on each page...

I upload some screenshot

 

www.turismopesaro.com/download/1.jpg

www.turismopesaro.com/download/2.jpg

www.turismopesaro.com/download/3.jpg



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 15194 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 06 January 2013 - 11:20 AM

As far as I know, we haven't had any other reports of users having this issue and I have no experience with the Google Rich Snippet tool. Are you sure you have configured the Rich Snippet tool correctly.



#5 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts
  • Country: Country Flag

Posted 19 January 2013 - 11:05 AM

sorry but...

 

 Are you sure you have configured the Rich Snippet tool correctly

 

what have I to configure????



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 21 January 2013 - 10:53 PM

Buongiorno Michel,

 

I'd suggest updating your permalinks. To do this, go to Dashboard > Settings > Permalinks.  Do not change anything. Simply click the Save button which should update all links on your site.  Let me know if this works.



#7 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts
  • Country: Country Flag

Posted 22 January 2013 - 07:50 AM

Thanks for your reply Rob.

I followed your instruction, but it doesn't s still work

Please Login or Register to see this Hidden Content



#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 22 January 2013 - 03:21 PM

Can you please try deactivating all active non-PageLines plugins?



#9 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts
  • Country: Country Flag

Posted 22 January 2013 - 04:11 PM

Thanks for yiur help Catrina.

I deactivated all plugins and resaved my permalink settings and now it works!

 

now I try to activate a plugin at a time to figure out which is causing the problem



#10 benz_admin

benz_admin

    Advanced Member

  • Members
  • 65 posts
  • Country: Country Flag

Posted 22 January 2013 - 04:19 PM

the plugin who generate the error is: Wordpress SEO by Yoast

 

How can I solve it?

I wouldn't give up to this plugin because it is the best for me at the moment...



#11 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 22 January 2013 - 04:35 PM

I use wp-seo on my blog and the google thing validates 100%

 

Impossible to see what info is on your site as you are using caching and minifying the HTML too.

 

If you want us to help debug something please let us at least see the page source.