Jump to content


Photo
* * * * * 1 votes

IE9 Issue - Sidebars not showing in the right place.

ie9 layout sidebars css

Best Answer Simon_P , 07 January 2013 - 01:57 PM

Your server is adding this to the header of every PHP page: http://screencast.com/t/OMilJoxM2gsi

 

Basically tells internet explorer to only work in ie7 mode.

 

Contact your host and ask why this is.

Go to the full post


  • Please log in to reply
26 replies to this topic

#21 joaoreis

joaoreis

    Advanced Member

  • Members
  • 30 posts
  • LocationPorto alegre
  • Framework Version:v2.3.8
  • Country: Country Flag

Posted 07 January 2013 - 01:46 PM

This is what i found inside the wp-config.php.

 

I've added the code you said above one of the lines, i don't with it is the right place.

 

Please Login or Register to see this Hidden Content



#22 Danny

Danny

    Is Awesome!

  • Moderators
  • 15163 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 07 January 2013 - 01:50 PM

This is in a language I can not read, also in future do not post huge lines of code, please use our paste service

Please Login or Register to see this Hidden Content

 

The WP Define Debug line of code is standard in all Wordpress installation, please add the line of code I gave you previously underneath the debug line of code. If you can not find WP Define Debug then its sounds like there is something wrong with your installation.

 

If that doesn't work, please reply here, as its most likely an issue with your server.


  • joaoreis likes this

#23 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 07 January 2013 - 01:57 PM   Best Answer

Your server is adding this to the header of every PHP page: 

Please Login or Register to see this Hidden Content

 

Basically tells internet explorer to only work in ie7 mode.

 

Contact your host and ask why this is.


  • joaoreis likes this

#24 joaoreis

joaoreis

    Advanced Member

  • Members
  • 30 posts
  • LocationPorto alegre
  • Framework Version:v2.3.8
  • Country: Country Flag

Posted 07 January 2013 - 03:22 PM

Danny,

 

 Sorry for the huge code.

 

 Now I've added the line you said.

 

 Here are the messages:

 

Notice: Use of undefined constant get_magic_quotes_gpc - assumed 'get_magic_quotes_gpc' in /home/desenv/www/wp-content/plugins/cforms/lib_functions.php on line 360

Notice: Undefined index: sps_action in /home/desenv/www/wp-content/plugins/statpress-seolution/statpress.php on line 16

Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/desenv/www/wp-includes/functions.php on line 2824

Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/desenv/www/wp-includes/functions.php on line 2824

Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/desenv/www/wp-includes/functions.php on line 2824

Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/desenv/www/wp-includes/functions.php on line 2824

Notice: load_plugin_textdomain foi chamado com um argumento que está obsoleto desde a versão 2.7 sem nenhuma alternativa disponível. in /home/desenv/www/wp-includes/functions.php on line 2910

Notice: Undefined offset: 1 in /home/desenv/www/wp-content/plugins/statpress-seolution/statpress.php on line 834

Notice: Undefined index: rcommentid in /home/desenv/www/wp-content/plugins/wp-recaptcha/recaptcha.php on line 481

Notice: Undefined index: rchash in /home/desenv/www/wp-content/plugins/wp-recaptcha/recaptcha.php on line 482

Notice: Undefined index: aiosp_front_meta_tags in /home/desenv/www/wp-content/plugins/all-in-one-seo-pack/aioseop.class.php on line 346

Notice: Undefined index: cforms_no_css in /home/desenv/www/wp-content/plugins/cforms/cforms.php on line 1048



#25 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 07 January 2013 - 03:33 PM

You may as well turn off debug. All those notices are from poorly coded plugins. The problem is highlighted in my reply above, please show your host the screenshot and ask why ie7 mode is being forced
  • joaoreis likes this

#26 joaoreis

joaoreis

    Advanced Member

  • Members
  • 30 posts
  • LocationPorto alegre
  • Framework Version:v2.3.8
  • Country: Country Flag

Posted 07 January 2013 - 04:48 PM

Thanks! Danny, Simon_P and everyone that helped, the problem was ie7 mode. 

Please Login or Register to see this Hidden Content



#27 counterstrike

counterstrike

    Newbie

  • Members
  • 1 posts
  • Country: Country Flag

Posted 22 January 2013 - 12:36 AM

@ JOAOREIS, what was the resolution to the problem?

 

I'm Having the same issue, site works fine when I disable compatibility view mode in IE9







Also tagged with one or more of these keywords: ie9, layout, sidebars, css