Archived

This topic is now archived and is closed to further replies.

  • 0

How to create a page that shows only one category?


Question

Posted · Report post

Hi,

I have been looking for a solution that a page loads only a specific category. For example: I like that the Page Tutorials shows only the Tutorials category.  I really appreciate your suggestions.

 

Thanks,

Amir

 

Share this post


Link to post
Share on other sites

6 answers to this question

Posted · Report post

Amir,

 

A category page is always accessible, if you know the link and have the taxonomy set up. You can find and view a Category page by going to Dashboard > Posts > Categories and on hover over the Category title, click "View".

 

Category templates at the Page Template and Content Area levels are fully customizable, but there's no specific 'page' to apply anything to and you can't access settings for special pages. 

 

You can always create Category pages manually, and apply plugins to pull category-specific content onto them.

Share this post


Link to post
Share on other sites

Posted · Report post

One Smart Egg,

 

I have read about using the link for the category and point the page to that link using plugins.  The problem is that I am working on my wordpress/pageline website to replace it with my existing website that I have been using with Joomla in many years.  The problem is that the entire URLs for all my posts and blogs could get changed which isn't good for SEO.  The main problem is that Wordpress adds the word "category" into all URLs for each individual category.  For example: www.revitclinic.com/category/tutorials

 

Do you have any suggestion how to cut the word "category" from the URLs?

 

Thanks,

Amir

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Amir,

 

This is a issue with Wordpress, therefore you will need to ask this question on the Wordpress support forums.

Share this post


Link to post
Share on other sites

Posted · Report post

Advocate,

thank you for providing those links.  I found the correct answer and it works.  I just insert the correct answer in my post if anyone else is looking for it:

 

In your Permalinks options, set your

 

"Custom Structure" to:

/%category%/%postname%/

and your

 

"Category Base" to:

/.

Share this post


Link to post
Share on other sites

Posted · Report post

PageLines Rockstar,

 

I guessed it before too that it is a Wordpress question, but would you help me with your professional knowledge?  I am sure you know how to fix this problem.

 

Thanks,

Amir

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there,

 

As Danny said unfortunately as it's a wordpress issue we wouldn't be able to advise, however I have found the two posts below which might be able to help you further.

 

http://wordpress.org/support/topic/remove-the-category-from-url

 

http://wordpress.org/extend/ideas/topic/remove-category-base-from-permalinks

 

Please make sure you back everything up before making any changes.

Share this post


Link to post
Share on other sites