Jump to content


Photo
- - - - -

Whitescreen after importing settings


  • Please log in to reply
37 replies to this topic

#21 Guido

Guido

    Advanced Member

  • Members

  • 48 posts
  • Country: Country Flag

Posted 04 January 2013 - 07:49 PM

I dont know what hardened php is - i have not compiled it, everything was ready when i accessed the webserver for the first time. This is the reason why i cannot change the setup, i am not able to do it.



#22 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 04 January 2013 - 07:51 PM

Its your VPS right? You have root access?

 

Or is it someone elses VPS and they have let you add your site to it?



#23 Guido

Guido

    Advanced Member

  • Members

  • 48 posts
  • Country: Country Flag

Posted 04 January 2013 - 08:09 PM

Yes it is mine - in theory i could make my own setup. But i am not able to. Thats why this hosting package is called "virtual server managed"... what in this case means "not managed". It has at least some drawbacks but is still better than some shared hosts afaik.



#24 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 04 January 2013 - 09:15 PM

A VPS will always be better than a shared host, but you need to figure out how to properly install Apache/PHP. Ideally these days people use Nginx with phpfpm as its so much faster than the old apache.



#25 Guido

Guido

    Advanced Member

  • Members

  • 48 posts
  • Country: Country Flag

Posted 13 January 2013 - 06:43 PM

After a lot of effort the problem is solved as far as i can make it. Pagelines and suhosin are no friends. When suhoshin is set simulation mode, it does only log and is not blocking anything. With suhosin simulation mode turned on, the import works fine (like on any cheap shared hosts).

 

The logfile shows:

 

Jan 13 19:15:48 Debian-60-squeeze-64-LAMP suhosin[13906]: ALERT-SIMULATION - Include filename is an uploaded file (attacker '80.81.xxx.xxx', file '/var/www/xxx/wordpress/wp-content/themes/pagelines/includes/library.options.php', line 898)

 

This problem was discussed in at least two topics here before:

Please Login or Register to see this Hidden Content


Please Login or Register to see this Hidden Content

 

 

Anyhow, whatever it is, (maybe a bug) my settings.dat is now uploaded and i hope it will help others with the same problem.


  • nondualit likes this

#26 nondualit

nondualit

    Member

  • Members
  • 18 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 16 January 2013 - 06:10 PM

After a lot of effort the problem is solved as far as i can make it. Pagelines and suhosin are no friends. When suhoshin is set simulation mode, it does only log and is not blocking anything. With suhosin simulation mode turned on, the import works fine (like on any cheap shared hosts).

 

The logfile shows:

 

Jan 13 19:15:48 Debian-60-squeeze-64-LAMP suhosin[13906]: ALERT-SIMULATION - Include filename is an uploaded file (attacker '80.81.xxx.xxx', file '/var/www/xxx/wordpress/wp-content/themes/pagelines/includes/library.options.php', line 898)

 

This problem was discussed in at least two topics here before:

Please Login or Register to see this Hidden Content


Please Login or Register to see this Hidden Content

 

 

Anyhow, whatever it is, (maybe a bug) my settings.dat is now uploaded and i hope it will help others with the same problem.

 

Fantastic Guido, after reading lot of post not guiding me to any direction, your fix was the fix for my issue also.

 

for everyone: if you are using Debian 

 

/etc/php5/apache2/php.ini

 

 

3) Open the php.ini file and add the following code to the file:

[suhosin]
; Misc Options
suhosin.simulation = On

[On indicates disabled, Off indicates enabled]

 

restart apache & everythng works again



#27 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 16 January 2013 - 06:15 PM

You should really be disabling suhosin on a per directory basis, either in its config or using .htaccess. Completely turning it off defeats the object of having it installed in the first place.



#28 flowcom

flowcom

    Newbie

  • Members
  • Pip
  • 1 posts
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 16 January 2013 - 07:08 PM

Thank you very much!



#29 Guido

Guido

    Advanced Member

  • Members

  • 48 posts
  • Country: Country Flag

Posted 16 January 2013 - 10:15 PM

After uploading the settings.dat suhosin can be enabled again. If it is not needed to upload settings files every day, one can live with this issue.

 

To workaround general uploadproblems with suhosin you can whitelist uploads in the php.ini with the following syntax:

 

suhosin.executor.include.whitelist = upload://

 

BUT in this case it does not help... maybe it is a real bug in pagelines or in suhosin..



#30 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 January 2013 - 02:56 AM

Hi Guido,

 

As we're not seeing volumes of clients saying that they're seeing a white screen when importing settings, my guess is suhosin may have some conflict.  It might well be with WP or one of the plugins you have, or even a bit of code. Honestly, I don't believe this to be a PageLines bug.

 

I'll keep this open in case someone can replicate the error.



#31 kaiserbrand

kaiserbrand

    Member

  • Members
  • 10 posts
  • LocationBerlin
  • Framework Version:2.3.6
  • Country: Country Flag

Posted 05 February 2013 - 03:41 PM

I can confirm Guido's issue: I am also with a German host and had a whitescreen when I tried to upload a .dat file via the PageLines import section (in my case the file included in the "citi" theme).

After turning on simulation mode of suhosin it worked fine.

 

Thank you for providing this information!!!!



#32 mackenzie

mackenzie

    Advocate

  • Members
  • 333 posts
  • Country: Country Flag

Posted 06 February 2013 - 05:11 PM

To the original poster - is this resolved or are you still seeing issues?



#33 Guido

Guido

    Advanced Member

  • Members

  • 48 posts
  • Country: Country Flag

Posted 07 February 2013 - 08:07 PM

The isue is still there - but i can live with it as long as i know that i have to stop suhoshin when restoring pagelines settings.



#34 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 07 February 2013 - 08:10 PM

You should really be disabling suhosin on a per directory basis, either in its config or using .htaccess. Completely turning it off defeats the object of having it installed in the first place.

You dont have to 'stop' suhosin.



#35 Guido

Guido

    Advanced Member

  • Members

  • 48 posts
  • Country: Country Flag

Posted 09 February 2013 - 09:40 AM

Thank you for the suggestion but it does not happen that often that i have to load up pagelines settings. When i need it, i switch it of and after wards i switch it on again. There is no other public website on this vServer so this option is better than disabling suhosin in the .htaccess



#36 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 09 February 2013 - 12:28 PM

You could have put the htaccess file in wp-admin Sent from my iPad using Tapatalk HD

#37 codesigner

codesigner

    Newbie

  • Members
  • 2 posts
  • Country: Country Flag

Posted 06 March 2013 - 07:52 PM

Nevermind



#38 James B

James B

    Advocate

  • Moderators
  • 4978 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 06 March 2013 - 11:31 PM

If anyone has any new issues with white screen, please start a new thread so the moderating team can pick it up as a new issue. :-)