Archived

This topic is now archived and is closed to further replies.

  • 0

Whitescreen after importing settings

Question

Posted · Report post

Hi,

 

i am not able to upload any settings.dat to my pagelines installation. This issue occurs on 2 different webservers and on any wp-installation (new installations without plugins). The error-logs dont have an entry according to this. We discussed it in the live chat and the moderator (i cannot remember her name) was able to import my .dat-file on her server - so the file itself is not the problem. I want to run my live-website with pagelines and therefore i need to import the settings from my sandbox-site. So i hope to solve the problem here in the forum.

 

I have made a new wp-installation to reproduce the issue - it is on www.neurofx.net/pagelines - please pm me for the login data. I hope you can find out the reason by uploading any settings.dat on this installation.

 

Regards, Guido

 

 

 

Share this post


Link to post
Share on other sites

37 answers to this question

Posted · Report post

Hi Guido,

 

As we're not seeing volumes of clients saying that they're seeing a white screen when importing settings, my guess is suhosin may have some conflict.  It might well be with WP or one of the plugins you have, or even a bit of code. Honestly, I don't believe this to be a PageLines bug.

 

I'll keep this open in case someone can replicate the error.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Guido,

 

I'm afraid I'm not strong enough on php to be able to go through the link you've provided and spot any errors successfully. However, have you checked with the host that the Php memory limit is set to over 128mb in php.ini file? Or any alterations to the functions.php?

 

Unfortunately this is quite a common wordpress issue, this link might be able to help you track it down further and there's some solutions suggested there as well which could help-http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-wordpress-white-screen-of-death/ and  http://wordpress.org/support/topic/white-screen-of-death-7

Share this post


Link to post
Share on other sites

Posted · Report post

After a lot of effort the problem is solved as far as i can make it. Pagelines and suhosin are no friends. When suhoshin is set simulation mode, it does only log and is not blocking anything. With suhosin simulation mode turned on, the import works fine (like on any cheap shared hosts).

 

The logfile shows:

 

Jan 13 19:15:48 Debian-60-squeeze-64-LAMP suhosin[13906]: ALERT-SIMULATION - Include filename is an uploaded file (attacker '80.81.xxx.xxx', file '/var/www/xxx/wordpress/wp-content/themes/pagelines/includes/library.options.php', line 898)

 

This problem was discussed in at least two topics here before:

http://www.pagelines.com/forum/topic/11043-settings-not-changed-on-import/
http://www.pagelines.com/forum/topic/10730-import-settings-not-working-take-ii/

 

 

Anyhow, whatever it is, (maybe a bug) my settings.dat is now uploaded and i hope it will help others with the same problem.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Update:

 

It is not like my websites are on a crappy host ;) It is a virtual server with 256MB php memory and a huge amount of php-apps can be installed per one click. So i hope, the most common sources of errors can be excluded.

 

At least i set the logging level of the webserver to E_ALL, debug in WP and Pagelines on - but still no message in the error logfile.

 

What could be the next step? My webhost says that they wont support third party applications.

Share this post


Link to post
Share on other sites

Posted · Report post

I can confirm Guido's issue: I am also with a German host and had a whitescreen when I tried to upload a .dat file via the PageLines import section (in my case the file included in the "citi" theme).

After turning on simulation mode of suhosin it worked fine.

 

Thank you for providing this information!!!!

Share this post


Link to post
Share on other sites

Posted · Report post

If anyone has any new issues with white screen, please start a new thread so the moderating team can pick it up as a new issue. :-)

Share this post


Link to post
Share on other sites

Posted · Report post

php settings

 

I have made exactly the same Pagelines installation on a cheap webhost with 90MB php memory and other limitations - without the whitescreen issue.
So i asume that it must be a uncommon (maybe not the core) php setting which does not match which the Pagelines-Import function. All other reasons can be excluded so far.
The php configuration is here http://www.silbertreu.de/info.php - some of them do not work with Pagelines.


But where to look at? All values which belong to PHP_INI_ALL or PHP_INI_PERDIR can be changed in the htaccess. Is there a checklist of essential php settings for Pagelines?

Share this post


Link to post
Share on other sites

Posted · Report post

Look at your display_errors settings, they are all off.

 

error_reporting is set to 337

As you can see here http://php.net/manual/en/errorfunc.constants.php

377 is not one of them.

 

I can see its a VPS, did you configure this yourself? Or is someone doing it for you?

 

As your running PHP in the very insecure mod_php mode with apache running as user 'nobody' you should be able to change php values in the .htaccess file.

 

We cannot setup your server/vps for you, the Framework has been tested in the 10 leading shared hosts and countless default PHP setups.

Share this post


Link to post
Share on other sites

Posted · Report post

I did not configure the VPS. The setup is provided by the host, which is also a leading host in germany. I cannot tell if it is a good setting or not because i have no experience in webhosting and php at all.

Btw, I have no doubt that Pagelines has been well tested ;-).

 

According to Your info i set temporarily the error reporting to 30719 - and for the first time i received a message in the error log:

PHP Notice: Undefined index: 00 in ../wp-includes/locale.php on line 257, referer: ../wp-admin/plugins.php?deactivate-multi=true&plugin_status=all&paged=1&s=
PHP Notice: Undefined index: 00 in ../wp-includes/locale.php on line 257, referer: ../wp-admin/admin.php?page=PageLines-Admin
PHP Notice: Undefined index: 00 in ../wp-includes/locale.php on line 257, referer: ../wp-admin/admin.php?page=pagelines_templates
PHP Notice: Undefined index: 00 in ../wp-includes/locale.php on line 257, referer: ../wp-admin/admin.php?page=PageLines-Admin

 

I hope this gives us a hint?

Share this post


Link to post
Share on other sites

Posted · Report post

Still doesn't really show anything.

 

Can you attach your settings file so i can look at it?

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you for the suggestion but it does not happen that often that i have to load up pagelines settings. When i need it, i switch it of and after wards i switch it on again. There is no other public website on this vServer so this option is better than disabling suhosin in the .htaccess

Share this post


Link to post
Share on other sites

Posted · Report post

You could have put the htaccess file in wp-admin Sent from my iPad using Tapatalk HD

Share this post


Link to post
Share on other sites

Posted · Report post

Yea there is absolutely nothing wrong with the file, i imported it to my standalone site and a multisite with all debugging on, and got no errors at all.

 

Your host is right, they will not support anything you install on your VPS, thats the point of a VPS, you do it yourself ;)

 

My advice is to look at your PHP configuration again.

 

As i said before:

 

 

 

As your running PHP in the very insecure mod_php mode with apache running as user 'nobody' you should be able to change php values in the .htaccess file.

Also noticed your running hardened PHP, do you know how to set that up?

Did you compile php and set it up your self? Or was it a one-click installer?

 

Share this post


Link to post
Share on other sites

Posted · Report post

I dont know what hardened php is - i have not compiled it, everything was ready when i accessed the webserver for the first time. This is the reason why i cannot change the setup, i am not able to do it.

Share this post


Link to post
Share on other sites

Posted · Report post

Its your VPS right? You have root access?

 

Or is it someone elses VPS and they have let you add your site to it?

Share this post


Link to post
Share on other sites

Posted · Report post

Yes it is mine - in theory i could make my own setup. But i am not able to. Thats why this hosting package is called "virtual server managed"... what in this case means "not managed". It has at least some drawbacks but is still better than some shared hosts afaik.

Share this post


Link to post
Share on other sites

Posted · Report post

A VPS will always be better than a shared host, but you need to figure out how to properly install Apache/PHP. Ideally these days people use Nginx with phpfpm as its so much faster than the old apache.

Share this post


Link to post
Share on other sites

Posted · Report post

After a lot of effort the problem is solved as far as i can make it. Pagelines and suhosin are no friends. When suhoshin is set simulation mode, it does only log and is not blocking anything. With suhosin simulation mode turned on, the import works fine (like on any cheap shared hosts).

 

The logfile shows:

 

Jan 13 19:15:48 Debian-60-squeeze-64-LAMP suhosin[13906]: ALERT-SIMULATION - Include filename is an uploaded file (attacker '80.81.xxx.xxx', file '/var/www/xxx/wordpress/wp-content/themes/pagelines/includes/library.options.php', line 898)

 

This problem was discussed in at least two topics here before:

http://www.pagelines.com/forum/topic/11043-settings-not-changed-on-import/

http://www.pagelines.com/forum/topic/10730-import-settings-not-working-take-ii/

 

 

Anyhow, whatever it is, (maybe a bug) my settings.dat is now uploaded and i hope it will help others with the same problem.

 

Fantastic Guido, after reading lot of post not guiding me to any direction, your fix was the fix for my issue also.

 

for everyone: if you are using Debian 

 

/etc/php5/apache2/php.ini

 

 

3) Open the php.ini file and add the following code to the file:

[suhosin]

; Misc Options

suhosin.simulation = On

[On indicates disabled, Off indicates enabled]

 

restart apache & everythng works again

Share this post


Link to post
Share on other sites

Posted · Report post

You should really be disabling suhosin on a per directory basis, either in its config or using .htaccess. Completely turning it off defeats the object of having it installed in the first place.

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you very much!

Share this post


Link to post
Share on other sites

Posted · Report post

The isue is still there - but i can live with it as long as i know that i have to stop suhoshin when restoring pagelines settings.

Share this post


Link to post
Share on other sites

Posted · Report post

You should really be disabling suhosin on a per directory basis, either in its config or using .htaccess. Completely turning it off defeats the object of having it installed in the first place.

You dont have to 'stop' suhosin.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

If one of our staff members were able to successfully install the theme settings file, this is most likely related to your servers configuration. Would it be possible for you to provide your servers php info as well as enable PageLines debug (Site Options > Advanced). Once you have provided this we will be able to investigate further.

Share this post


Link to post
Share on other sites