Archived

This topic is now archived and is closed to further replies.

  • 0

Drop down button issue: bullets, padding


Question

Posted · Report post

Hi there,

I love the shortcode buttons, so elegant and silky. But the split drop down button appears differently in different pagelines areas. Sometimes the drop down text has padding sometimes not, and the button appears in different sizes depending on in which section it's placed.

 

Currently, I'd like to see if there is a fix for the dropdown split button on this page:

http://ramacommunications.net/advertising-1/

 

Here the dropdown area has no padding on the left and, more seriously, has bullets appearing outside the dropdown box, on the left. Any fix?

Share this post


Link to post
Share on other sites

8 answers to this question

Posted · Report post

Hmm interesting, ok try the below to see if that overrides it. I can see in firebug its clearing them - http://screencast.com/t/n7cygi8sL

.dropdown-menu ul {

    list-style: none outside none !important;
}

 

Share this post


Link to post
Share on other sites

Posted · Report post

Dont see any bullet points, you do have 2 <p> tags in there though, can you show us the shortcode you are using?

Share this post


Link to post
Share on other sites

Posted · Report post

The bullet points appear when you click on the red Contact Us button and the drop down menu appears. Two bullets appear outside the drop down box, to the left. They appear whether in Firefox or Chrome or Safari. The button is inside a content box. These type of bullets do not appear when clicking on any other buttons throughout the site, even though I'm using the same code for them throughout. Also, there is no padding on the left of the drop down contents in this particular case, although in some other instances using this button there is padding-left.

 

The code is:

[pl_splitbuttondropdown size="large"
type="important" label="Contact Us"]
<ul>
	<li><a href="mailto:sue@ramacommunications.net">Email</a></li>
	<li>PHONE: 413.274.8595</li>

</ul>
[/pl_splitbuttondropdown]

Share this post


Link to post
Share on other sites

Posted · Report post

Thats weird i tried all 3 browsers, never saw a bullet.
 
You have 'carriage returns' in there, thats why wordpress adds a <p>
 


[pl_splitbuttondropdown size="large" type="important" label="Contact Us"]<ul><li><a href="mailto:sue@ramacommunications.net">Email</a></li><li>PHONE: 413.274.8595</li></ul>[/pl_splitbuttondropdown]

I know its harder to read, but its the only way to stop wp from adding <p> and <br>

Share this post


Link to post
Share on other sites

Posted · Report post

Oh, I believe that I just copied and pasted the code as it appeared on the Pagelines TOOLS page. That's incorrect? What is the result of <p> tags?

 

Even without the line breaks the drop down from the button has those bullets. Here is a link to a screenshot with the bullets circled:

 

http://ramacommunications.net/wp-content/uploads/2012/12/buttonDrpDwnBults.jpg

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there, yes that is correct, unfortunately the wordpress editor can add in unwanted breaks due to the way it formats the content. So the easy way to prevent this is to add it all as one block, like in Simon's example.

 

Could you try pasting this in to Pagelines>site options>custom code and see if the dots disappear

 

.dropdown-menu {

list-style: none;

}

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks, but that did not work.

Share this post


Link to post
Share on other sites

Posted · Report post

Ah, that worked! Thank you!

Share this post


Link to post
Share on other sites