Archived

This topic is now archived and is closed to further replies.

  • 0

Progid:dximagetransform Filter Screwing With My Form Buttons In Ie

Question

Posted · Report post

Hi guys. My form submit buttons in MSIE are all whited out, and won't take CSS background attributes. After hours of frustration, I found the culprit in the compiled CSS file. I opened up MSIE and pressed F12 and unchecked the culprit, and it solved the problem. Here's the culprit: filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#ffffff', endColorstr='#dcdcdc', GradientType=0). After I unchecked that in the MSIE editor, my buttons looked correct, rather than just a plain white square of nothing. I went into chat and asked how to disable it. Someone suggested I just add the filter param to my CSS and cancel it out. So I added the same line (found in the compiled css file), line 5545, and I just changed the colors to transparent. Unfortunately, this just added a second filter over the top of the first one, and what's more, instead of being transparent, it made my button turn a hideous blue. So when I went back into F12 of MSIE, I had to uncheck both filters to get the button to look right. There has to be a way to disable this, other than deleting the line from the compiled CSS source file, which will just be overwritten again next update, right?

Thanks for your help! 

Share this post


Link to post
Share on other sites

3 answers to this question

Posted · Report post

Found the solution already. Added this line to my custom css under the input.button class: filter: progid:DXImageTransform.Microsoft.gradient(enabled=false);

 

That did the trick. 

Share this post


Link to post
Share on other sites

Posted · Report post

Can you tell me exactly how you added this.  I am having the same problem + have now had two clients complain. 

Share this post


Link to post
Share on other sites

Posted · Report post

Use Firebug in Firefox. Click on the button and scroll through the Firebug CSS until you find the culprit, which may be this filter. You won't be able to just delete it, probably, because it's in the compiled CSS (whatever those things are, they're annoying). But in Firebug you'll be able to check/uncheck the CSS element to see its effect on the page. Once you've found the right culprit, copy and paste what it says into your CSS/LESS custom box on the Pagelines Site Options menu, and just do what I did above. If it's DXImageTransform, you just have to add (enabled=false); to the end, to override what's in your compiled CSS. 

Share this post


Link to post
Share on other sites