Jump to content


Photo
- - - - -

Consistant Issue W/ Features Section Upon Pagelines Framework Upgrades

Features Sections Pagelines Framework Upgrading

Best Answer rubyhaus , 18 December 2012 - 08:22 PM

Found my error with Thanks again to Simon. The error it's with Mobile Menu Version 1.2.0 | By Enrique Chavez

It was working before the Update and now suddenly not. Moving this into a different topic for specific Plugins problems.

Go to the full post


  • Please log in to reply
15 replies to this topic

#1 rubyhaus

rubyhaus

    Advanced Member

  • Members

  • 40 posts
  • Framework Version:Always Current
  • Country: Country Flag

Posted 18 December 2012 - 06:09 PM

For some reason every time I upgrade to a new version of Pagelines Framework, the Features Section seems to break.

In other words, instead of all slides being hidden except the one being viewed, they instead all for lack of better words Clear one another on the page and are all visible.

Anyone else having issues like this with Features?


dev.tviaudio.com

username: pagelines
password: developer



#2 dsh2000

dsh2000

    Advanced Member

  • Members
  • 44 posts

Posted 18 December 2012 - 07:01 PM

Yes, I'm having an issue as well after the upgrade.

 

It seems like all my sections are broken, and the css is not loading or displaying as it should.

 

Please Login or Register to see this Hidden Content



#3 dsh2000

dsh2000

    Advanced Member

  • Members
  • 44 posts

Posted 18 December 2012 - 07:05 PM

I'm also getting these strange errors that I have never seen before.

"PageLines Custom LESS/CSS error."

 

Also, the pagelines store is not displaying as it should.



#4 rubyhaus

rubyhaus

    Advanced Member

  • Members

  • 40 posts
  • Framework Version:Always Current
  • Country: Country Flag

Posted 18 December 2012 - 07:19 PM

Yup... Everyonce in a while you have to watch you CSS files closely. Sometimes the naming of ID's used and such within the structure is updated or changed. So you have to verify/mod your CSS with those changes as well.

 

As for the Store mine seems fine thus far.

 

Recently the LESS is a new integration to the framework over the last few months. But I'm not sure why you'd be getting any kind of error there.



#5 rubyhaus

rubyhaus

    Advanced Member

  • Members

  • 40 posts
  • Framework Version:Always Current
  • Country: Country Flag

Posted 18 December 2012 - 07:22 PM

Also be sure that after every upgrade, to go back into your Site Options of Pagelines and Save it at least once for good measure.

 

Also check your WordPress Widgets. Sometimes you have to reposition them in the right areas of your widgets etc... and check that your widgets ID's are the same as what you referenced within your CSS file.



#6 dsh2000

dsh2000

    Advanced Member

  • Members
  • 44 posts

Posted 18 December 2012 - 07:38 PM

Thanks for the reply.......glad to know I'm not the only one experiencing difficulties with the new Pagelines updates.

 

For me this is a nightmare!

 

I have a deal going on with the local ballet company for a promotion and the posts on my site are not even loading:

 

Please Login or Register to see this Hidden Content

 

I used to love Pagelines......oh man!!



#7 dsh2000

dsh2000

    Advanced Member

  • Members
  • 44 posts

Posted 18 December 2012 - 07:43 PM

I just went into my permalinks and set it back to default, saved those settings, then switched back to the custom settings and saved.

 

Now my css appears to be loading once again.



#8 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 18 December 2012 - 07:48 PM

Alot of FUD in this topic ;)

 

Ruby I replied to your bug report, you have a fatal javascript error on your page thats nothing to do with features.

 

dsh200, a compile error in customcss/less means you have some code in the custom css box that will not compile for whatever reason.

 

Also we have not changed any widget ID's for like a year or something.



#9 rubyhaus

rubyhaus

    Advanced Member

  • Members

  • 40 posts
  • Framework Version:Always Current
  • Country: Country Flag

Posted 18 December 2012 - 08:01 PM

I see your problem. It's in the Padding of the LESS/CSS file. Padding: 10px: should be Padding: 10px;

Note the colo vs. the instead needed semi-colon. Line 1411 in your CSS file. I think the LESS is just compiling the CSS for you. It's the little checkbox in your Pagelines Settings that does the Minifying CSS process.

 

I could be wrong but that may temporarily fix that till Pagelines updates the LESS/CSS file.



#10 dsh2000

dsh2000

    Advanced Member

  • Members
  • 44 posts

Posted 18 December 2012 - 08:02 PM

Thank you Simon,

 

I'm going over my css right now to find out why some of it is not compiling because I'm still getting the Less compile error.

 

Yeah, perhaps a little too much FUD on my part, apologies for that.



#11 rubyhaus

rubyhaus

    Advanced Member

  • Members

  • 40 posts
  • Framework Version:Always Current
  • Country: Country Flag

Posted 18 December 2012 - 08:06 PM

Thanks Simon for the Bug response. When I try to post over there it's hard to tell if it actually posted in a current area of the Bug Tracking.

 

But thanks again for your response. I'll look into it. It happens quite often on an update.

 

dsh2000 I could be wrong. Your CSS looks stellar but see if you can find a colon after your 10px padding number. Looked like the issue when I read your Orange Compile error buttons statement.



#12 dsh2000

dsh2000

    Advanced Member

  • Members
  • 44 posts

Posted 18 December 2012 - 08:08 PM

Thanks Rubyhaus,

 

That was the culprit.


  • rubyhaus likes this

#13 rubyhaus

rubyhaus

    Advanced Member

  • Members

  • 40 posts
  • Framework Version:Always Current
  • Country: Country Flag

Posted 18 December 2012 - 08:09 PM

Good deal. Happens to the best of us. Always the dumb semi-colon search. lol



#14 dsh2000

dsh2000

    Advanced Member

  • Members
  • 44 posts

Posted 18 December 2012 - 08:13 PM

I've never seen the LESS error before, but it is quite useful.


  • rubyhaus likes this

#15 rubyhaus

rubyhaus

    Advanced Member

  • Members

  • 40 posts
  • Framework Version:Always Current
  • Country: Country Flag

Posted 18 December 2012 - 08:22 PM   Best Answer

Found my error with Thanks again to Simon. The error it's with Mobile Menu Version 1.2.0 | By 

Please Login or Register to see this Hidden Content

It was working before the Update and now suddenly not. Moving this into a different topic for specific Plugins problems.



#16 rubyhaus

rubyhaus

    Advanced Member

  • Members

  • 40 posts
  • Framework Version:Always Current
  • Country: Country Flag

Posted 18 December 2012 - 08:35 PM

Alot of FUD in this topic ;)

 

Ruby I replied to your bug report, you have a fatal javascript error on your page thats nothing to do with features.

 

dsh200, a compile error in customcss/less means you have some code in the custom css box that will not compile for whatever reason.

 

Also we have not changed any widget ID's for like a year or something.

 

By the way just for clarification... I meant 3rd Party Widgets etc... I've usually found that for whatever reason when updating etc... sometimes I've notice when the widgets in the WordPress widget pull out of where they were placed and you place them back... The ID's are different than they were or... That party has updated there widget etc...







Also tagged with one or more of these keywords: Features, Sections, Pagelines Framework, Upgrading