Jump to content


Photo
- - - - -

Ie Compatibility

Internet Explorer

  • Please log in to reply
21 replies to this topic

#1 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 12 December 2012 - 01:27 PM

IE9 > website doesn't show up properly

 

I've searched the forums for the solution to my problem but I'm missing something for sure. I have two websites on my hands, both are almost the same:

 

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content

 

The first one display almost ok on Internet Explorer but the second one, doesn't.

 

What I can't understand is the fact that almost all the CSS and settings are the same. Only diference, the .com.cn sits on a chinese server.

 

Anyone can help here? I need the chinese to al least have the right font and layout displaying on Internet Explorer. It's no use to tell them to use another browser. Internet Explorer is still very popular...

 

I just tested the following:

 

Removed all custom code > it's not the problem

Deactivated plugins > it's not the problem 

 

:(



#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 December 2012 - 03:27 PM

Well one site is using version 2.3 of the full product, thats 8 revisions behind, and the other site is using an old version of the free version.



#3 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 12 December 2012 - 04:44 PM

updating now (feeling really stupid) :wacko:  the site that needs fix on IE9 is www.swissinternationalhotels.com.cn

 

ok, well now this one is updated but that didn't fix the problem. It's like most of the CSS just doesn't load.. what else am I missing ?



#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 12 December 2012 - 05:33 PM

Can you please take a screenshot of your site on IE and upload it here? I can't see the problem since I don't have IE.



#5 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 13 December 2012 - 08:46 AM

Here's the screen shot bellow:

 

Please Login or Register to see this Hidden Content

> this one is almost the same and looks fine on IE8 and IE9

 

but 

Please Login or Register to see this Hidden Content

doesn't. 

 

ps_1312.jpg



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 13 December 2012 - 10:28 AM

After looking at both sites, they aren't using the same plugins, which may be the cause. However, this is a rather odd issue, as according to BrowserStack, you sites displays correctly in IE8.

 

PageLines is compatible with IE9, so the only way your site would not function correctly, would be caused by the following:

 

  • Bad plugins
  • You have made changes to the core files
  • You have added custom code that isn't compatible with IE9

As both sites are on different servers, the server setup may have something to do with it. It may also be related to your custom CSS, I would check to see if there are any minor errors.



#7 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 13 December 2012 - 11:30 AM

I deactivated the plugins that the other site doesn't have to see if one of them was causing this. That wasn't the issue.

I removed the Custom CSS to see and compared but that wasn't the issue either. On IE,  the font that you choose on the pagelines settings is not displaying. So I guess the style sheet is not working. 

 

That only leaves me a server issu, but everything is in chinese.

 

Any other ideas would be welcome.



#8 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 13 December 2012 - 11:44 AM

Well, I tried to activate another theme, then looked how that theme was looking in IE9 and Chrome - all looked the same... so the problem come from pagelines theme.

I'm now deleting Pagelines and will re-install it via ftp with latest version to see what happens..



#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 13 December 2012 - 11:59 AM

That isn't really a valid test to be honest, but keep us posted when you have performed the above.



#10 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 13 December 2012 - 12:08 PM

I meant no ofense,  I love pagelines!!  I'm just trying to figure out what's wrong here, (getting really worried) 

I uploaded and activated again the theme. Looks great in Chrome, but again, no changes on IE9 not even the the right font.

 

If this is a server problem, what kind of setting could be causing this? I might need to go through a third party to contact the server so I would need to tell him what to look for... 

 

by the way, thanks for your support!

 

...now downloading everything, entire website and data-base, then I will install all in another server and see if the problem continues.. if it does, then it my files, if it doesn't, then it's the chinese server ... 

 

guys, I'm far from beeing an expert here, so if you can keep on looking how to solve this, maybe somebody else had this issue?

 

thanks again



#11 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 16 December 2012 - 09:05 AM

Hi,

 

I am unsure as to what could be causing this issue, as server configuration isn't my forte but if your site is style, layout and CSS is working on one site in IE but not the other and  both are located on different servers, it stands to reason that this is the cause.

 

Did downloading/uploading everything as you mentioned above work ? Was it is server in the end ?



#12 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 17 December 2012 - 10:40 AM

Hello,

 

Well I re-installed pagelines under another domain, same server..(China)  and yes, same problem.. The CSS doesn't work on IE, now I have the confirmation that it's something related with this server... help!

 

just compare Chrome with IE with this one: www.swissinternationalhotels.cn 

 

server is hichina.com

 

But what's really odd is that, if I activate the "twenty eleven" theme (for example) - then it works fine on all browsers includind IE.

 

It's something related with this server and the pagelines theme. The CSS just doesn't work. I'll activate pagelines again on this "test-site"... www.swissinternationalhotels.cn 

 

If you could have a look, that would be great. 

 

thanks 



#13 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 December 2012 - 02:43 PM

Open wp-config.php and add this line:

define( 'PL_NO_DYNAMIC_URL', true );


Your server is sending the wrong mime type.

#14 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 17 December 2012 - 04:19 PM

just did it, (on www.swissinternationalhotels.cn ) but it didn't solve. :_(   Thanks for helping me out ( is there anything else I can try?



#15 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 December 2012 - 05:01 PM

Your server is sending a header forcing it to be in IE7 mode:

 

Please Login or Register to see this Hidden Content



#16 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 17 December 2012 - 05:26 PM

ok, so I need to contact the server to fix it? (sorry , I don't understand much of this) again, thank you very much.



#17 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 December 2012 - 05:31 PM

Something is adding that header to ever page, its not PageLines Framework, so its either something you have added, something in htaccess, or your server is configured to do that.



#18 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 18 December 2012 - 09:53 AM

Hi Simon, thanks for all your support. I asked the Chinese IT team to contact their server. I don't speak Chinese so, can't do anything else. I'll keep you posted  ;)

Thank you!!



#19 adminsihr2012

adminsihr2012

    Member

  • Members
  • 16 posts

Posted 19 December 2012 - 11:02 AM

Sever replies: cannot change the settings because it's "default" , "you have to change the website's code.. " arg!! I'm Thinking about moving it from this server..? Unless you have another solution for me?



#20 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 19 December 2012 - 11:20 AM

Im not sure why on earth they would want this on by default, I would recommend moving from that host if Im honest.







Also tagged with one or more of these keywords: Internet Explorer