Archived

This topic is now archived and is closed to further replies.

  • 0

Do Or Don't : Use Wp Editor


Question

Posted · Report post

hi folks,

 

A)

I wan't to add some custom css to my site.  I would use wp menu -> appearence -> editor -> style.css and add the css code.

 

However, this document says:

 

You’re unable to customize the Framework further by editing core files such as style.css, as this would require editing the core files (something we do not recommend or support), any edits made to these files will be removed upon updating PageLines Framework, when an update is available.

 

In my view there are 4 methods:

 

1: Wordpress editor

2: Framework-> menu -> custom code area

3: Install Customize plugin

4: Use a Child theme

 

So, what is the best method? and why can't I use the wp editor to edit the style.css when I allready did activate the pagelines customization plugin so nothing will ever be lost?

 

B )

I don't understand why this document says that the customize plugin doesn't support CSS / LESS Editor while the plugin is allways and only used in combination withe the pagelines framework that does support the CSS / LESS Editor..

 

 

 

Share this post


Link to post
Share on other sites

4 answers to this question

Posted · Report post

You don't have to upload anything. Simply add your LESS code to PageLines -> Site Options -> Custom Code -> Custom CSS/LESS ... OR .... use the style.less file in your child theme.

 

And yes, do not alter the style.css file located in wordpress appearance -> editor IF PageLines Framework is your active theme. If you have a child theme active, then it is OK to edit the file as it is the child theme's CSS file and not the core framework's CSS file.

Share this post


Link to post
Share on other sites

Posted · Report post

The wordpress file editor only supports php and css files not less files.

Clear

So if you want to use less code, use the customcss box under custom code in the settings, or use the style.less file in your child theme or customize plugin and edit it over FTP.

Is it correct that you need to upload the pagelines style.less.zip file to use Less in combination with the customize plugin?  if I want to use less code (without using a childtheme) this tabel says the framework allready supports the CSS/ LESS Editor. So why to upload this file at all?

If you just want to use css, the again either use the custom code box, or style.css in child theme or customize plugin, but this time you can use the wordpress theme/plugin editor ( if you want to, its not supported by us).

Ok not supported, clear, but does this mean that when Pagelines Framework runs an update the custom css code is lost as stated in the following text??

You’re unable to customize the Framework further by editing core files such as style.css, as this would require editing the core files (something we do not recommend or support), any edits made to these files will be removed upon updating PageLines Framework, when an update is available.

I assume we're talking about the style.css file displayed in the wordpress appearence-> editor?

Share this post


Link to post
Share on other sites

Posted · Report post

The wordpress file editor only supports php and css files not less files.

 

So if you want to use less code, use the customcss box under custom code in the settings, or use the style.less file in your child theme or customize plugin and edit it over FTP.

 

If you just want to use css, the again either use the custom code box, or style.css in child theme or customize plugin, but this time you can use the wordpress theme/plugin editor ( if you want to, its not supported by us).

Share this post


Link to post
Share on other sites