Jump to content


Photo
- - - - -

Website Ultra Slow


  • Please log in to reply
20 replies to this topic

#1 blzalewski

blzalewski

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 10 December 2012 - 10:40 PM

Pagelines,

 

I am currently building two websites right now. One with Pagelines and one just a generic Wordpress theme

 

Pagelines:

Please Login or Register to see this Hidden Content

Other website:

Please Login or Register to see this Hidden Content

 

The Pagelines website is ULTRA MEGA SILLY slow. Why is this? I checked Pingdom and it says DNS/CSS-compile is taking about 3 seconds each. Is Pagelines just slower than other themes because of its power? If so, I gotta switch. Speed is #1 for me. Is there a troubleshooting page I can use to figure out whats going on? I'm on a MediaTemple 1GB VPS with Nginx, php-fpm, apc, varnish, and some other stuff. I hooked it up to CloudFlare and stopped that so I know CloudFlare is not causing this.

 

Is it possible for me to be serving up my home page in under 2 seconds? The DNS lookup/Compiled CSS each take about 3 seconds each and then the rest of my content is served in under 1s according to pingdom tools.

 

Is there a list of requirements for Pagelines (performance wise.. recommended server set up etc.) This is killing me! Thanks all for reading.

 

Regards,

 

Brian


  • tjrutkowski likes this

#2 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 10 December 2012 - 11:11 PM

Hi Brian

 

Which version of the Framework are you currently on, from 2.3.7 we went back to providing a static style sheet and turned the Less compiling off by default. 

 

I think the link below will help you, a previous client went through the same troubleshooting process with one of our core team, you can read the advise they gave below.

 

Please Login or Register to see this Hidden Content



#3 blzalewski

blzalewski

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 11 December 2012 - 07:39 AM

Hi, I tried that and it did improve the performance somewhat... but check this out:

 

Please Login or Register to see this Hidden Content

 

The time it takes to load the pagelines compiled css and the time to resolve the dns are both very long while the time to load everything else is very short... it is not like this on my non-pagelines site

 

I want to understand why its doing this so I can figure out where performance tweaks are needed.



#4 blzalewski

blzalewski

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 11 December 2012 - 07:56 AM

I was on the latest version yesterday but I think 2.3.8 just came out



#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 15242 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 11 December 2012 - 08:02 AM

I am unable to view what version of PageLines Framework you're using as your pagelines style.css is not reachable? 

 

Please Login or Register to see this Hidden Content

 

Also your compiled CSS isn't the issue, check it out here, it loads instantly - 

Please Login or Register to see this Hidden Content

 

Your site loads fast for me!



#6 blzalewski

blzalewski

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 11 December 2012 - 11:07 AM

it loads fast but its slowing down everything else because all of the other content only starts downloading after the compiled CSS is downloaded.

 

I'm now on the latest version of Pagelines

 

Also, is it possible that I don't have any style.css? what is that for? I have no custom CSS rules yet

 

It seems like the compiled css is not being cached - how can I fix this?



#7 blzalewski

blzalewski

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 11 December 2012 - 11:20 AM

I added define( 'LESS_FILE_MODE', true );   - does this have to go to the end of wp-config.php or can it go anywhere in the file?

 

My ultimate goal is to get speed that resembles the other website greenwaymaterials.com (that website isn't even set up with w3 total cache yet either)

 

Is this possible with Pagelines? are there significant performance sacrifices?



#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 December 2012 - 02:28 PM

Go to advanced and enable debug.

 

less file mode is active by default now, if its not working the your server is incompatible, the above setting will tell you why.



#9 dnnyboy

dnnyboy

    Advanced Member

  • Members
  • 52 posts
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 11 December 2012 - 05:48 PM

How can one tell if one's server is incompatible? What should I look for in the debug info? I'm struggling with the same issue.



#10 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 December 2012 - 06:05 PM

@dnnyboy:

 

Both of the following will stop the file css mode:

 

 

Please Login or Register to see this Hidden Content



#11 dnnyboy

dnnyboy

    Advanced Member

  • Members
  • 52 posts
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 11 December 2012 - 06:44 PM

Please Login or Register to see this Hidden Content

Seems I'm all out of luck then. Any other possible ways of bringing down the compiled css loadtime? As you can see it's quite significant compared to the rest of the css files:

 

pageless.png



#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 December 2012 - 07:00 PM

Maybe you should ask your host why your php is running mod_php and a different user to yourself.

 

If your running 2.3.8 you can try the force filter...

 

add_filter( 'render_css_posix_', '__return_true' );

 

add to child functions.php

 

Nothing guaranteed.

 

Apologies to the OP for thread being taken over.



#13 blzalewski

blzalewski

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 11 December 2012 - 11:23 PM

Thanks for your help Simon

no problem... seems like dnnyboy is having the same problem i am

i have access to SSH root... any ideas what I should install to get Pagelines working fine? Right now i'm running nginx, php-fpm, and apc... so i'm on nginx instead of apache and php-fpm instead of php_mod...

update: after fine tuning everything else... the css file is about 50% of my load time

#14 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 December 2012 - 11:55 PM

Your css is still running in 'safe mode' cant tell without debug enabled.



#15 blzalewski

blzalewski

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 12 December 2012 - 12:19 AM

okay.. should be enabled right now



#16 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 December 2012 - 12:21 AM

Thats great but us peons will never see it as you have caches installed.



#17 blzalewski

blzalewski

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 12 December 2012 - 02:45 AM

hhmmm.. not sure what to make of that but... maybe there's some other bootleg way of fixing this? is there a way to get pagelines to pre-compile the CSS? right now it seems like my website is compiling every time someone connects... it might be fast now but if I get even a little spike in traffic its gonna noticeably reduce my load times

thanks for your help so far Simon_P



#18 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 December 2012 - 02:58 AM

ok what i meant was, there is no way fro us to see the pldebug url, as your site is cached. So all logged out users just see cached pages.

 

If you want us to try and help, turn off all the caches.



#19 lucasgarvin

lucasgarvin

    Member

  • Members
  • 17 posts
  • LocationNew York, NY
  • Framework Version:2.3
  • Country: Country Flag

Posted 12 December 2012 - 03:33 AM

This is a helpful thread; I'm anxious to see the end result. Thanks for all the interaction here!



#20 blzalewski

blzalewski

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 12 December 2012 - 03:49 AM

ok i turned off w3 total cache... do I need to turn off server level caches too? any ideas which ones in particular might be causing the problem?

 

maybe I make you an admin on my site? or maybe I can modify the following nginx.conf from this link to not cache the debug url (my nginx.conf is roughly similar):

 

Please Login or Register to see this Hidden Content