Jump to content


Photo
- - - - -

Ubermenu And Sliderpro And Z-Index Issues


Best Answer thomstark , 10 December 2012 - 03:43 AM

Problem solved. z-indexing #sb_universal did the trick. Just had to figure out how to call the universal sidebar.

Go to the full post


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 thomstark

thomstark

    Super Member

  • Members

  • 147 posts

Posted 09 December 2012 - 09:07 PM

Hi.

 

I did try to get this resolved with the creators of UberMenu and SliderPro first, but their solution didn't work.

Here's the website: www.bringtheharvest.com

 

You'll notice if you hover over "Who We Are" on the UberMenu, the dropdown menu will go in front of the big slider image (like it should) but _behind_ the thumbnail navigation gallery (like it shouldn't).

 

They told me to add this to my CSS:


#nav {
     position: relative:
     z-index: 2;
}

#page-main {
     position: relative:
     z-index: 1;
}

 

 

I tried that, and I also tried changing 'page-main' to 'content'. I also tried changing it to 'universal-sidebar' but that was just a stab in the dark. Still nothing. FYI: I have the SliderPro widget in the universal sidebar above the content section.

 

Any help would be tremendously appreciated!



#2 thomstark

thomstark

    Super Member

  • Members

  • 147 posts

Posted 10 December 2012 - 03:43 AM   Best Answer

Problem solved. z-indexing #sb_universal did the trick. Just had to figure out how to call the universal sidebar.