Archived

This topic is now archived and is closed to further replies.

  • 0

Pagelines 2.3.7 And Buddypress

Question

Posted · Report post

Has this version been tested with BuddyPress? I have a BuddyPress PageLines site. I tested this upgrade on the WP Engine Staging server and the /groups/ and /members/ and /forums/ were all just gone -- blank white page. No WP_DEBUG errors. No difference after deactivating all but BuddyPress, BP Template Pack, and BP for PageLines. No difference when switching from child theme to parent theme. Only difference is if I deactivated all (including BP) plugins, in which case I got a page that just said "Groups" or "Members" or "Forums".

 

(Copied from http://www.pagelines.com/forum/topic/23784-237-release-notes/?p=139123 )

 

Thank you.

Share this post


Link to post
Share on other sites

10 answers to this question

Posted · Report post

When a store item is updated that you have installed, it will show you the update in PageLines -> Dashboard. Make sure your account credentials are added, of course. You can also check the individual sections within the Store tab if you would like. Hope that helps!

Share this post


Link to post
Share on other sites

Posted · Report post

And the url to this site?

Share this post


Link to post
Share on other sites

Posted · Report post

That may be true; I don't know; but odd that PL never told me there was a new version. Do the update notifications work for the Integrations in addition to Plugins and Sections? I assume yes. I even clicked to "Store" and "Dashboard" several times over the past few weeks trying to figure this out and never was informed there was an update.

Share this post


Link to post
Share on other sites

Posted · Report post

There should also be a subscribe button, so you get emailed on updates.

Share this post


Link to post
Share on other sites

Posted · Report post

I tried the PL, BP, and WP updates and no better. :-(

 

I disabled almost everything, like I said before, and then I switched themes to see if it's PL or BP/WP and I got a WP_DEBUG error so I went to disable the BP for PL plugin (while Twenty Twelve was active) and the screen went white/blank except for this error:

 

Notice: Use of undefined constant CORE_VERSION - assumed 'CORE_VERSION' in /wp-content/plugins/pagelines-buddypress/pagelines-buddypress.php on line 67

Fatal error: Call to undefined function toggle_integration() in /wp-content/plugins/pagelines-buddypress/pagelines-buddypress.phpon line 57

 

So it wouldn't let me deactivate that plugin without activating PL then deactivating, then switching from PL.

 

Other than that, it's not a PL issue, unfortunately... I'll keep investigating on my own.

Share this post


Link to post
Share on other sites

Posted · Report post

I finally figured it out... I had to delete the PageLines theme, delete the BP Template Pack, delete the BP for PL plugin, and then install fresh PL, re-install/setup BP Template Pack, and then install BP for PL plugin and everything worked fine with newest PL, BP, and WP 3.5.

 

Is this a known thing -- to have to do something like this for some upgrades to PL?

 

Thanks.

Share this post


Link to post
Share on other sites

Posted · Report post

I just ran an update on both PageLines and Wordpress to the latest versions and didn't run into this error.

 

What plugins did you have active, so we can try to recreate your issue.

Share this post


Link to post
Share on other sites

Posted · Report post

you were running an out of date pagelines-buddypress

Share this post


Link to post
Share on other sites

Posted · Report post

I looked at the plugin's store page and only see a version 1.00:

1.0.0
  • Initial release
  • Added info.txt
  • Added images
  • Color control supported

Whatever, it's fixed now. Hopefully my feedback has helped in some way. Please close the ticket.

Share this post


Link to post
Share on other sites