Archived

This topic is now archived and is closed to further replies.

  • 0

Inserting Custom Form - Submit Button Not Displaying

Question

Posted · Report post

Hello, I am trying to place a Form generated from HubSpot into the theme. I can get all the fields to display EXCEPT the Submit Button. I am on StationPro3. The page that this table is currently on is: http://www.ecommerceinboundmarketing.com/evaluate-your-b2c-website-grade/ The code for the table that I am using is: <form action="http://mewing.web6.hubspot.com/Default.aspx?app=iframeform&hidemenu=true&ContactFormID=35882" method="post"> <input type="hidden" name="FormSubmitRedirectURL" id="FormSubmitRedirectURL" value="http://www.ecommerceinboundmarketing.com/thank-you-your-free-website-grader/" > <input type="hidden" name="Lead_Src" id="LeadSrc" value="Get a Website Grade For Your Business | Contact Form" /> <script type='text/javascript' language='javascript'>/* <![CDATA[ */ HubSpotFormSpamCheck_LeadGen_ContactForm_35882_m0 = function() { var key = document.getElementById('LeadGen_ContactForm_35882_m0spam_check_key').value; var sig = ''; for (var x = 0; x< key.length; x++ ) { sig += key.charCodeAt(x)+13; } document.getElementById('LeadGen_ContactForm_35882_m0spam_check_sig').value = sig; // Set the hidden field to contain the user token var results = document.cookie.match ( '(^|;) ?hubspotutk=([^;]*)(;|$)' ); if (results && results[2]) { document.getElementById('LeadGen_ContactForm_35882_m0submitter_user_token').value = results[2]; } else if (window['hsut']) { document.getElementById('LeadGen_ContactForm_35882_m0submitter_user_token').value = window['hsut']; } return true; }; /*]]>*/</script> <input type='hidden' id='LeadGen_ContactForm_35882_m0submitter_user_token' name='LeadGen_ContactForm_35882_m0submitter_user_token' value='' /><input type='hidden' name='ContactFormId' value='35882' /><input type='hidden' id='LeadGen_ContactForm_35882_m0spam_check_key' name='LeadGen_ContactForm_35882_m0spam_check_key' value='shfmdhmefkddgdinfmkjsgepoemhkilsopsqssodidwfddgllmcquqnwmgim' /><input type='hidden' id='LeadGen_ContactForm_35882_m0spam_check_sig' name='LeadGen_ContactForm_35882_m0spam_check_sig' value='' /><div class='ContactFormItems FormClassID_35882'><table border="0" cellspacing="0" cellpadding="5"> <tr><td>? </td><td>Full Name <span style='color: red'> *</span></td></tr> <tr><td>? </td><td><input type="Text" name="LeadGen_ContactForm_35882_m0:FirstName" class="StandardI AutoFormInput LeadGen_ContactForm_35882_m0_AutoForm" id="LeadGen_ContactForm_35882_m0_FirstName" value="" /><div class="fieldclear"></div></td></tr> <tr><td>? </td><td>Email <span style='color: red'> *</span></td></tr> <tr><td>? </td><td><input type="Text" name="LeadGen_ContactForm_35882_m0:Email" class="StandardI AutoFormInput LeadGen_ContactForm_35882_m0_AutoForm" id="LeadGen_ContactForm_35882_m0_Email" value="" /><div class="fieldclear"></div></td></tr> <tr><td>? </td><td>Website</td></tr> <tr><td>? </td><td><input type="Text" name="LeadGen_ContactForm_35882_m0:Field_Text_5" class="StandardI AutoFormInput LeadGen_ContactForm_35882_m0_AutoForm" id="LeadGen_ContactForm_35882_m0_Field_Text_5" value="" /><div class="fieldclear"></div></td></tr> <tr><td></td><td><input onclick='return HubSpotFormSpamCheck_LeadGen_ContactForm_35882_m0();' class='FormSubmitButton' type='submit' name='LeadGen_ContactForm_Submit_LeadGen_ContactForm_35882_m0' value="Submit"></td></tr> </table></div> </form> Please help. Thanks!!

Share this post


Link to post
Share on other sites

1 answer to this question