Jump to content


Photo
- - - - -

How To Make A Few Pages Invisible For The Menu


Best Answer Danny , 06 December 2012 - 11:09 AM

This is the default workings of Wordpress, if you do not create a Wordpress custom Menu or you have but haven't assigned it to your Theme Location, then Wordpress will use the Pages you have created to populate your menu. Thats why when you first install Wordpress your menu will always contain a menu item called Sample Page, this is because Wordpress creates a sample post and sample page by default. So assign your menu to your NavBar like in the link I posted above and this should resolve your issue. Go to the full post


This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1 texasx

texasx

    Member

  • Members
  • 26 posts

Posted 06 December 2012 - 09:19 AM

Hi,

I have made two text pages, Policy and Copyright, but I don´t want them in the Navbar menu or in the Breadcrumb NavXT.

Even if I exclude them when I build the navbar menu, they will appear anyway.

 

I have made a separate meny for thoose two pages in the middle footer. That's the only place I want them to show.

 

Greatful for your help

 

Please Login or Register to see this Hidden Content

 

Added:

I can see that the simple nav in the footer is behaving as it should, or as I expect.



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17931 posts

Posted 06 December 2012 - 10:19 AM

Hi,

 

I recommend you create your own Wordpress Custom Menu.

Please Login or Register to see this Hidden Content

 

Once created, you can set your menu for your Navbar by going to the NavBar settings panel. -

Please Login or Register to see this Hidden Content

 

As for removing pages from Breadcrumb NavXT, I recommend you review the documentation for the plugin and see if it supports this option -

Please Login or Register to see this Hidden Content



#3 texasx

texasx

    Member

  • Members
  • 26 posts

Posted 06 December 2012 - 10:32 AM

Thanks,

Then I understand that the CMS is working as it should, altough I have created a menu without thoose pages.

I´ll look into your links.

 

Many thanks



#4 texasx

texasx

    Member

  • Members
  • 26 posts

Posted 06 December 2012 - 10:52 AM

Hi again,

Looked into your links and it will take some work to do this. Before I jump into this ...

 

Why do I get another meny than the one I have created / customized in Framework 2.3.7, under the "Menues"?

It seams that somethings aren't working correct or that I have missed something.



#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 17931 posts

Posted 06 December 2012 - 11:09 AM   Best Answer

This is the default workings of Wordpress, if you do not create a Wordpress custom Menu or you have but haven't assigned it to your Theme Location, then Wordpress will use the Pages you have created to populate your menu. Thats why when you first install Wordpress your menu will always contain a menu item called Sample Page, this is because Wordpress creates a sample post and sample page by default. So assign your menu to your NavBar like in the link I posted above and this should resolve your issue.

#6 texasx

texasx

    Member

  • Members
  • 26 posts

Posted 06 December 2012 - 11:28 AM

Thanks again,

I found out what I missed ... very much what you describe.

Under Site Option - Navbar there is a field to chose meny. I've missed that, now it's showing up the right way.

The reason this haven't been a problem before is that as long as you whish all of your main pages to appear in the navbar, it matches your created menu.

 

Thanks for your valuable input



#7 Danny

Danny

    Is Awesome!

  • Moderators
  • 17931 posts

Posted 06 December 2012 - 12:38 PM

No problem!