Archived

This topic is now archived and is closed to further replies.

  • 0

Discovered Bug With Nextgen Gallery And Supersize Bg Image

Question

Posted · Report post

I was working with James and Robert in Live Chat and we've discovered a bug.

 

Five of my site's pages display a Carousel using NextGen Gallery images, and all use the same supersized background image set in Pagelines > Site Options > Color Control with the supersized option checked. Four of the pages work without issue, but one page will not load the background image in Firefox (v18 OS X). All pages work fine in Chrome (Version 23.0.1271.95 OSX) and Safari (v6.0.2 OS X).

 

Discovered that turning off the Carousel in the page meta settings on this page only would allow the background image to load. Otherwise, with the Carousel on, here is the result: http://screencast.com/t/ldksAMopc2

 

A working page in all browsers: http://www.ancienttreearchive.org/our-activities/collection/

The non-working page when shown in Firefox only: http://www.ancienttreearchive.org/our-activities/archive/

 

Looking forward to a fix or ideas on this!

Thanks

Bill

 

Pagelines V 2.3.6 using Base Theme 1.0.2

Share this post


Link to post
Share on other sites

11 answers to this question

Posted · Report post

Hey James!

 

I do have Web Dev tools. I tried turning off firefox plugins but it didn't make any difference. The background image still didn't show up.

 

Per previous posters, I see that there are all sorts of warnings and errors. Most have to do with a third-party page that is being shown in a modal, and the others have conflicts with the share buttons in my footer, which I have inserted with the following less shortcodes:

[like_button]

[twitter_button]
[googleplus]
[linkedin]

 

NextGen Gallery does have a PluginCheck button on their config settings. Running this comes up with this error:

Check theme compatibility

 

Missing the call to wp_head() in your theme, contact the theme author

 

 

One of the errors from the firefox debugger:

 

Timestamp: 12/6/12 12:47:24 PM
Error: Error: jCarousel: No width/height set for items. This will cause an infinite loop. Aborting...
Line: 1
Inside the Carousel meta settings, I had been leaving the sizes blank because it says that when using NextGen Gallery images, the height and width of the images are set in by NextGen. It also says the image sizes are for Posts Mode only. I'm not using post mode on this page.
 
Once again, no idea how to fix any of this stuff, but it's what I'm seeing.

Cheers,
Bill

Share this post


Link to post
Share on other sites

Posted · Report post

Well i tried to reproduce this locally.

 

Installed nextgen, created a gallery. Added some images to the dir and let nextgen index them and create thumbs.

 

Added the carousel to blog page, told it to use nextgen and set a scroll time.

 

Added a global supersized background.

 

All works no errors.

 

Your site is impossible to debug when its minified and still using external JS that causes errors.

 

How did you create the gallery? 

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for posting Bill, we'll get this looked into and come back to you shortly when we know a little more.

Share this post


Link to post
Share on other sites

Posted · Report post

If you're interested, I recently released Better Carousel, a Carousel a lot like the one in core, but responsive, and with a few more options. I just tested it with background images and it seems to work ok and not present any issues like you describe. 

 

Might be a good alternative.

 

http://pagelines.com/store/sections/better-carousel/

Share this post


Link to post
Share on other sites

Posted · Report post

There are a number of javascript fatal errors on your page, could be the cause.

Share this post


Link to post
Share on other sites

Posted · Report post

HI Eejit

There are a number of javascript fatal errors on your page, could be the cause.

Any way to tell where these are coming from? Plug-ins? Or pagelines itself? Do you see the same errors on other pages from the site?

 

@Unicorn: I heard about better carousel - was planning on giving that a try, but not before seeing if my situation was a dead end or not.

Share this post


Link to post
Share on other sites

Posted · Report post

You can use your browsers debug tools to see the errors.

Share this post


Link to post
Share on other sites

Posted · Report post

Simon:

I created the gallery by using the nextgen uploader. 

And it is odd, because I have four other instances of the gallery that work just fine. It's this fifth one that is the problem. In fact, I created another page as a test with the gallery and had the same problem.

Weird.
B

Share this post


Link to post
Share on other sites

Posted · Report post

Do you have any firefox add on's Bill, like Web Dev tools? Turn off firefox plugins and see if that makes any difference to the supersize bg.

Share this post


Link to post
Share on other sites

Posted · Report post

Bill the background is coming up in firefox now on that page, did you find the js error?

Share this post


Link to post
Share on other sites