Jump to content


Photo
* * * * * 1 votes

Layout Not Working Well

layout

  • Please log in to reply
28 replies to this topic

#21 Danny

Danny

    Is Awesome!

  • Moderators
  • 16526 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 03 December 2012 - 09:47 AM

Stefano, I apologise but I don't understand your post above, are you saying that on a fresh install you encounter 963 HTML errors ? 



#22 stefanoferruggiara

stefanoferruggiara

    Advocate

  • Members
  • 564 posts
  • LocationVerbania (VB) - Italy
  • Country: Country Flag

Posted 03 December 2012 - 02:03 PM

Hi there,

yesterday i was talking about some problem that i found with my site, about layout setting and some feature that is not centered.

Robert give me 2 link for validate html and w3c cause he talk about some error that maybe i do customizing css code.. I have reinstalled all.. and without plugin and css code Pageliens Framework Theme return 933 error html and 3 critical error with W3C. No one reply to me and i'm still waiting with now my site off line and to made as new.

 

Today i build a site for a client and the box (core plugin box) IS NOT CENTERED!! Now i don't think that i lost my view or my browser or css code.. maybe is possible that the section don't center automatically the box dipending on their dimension etc...

 

You can help me to fix the html and w3c error and center the box please?

Thanks for fast reply because i have my site off line caused to this problem..

 

I think that.. is not correct that I have the site off line just because I have reinstalled everything cause I believe i have done something wrong, and instead is the theme or plugin that has some bug or setting to fix. Please now, in light of the fact that it was not a plugin or my css code, after receive a warning unfair because I had every reason to be angry, please help me to put my site online without errors and with the correct aspect.

 

The site of my client is

Please Login or Register to see this Hidden Content

see the box here. and also this site try to validate with html and w3c and you can see how many error have pageliens framework due to original installation and not cutomization code or plugin.

 

my site is:

Please Login or Register to see this Hidden Content



#23 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 03 December 2012 - 03:23 PM

Did you make sure that all plugins (including cache plugins) are deactivated?



#24 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 03 December 2012 - 03:40 PM

As Catrina noted, I would start deactivating all plugins and sections. My personal site, running on PageLines, full validates.

 

Please Login or Register to see this Hidden Content

 

Also, the box section images are not shipped with a center aligned box image, however it's very easy to do with CSS.



#25 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 03 December 2012 - 03:47 PM

The boxes are not aligned left, right or centered. Thats up to you the designer to align them. If we aligned them to the center someone else would complain that they are hard coded centered and they want them aligned to the right or left.

 

As for the validation, all those errors are browser 'hacks' in bootstrap for internet explorer.

 

Please stop opening multiple posts on the same topic.

 

Merging this post into the other one.



#26 stefanoferruggiara

stefanoferruggiara

    Advocate

  • Members
  • 564 posts
  • LocationVerbania (VB) - Italy
  • Country: Country Flag

Posted 03 December 2012 - 09:27 PM

Listen Nick.. which is the best way to understand how have validate site?

I have just reinstall all and give me the same problem.. ok .. the site work but.. you know.. the would be have html clean code.

Any suggest?

You think that i can ask in pros section for resolve this problem?



#27 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 04 December 2012 - 12:22 AM

Stefano,

 

You have Firebug or Chrome tools.  Looking at the boxes in Firebug,  I see that the image is not aligned within the box area. What happens is that the image aligns left without coding, by default.  Since the box area is so wide, the space has to be filled and without no alignment for the images, the flush left.  This is the result, I'm sorry to say, of your coding and not something PageLines did.

 

The solution Batman offered was correct.

 

Here's what I found works too, and this was independent of Batman's correct response:

Please Login or Register to see this Hidden Content

Let me explain this.   The "auto" option allows the image to be automatically aligned.  With no other alignment, this will follow the rest of the site's alignment and essentially center... IF you make both left and right auto margins set to auto.   It's telling the image to align equally on both sides.

 

As soon as I applied that to one of your client sites, the three boxes lined up in the center of each box and the left and right space were even.

 

On a personal note, I know you get upset when things don't work, but as one Italian to another, don't go into panic mode every time. Nothing is so "URGENT" that you need to go into crisis mode and post bug reports, panic posts and be upset.  This is not worth having cardiac arrest from.  It's just page styling.  It will always be fixed but if it takes 24 hours to do it, then it takes 24 hours to do it. Solutions in a forum are not provided instantly.  You've just got to be patient.


  • stefanoferruggiara likes this

#28 stefanoferruggiara

stefanoferruggiara

    Advocate

  • Members
  • 564 posts
  • LocationVerbania (VB) - Italy
  • Country: Country Flag

Posted 04 December 2012 - 05:25 PM

OK MANY THANKS ROB AND PAGELIENS STAFF!!! ;)



#29 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 04 December 2012 - 05:41 PM

Do you need any further assistance?







Also tagged with one or more of these keywords: layout