Jump to content


Photo
- - - - -

Tinymce Stripping P Tags From Html


  • Please log in to reply
3 replies to this topic

#1 lloydq

lloydq

    Newbie

  • Members
  • 1 posts
  • Country: Country Flag

Posted 29 November 2012 - 05:31 AM

Just upgraded a site to 2.3.5 (and then to 2.3.6 hoping to solve the problem). Since then TinyMCE seems to be stripping out P and BR tags from the boxes. Pages and posts seem to be okay. If I had a style attribute to the tag it is okay but simple P tag goes away when you switch from html to visual. There are quite a few forums with complaints about TinyMCE, but most of the solutions didn't seem to fit this problem. There were some metabox code solutions that were possible, but I wanted to post here first to see if there other similar issues related to Pagelines first.



#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 15702 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 29 November 2012 - 07:26 AM

Hi,

 

Which TinyMce plugin is stripping the HTML ?

 

I've just installed TinyMCE ultimate and adding HTML to boxes, save them and the HTML remains.



#3 lloyd118

lloyd118

    Newbie

  • Members

  • 7 posts
  • Framework Version:2.3.6
  • Country: Country Flag

Posted 29 November 2012 - 10:25 PM

lloydq replying as a different user:

 

I was using the built-in version. After the problem occurred I tried installing Ultimate after reading that someone had cured their similar problem by installing it. It did not work for me though. 



#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 29 November 2012 - 10:35 PM

P tag goes away when you switch from html to visual.

 

You cant switch between the two! Use one or the other.