Archived

This topic is now archived and is closed to further replies.

  • 0

Warning Framework 2.3.6 And Wordpress 3.5 Rc1, In Wp 3.4.2 Works Well

Question

Posted · Report post

Warning: Invalid argument supplied for foreach() in /usr/home/servidor.com/web/miweb/wp-content/themes/pagelines/includes/class.render.css.php on line 727

It happens on all my pages with pagelines with the previous version 2.3.5 with 3.5Rc1 did not have this problem

EDIT: Also happens in wordpress 3.4.2! It happens the first time you load the page after saving Pagelines Site Options. In the following reloads dont recur

Regards

Share this post


Link to post
Share on other sites

39 answers to this question

Posted · Report post

The PHP warning is caused by the pagelines-sections plugin NOT being installed and activated.

 

To fix, install and activate it.

Share this post


Link to post
Share on other sites

Posted · Report post

Where's this section plugin?

Share this post


Link to post
Share on other sites

Posted · Report post

The fix with the sections plug-in worked for me too.

The sections plugin can be downloaded by going to the Dashboard/Pagelines/store menu item. I was then prompted to download the sections plugin (which I had planned to do anyway). Somewhat ironic that the first support questions were concerned with plugins...

Share this post


Link to post
Share on other sites

Posted · Report post

OK - found that and the php warning is gone but now I'm stuck with a site looking like pic2 above whatever layout I give it - any ideas?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

Im running Wordpress Version (3.5-RC1-22879) and PageLines Framework 2.3.6 and I have no such issue. Have you tried disabling all non-PageLines plugins?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi.

I just editing my post, also happen in WP 3.4.2, with 2.35 release dont happen this problem. Only happens the first time to reload the web before saving Pagelines Stie Options, the next loads dont happen :S

Each time you make a save PageLines Site Options on the next web load returns this warning

The plugins is disabling.

Share this post


Link to post
Share on other sites

Posted · Report post

Do you have WP-Debug enabled ?

Share this post


Link to post
Share on other sites

Posted · Report post

Yes , it returns:

Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /usr/home/miweb.com/web/pagelines/wp-includes/functions.php on line 2937

Warning: Cannot modify header information - headers already sent by (output started at /usr/home/miweb.com/web/pagelines/wp-includes/functions.php:2937) in /usr/home/miweb.com/web/pagelines/wp-includes/pluggable.php on line 876

Share this post


Link to post
Share on other sites

Posted · Report post

same problem after update! latest wordpress. latest pagelines.

Share this post


Link to post
Share on other sites

Posted · Report post

I have the same problem since upgrading to Framework Pro 2.3.6 from 2.3.5 on Wordpress 3.4.2. I have no plugins installed.

Share this post


Link to post
Share on other sites

Posted · Report post

Did you read the entire topic? The problem is solved by installing the sections plugin, or waiting for 2.3.7

 

Again: Apologies to the original poster for all the unrelated email alerts

Share this post


Link to post
Share on other sites

Posted · Report post

Yes , it returns:

Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /usr/home/miweb.com/web/pagelines/wp-includes/functions.php on line 2937

Warning: Cannot modify header information - headers already sent by (output started at /usr/home/miweb.com/web/pagelines/wp-includes/functions.php:2937) in /usr/home/miweb.com/web/pagelines/wp-includes/pluggable.php on line 876

A plugin is causing that.

as for the other error go into the store tab, clck refresh and make sure there are no products that need updating.

Share this post


Link to post
Share on other sites

Posted · Report post

i just fixed the notice error of the debug, but the warning continues
Warning: Invalid argument supplied for foreach() in /usr/home/servidor.com/web/miweb/wp-content/themes/pagelines/includes/class.render.css.php on line 727

As I said before I only happens the first time I load the web after saving settings on the Site Options or Page Options on Pagelines menu

 

All the plugin is disabled

Share this post


Link to post
Share on other sites

Posted · Report post

OK - found that and the php warning is gone but now I'm stuck with a site looking like pic2 above whatever layout I give it - any ideas?

 Got the same problem - nightmare. Any help much appreciated

Share this post


Link to post
Share on other sites

Posted · Report post

No idea without a URL to your site. There are like 4.5 billion to choose from ;)

Share this post


Link to post
Share on other sites

Posted · Report post

Changed permalinks - fixed it in firefox - still messed up in safari.

Share this post


Link to post
Share on other sites

Posted · Report post

Impossible to tell, your developing your site using a page caching plugin.

Share this post


Link to post
Share on other sites

Posted · Report post

I deleted the plugin - seems to have fixed the problem. Thanks

Share this post


Link to post
Share on other sites

Posted · Report post

Its only a warning, turn off error reporting.

Share this post


Link to post
Share on other sites

Posted · Report post

OK - deactivated W3 Total Cache and the site looks vaguely like it did before. Is pagelines now incompatible with the most popular cache plugin on wordpress?

Share this post


Link to post
Share on other sites

Posted · Report post

@Spritch, I'm not sure what your site is supposed to look like but you do have this:

 

#cred {display:none;}

 

displaying in your footer, this is most likely caused by you adding CSS to the Custom Code > Footer Scripts area.

 

This area does not support CSS, so please remove it and also that CSS is for Platform Pro to remove the infamous leaf logo.

 

There is no need to use CSS to hide the logo in the footer, just use the WaterMark setting, which can be found in

 

PageLines > Site Options > Website Setup > Watermark.

 

Which allows you to hide the image completely or add your own image and URL, also please create a new topic.

Share this post


Link to post
Share on other sites