Jump to content


Photo
- - - - -
Open

Errorlog Full Of Alerts. "script Tried To Increase Memory_Limit"



  • Please log in to reply
7 replies to this topic

#1 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 27 November 2012 - 07:20 AM

My error log is full of these messages:


ALERT - script tried to increase memory_limit to 268435456 bytes which is above the allowed value (attacker '208.85.238.208', file '/www/public_html/wp-content/themes/pagelines/includes/library.pagelines.php', line 4)


It seems as if Pagelines is trying to change memory_limit to WP_MAX_MEMORY_LIMIT on every page load (see pagelines/includes/library.pagelines.php).

WP_MAX_MEMORY_LIMIT is 256m. I don't want PHP/Pagelines to use that much memory. Why is Pagelines doing this? Is there a easy fix to disable this functionality (without editing library.pagelines.php)?

Thank you

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17124 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 27 November 2012 - 08:49 AM

Hi,

I am not entirely sure why this would be doing this but before I ask one of our developers, can you please update to the latest version of PageLines Framework which is 2.3.5, you're using 2.2.5.

#3 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 27 November 2012 - 08:52 AM

I'm actually using 2.3.5. I'm using PageLines at two sites.

#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 27 November 2012 - 11:11 AM

Ive change the way this is called in 2.3.6, the memory is only raised when the CSS is built, thats when its actually needed.

#5 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 23 March 2013 - 05:35 PM

I still get the same errormessage:

Mar 23 11:15:37 debian suhosin[24965]: ALERT - script tried to increase memory_limit to 268435456 bytes which is above the allowed value (attacker '36.197.131.44', file '/www/domain.com/public_html/wp-content/themes/pagelines/incl
udes/library.pagelines.php(4) : runtime-created function', line 1)

 

I'm now using PageLines Version 2.4.1



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 17124 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 24 March 2013 - 09:27 AM

Can you enable PageLines debug mode and reply here when enabled.

 

You can enabled PageLines debug mode by going to PageLines > Site Options > Advanced.



#7 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 25 March 2013 - 01:47 PM

What should I do when debug mode is activated?



#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 25 March 2013 - 02:04 PM

Provide a url please.