Jump to content

- - - - -

One Page Not Mobile View

This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 Willem-Siebe Spoelstra

Willem-Siebe Spoelstra

    Super Member

  • Members
  • 228 posts

Posted 26 November 2012 - 11:15 PM

Hi there,

I wanted to make my Google Maps (Basic Google Maps Placemarks) also look nice for mobile view.
Then I read this:

Google recommends forcing the map to stay the original size on mobile devices, and they has an app specifically for iPhones, so I don't think they intend the regular full-sized maps to be viewed from mobile devices.

With that in mind I thougt, let's make this one page a 'not-mobile' one. So I edited the page and marked 'Disable mobile view'. But this page is still showing as mobile page on my iphone. HOw is is that possible.

#2 James B†

James B


  • DMS Subscriber†
  • 5126 posts

Posted 27 November 2012 - 01:28 AM

Hi there, i'm not sure you'll be able to turn off one page only in mobile view. You might be able to use browser specific css to target mobile devices and then .Page-id-x to make changes to the mobile layout on that one page which stop it being responsive but I'm not sure if or how that would work. Ideally you'd need to look into getting a pro www.pagelines.com/pros/ as it could be something that can only be disabled via php or javascript.

An example of some browser specific/mobile css is below.

Please Login or Register to see this Hidden Content

#3 Willem-Siebe Spoelstra

Willem-Siebe Spoelstra

    Super Member

  • Members
  • 228 posts

Posted 27 November 2012 - 08:39 AM

Okey, thanks for your reply. But it's nog clear to me why (if it's not possible) there is an option to disable mobile view for a certain page...

#4 Danny


    Is Awesome!

  • Moderators
  • 19801 posts

Posted 27 November 2012 - 09:11 AM


Go to your Wordpress Admin Dashboard > Pages > Select the page you wish to disable Mobile view on and then scroll down to the PageLines Meta Settings.

On the Page Setup tab, check the box for the option called "Disable Mobile Optimized View".