Jump to content


Photo
- - - - -
Resolved

Buddypress Styling And Loading Errors

buddypress

  • Please log in to reply
8 replies to this topic

#1 CliffordP

CliffordP

    Advocate

  • Members


  • 456 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 24 November 2012 - 05:18 AM

Site located at

Please Login or Register to see this Hidden Content

but some screenshots not available to non-registered users, just FYI.


1) Why are multiple pages showing active on the menu/nav area?

Please Login or Register to see this Hidden Content



2) Look and feel of most BuddyPress pages is wonky.

Please Login or Register to see this Hidden Content



3) Some areas have stray/errant bullet points

Please Login or Register to see this Hidden Content

and

Please Login or Register to see this Hidden Content



4) BuddyPress progress bars never finish loading
video:

Please Login or Register to see this Hidden Content




I haven't tried deactivating all other plugins, but other than that, do any of these look like known or common issues or something as part of the setup process?

Thank you for your help.

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 24 November 2012 - 05:49 AM

Cliff,

I'm looking into each of these. But for the bullet points:

Please Login or Register to see this Hidden Content


Some of the issues (Item 4) you raise have nothing to do with PageLines and are strictly BuddyPress which we can't help with. However, where we can help, we will.

Some, like Item 2 on your list is controlled simply by CSS. I completely concur that Buddypress does look a little weird. However, I tried it with my own site in the WP default themes (20/10 and 20/11) and it appeared exactly the same as in PageLines. So it's not us. I managed to apply some CSS, easily, and got it looking just the way I want it.

As for the menu, that one's a mystery to me. There's code for that page that makes it believe there are four links open at once as they're all seen as current. I've not seen that before and it might be a BuddyPress piccadillo related to a plugin or to some setting.

I have BuddyPress with our integration and don't have this issue at all. While I normally use NavClassic, I just finished testing NavBar and it was not the same as yours in this regard.

Have you already added any BuddyPress related CSS?

#3 CliffordP

CliffordP

    Advocate

  • Members


  • 456 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 24 November 2012 - 03:18 PM

1)
No special CSS.

2)
No special CSS.

3)
I'm familiar with that CSS, but I don't want that as a site-wide rule because then blog posts won't get bullet points.

4)
I switched from the WPMU DEV EduClean theme after using that for nearly 9 months and never had these loading issues, everything just worked. Then I switched to PageLines and saw those errors immediately. Thus, it's either the BuddyPress Template Pack or the PageLines theme or something that I already had installed that's messing with one of those 2.


With all plugins except BuddyPress, Template Pack, and PL Sections disabled (

Please Login or Register to see this Hidden Content

) -- and all custom CSS removed from PL settings and child theme -- and all widgets -- the nav had all those pages looking as ACTIVE still, even when I added BrandNav instead of Branding + NavBar (

Please Login or Register to see this Hidden Content

or

Please Login or Register to see this Hidden Content

).
And the forever loading circle issue was still there (

Please Login or Register to see this Hidden Content

).
I tested these with a totally fresh/cleared browser (cookies, cache).

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 25 November 2012 - 02:41 AM

I'm at a loss about your cryptic reply. Are you saying for items 1 and 2 that you refuse to apply css to fix the issue or suggesting something else?

For item 3, if you wish to play with that, feel free, but that is the solution.

As I point out in my reply, the same problem occurs in the WP default themes, thus it is not the PageLines integration which simply wraps Buddypress and does not convert or restyle it. That said, it must be the Template pack.

Again, the solution to most of your issues requires customized CSS solutions.

The menu issue stems from the majority of listed items somehow each having the same CSS, as if they're all the current page. I am not saying how that happened or why, only that it is the case. Additionally, I'm not suggesting you placed it there. That CSS could be generated by some plugin (which I suggested) or some other means, like a setting somewhere. In your screenshot

Please Login or Register to see this Hidden Content

the three plugins are active, not deactivated.

Given your testing and the continually spinning circle would indicate that this must be related to BuddyPress and a setting and thus I'll refer you to them for answers on that issue. On my own site, I do not have that problem and heaven knows I have tons of custom CSS and plugins. PageLines would not do anything to determine the status of a page as current, active and so on.

#5 CliffordP

CliffordP

    Advocate

  • Members


  • 456 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 25 November 2012 - 04:51 AM

I did not intend for the reply to be cryptic. I was saying I didn't have any CSS applied to those areas, at least nothing myself, maybe there was something in plugins.

I deactivated PL Sections and BP Template Pack as well.

The BP Template Pack activated was making the forever loading, but it still didn't fix the homepage "all active" issue. Do you have template pack enabled on your BP+PL setup without the forever loading issue?

#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 25 November 2012 - 01:10 PM

Yes, BP Template Pack is a critical, essential part of a successful BP installation and it causes no slowdown or problems with my site. See

Please Login or Register to see this Hidden Content



Its possible there's some setting you've missed or a plugin conflict... but I assure you, this isn't a PageLines integration or PageLines issue. Hence you should look through the BuddyPress forums for some solutions or their documentation for guidance.

Unfortunately, when we've identified that it's not a PL issue, I can't provide support for 3rd party products like Buddypress. I'm sure you understand and will find others in their forums experiencing similar issues.

#7 CliffordP

CliffordP

    Advocate

  • Members


  • 456 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 25 November 2012 - 04:44 PM

Thanks for sharing another PL + BP Template Pack site. I wish mine would work out of the box...

Not that you will use this information, but if it helps anyone else (or myself) referencing this in the future:
- I have WP 3.4.2, BP 1.6.1, and Template Pack 1.2.1
- adding this code got rid of the errant bullet points for the BuddyPress areas only:

Please Login or Register to see this Hidden Content

- I tried several things and couldn't get the forever loading issue resolved consistently. My temporary solution is to remove the Activity Stream checkbox from BuddyPress settings. I don't think it was being used much anyway. But the forever loading issue remains on the Group and Members pages.

Personally, I think PL should support the Template Pack and its issues because PL relies on it and because the plugin's support issues seem to be ignored (

Please Login or Register to see this Hidden Content

). That's not your issue in specific, but I think PL as a company should be more involved in it. It also states

Compatible up to: WordPress 3.3.1 / BuddyPress 1.5.4

and of course we should all keep up with the latest WP/BP versions for security and functionality and such. My 2 cents.


I guess my hope now is that the users don't experience the issues (at least not often -- sort of learn not to use them) and hope for a Template Pack and/or PL BuddyPress update -- just something that fixes these issues. Half giving up for now, more like postponing.
  • Erwan likes this

#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 25 November 2012 - 07:16 PM

Thanks for adding your two cents. :)

PageLines does evaluate and test the critical plugins and the Template Pack is one of them. While only a few BuddyPress users have had styling issues, they've been able to resolve them, as you have, with CSS. We can't get involved in the development of 3rd party plugins as you seem to be suggesting, but we do make sure our systems work with thousands of plugins.

Since you've resolved this issue, I'll resolve the topic.

#9 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 25 November 2012 - 07:16 PM

The topic was marked as resolved.





Also tagged with one or more of these keywords: Resolved, buddypress