• 0

Hfeed Warning: At Least One Field Must Be Set For Hatomentry


Question

Posted · Report post

I'm using PagelinesPro v1.53 on Wordpress 3.4.2. I am working on adding schemas / microdata to my site for SEO purposes, and have run into an issue. My website is [url="http://batonrougecounseling.net"]http://batonrougecounseling.net[/url] and when I use the google rich snippets structured data testing tool [url="http://www.google.com/webmasters/tools/richsnippets"]http://www.google.co...ls/richsnippets[/url] to view my pages, I get the following errors:

Warning: At least one field must be set for HatomEntry
Warning: Missing required field “entry-title”.
Warning: Missing required field “updated”.
Warning: Missing required hCard “author”.

This is apparently a common problem with other WP themes as well, and there have been some "fixes" floating around but they involve modifying some PHP files, which I am hesitant to do with PagelinesPro unless someone more knowledgeable can verify they actually work and fix the problem.

Here is one such fix I found: [url="http://www.ilmigo.com/fix-hfeed-warning-field-set-hatomentry.html"]www.ilmigo.com/fix-hfeed-warning-field-set-hatomentry.html[/url]

But, it involves modifying single.php and actually when I go into editor under PagelinesPro and open the single.php file, there is almost nothing in the file (not the lines of code the fix calls for).

Does anyone have a fix for this issue that is specifically compatible with PagelinesPro v1.53?

Many thanks in advance.

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Posted · Report post

Actually, Platform Pro is a legacy product now deprecated.  We came out with PageLines Framework in 2011.  Framework is a vast improvement over Platform Pro. Since we have very limited support for legacy products, you may want to consider upgrading.   Please consider too, that each time WordPress upgrades, they're updating things like jQuery, which may not work properly with the legacy products. 

 

An upgrade to Framework is pretty easy (I did it in less than 5 minutes) and we offer great support, improved documentation and many more resources for developing your site. If you want to upgrade, please write to hello@pagelines.com and the good folks in our business support team will help you as much as possible.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Todd,

Platform Pro will probably not receive any future updates, so I recommend you have a look through the template.postloop.php file and make the changes there.

If that does work, reply here and we can take a closer look.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Why wasn't this issue address in PL Platform 2?!  Obviously this was an issue in PL Pro so the PL folks should have been aware of the issue. I like the PL framework but documentation is HORRIBLY incomplete and dated. Time to get it together in this area. It is hurting your bottom line. 

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

I have the same problem, but I can't find the file template.postloop.php.

I've got several changes te make in the single.php of loop.php file (by http://fivera.net/hatom-feed-hatom-entry-error-wordpress-solution/)

 

Where can I change this?

I'm using the latest version of PageLines: 1.1.8

 

Many thanks in advance.

Edited by me.grund

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Could you create your own topic in the correct forum and we will take a look at this for you 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now