Jump to content


Photo
- - - - -
Open

Web Speed Optimised, But Lost Quickslider



  • Please log in to reply
3 replies to this topic

#1 pagerun

pagerun

    Advanced Member

  • Members
  • 42 posts

Posted 20 November 2012 - 01:20 PM

I have just enabled the browser cache by inserting the relevant code into htaccess. This increased the speed of my site.

But since I did that, the quickslider, doesn't appear about half the time that I load the page. - The rest of the page is fine, and loads, but when it doesn't show the quickslider, it says at the bottom "sending request.... "

Any thoughts on why?

Thanks

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 20 November 2012 - 08:08 PM

Could you explain how you 'enabled the browser cache" ? Do you mean a cache plugin?

It's possible that your page wasn't fully loaded when a cache locked in a view before the Quickslider images loaded. May we have a link to your site?

#3 pagerun

pagerun

    Advanced Member

  • Members
  • 42 posts

Posted 20 November 2012 - 11:04 PM

As I said I did this by inserting the relevant code into htaccess. (not using a plugin).
I added this code:

## EXPIRES CACHING ##
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access 1 year"
ExpiresByType image/jpeg "access 1 year"
ExpiresByType image/gif "access 1 year"
ExpiresByType image/png "access 1 year"
ExpiresByType text/css "access 1 month"
ExpiresByType application/pdf "access 1 month"
ExpiresByType text/x-javascript "access 1 month"
ExpiresByType application/x-shockwave-flash "access 1 month"
ExpiresByType image/x-icon "access 1 year"
ExpiresDefault "access 2 days"
</IfModule>
## EXPIRES CACHING ##


Any ideas on why adding this, sometimes prevents the loading of the quickslider?


Thanks

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 21 November 2012 - 09:17 PM

The key is, we know that caused the problem, so the smart thing to do would be to remove it and optimize your site in more effective means like MaxCDN and a cache plugin which is tested and known to work with WP and our products.